jcalvert

PTT (Delete) give continuous tone when pushed until released?

Recommended Posts

Just re-installed MCE after a gap of a few years . I'm having problems with the ATC! I tried assigning a PTT joystick button and it captured my button 9 and produced a continuous tone when pressed, which continued when released. I had to close FSX to get rid of the tone.

I re-installed MCE and made sure I did not attempt to set a joystick button but went instead for the DELETE key option.  However on pressing this I again get a continuous tone, which does stop when I release the key, but ATC hear nothing. There is no 'squelch' in out as described. Voice control with the co-pilot works OK in the short tests I have done.

Has anyone experienced similar and know a fix??

 

Thanks in anticipation

Jeff

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

13 hours ago, jcalvert said:

Just re-installed MCE after a gap of a few years . I'm having problems with the ATC! I tried assigning a PTT joystick button and it captured my button 9 and produced a continuous tone when pressed, which continued when released. I had to close FSX to get rid of the tone.

I re-installed MCE and made sure I did not attempt to set a joystick button but went instead for the DELETE key option.  However on pressing this I again get a continuous tone, which does stop when I release the key, but ATC hear nothing. There is no 'squelch' in out as described. Voice control with the co-pilot works OK in the short tests I have done.

Has anyone experienced similar and know a fix??

 

Thanks in anticipation

Jeff

The "squelch" sound has been removed. Should only get the continuous background humming sound while holding PTT which is normal.

As for joystick button, you may have one of those "ALWAYS ON" buttons which MCE is seeing as a PTT.

Here is the workaround.

 

Go to "General" tab in MCE UI and click <More options>

In "Advanced Options" panel, click <View config>

"mce.ini" config file will open in Notepad.

Scroll down to the [GAMEPAD] section.

Leave the joystick names as they are and just modify the "JoyButton"

[GAMEPAD]

JoyButton=set_a_digit_between_1_and_12_that_coresponds_to_the_joystick_button_number.

Save the file and restart MCE.

If setting is correct, you should only see MCE switch to ATC mode (and hear the humming sound), when you hold the correct joystick button down.

Eventually, try another digit

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now