Aaron Kim

Concorde X crashes when Windows Defender is on

Recommended Posts

Posted (edited)

Straight to the point. Concorde X crashes when Windows Defender is on. When I turn it off, Concorde works perfectly. But, after I updated Windows, I noticed that Concorde works only when Windows Defender is on. I get a "internal error, please contact author." error if Windows Defender is off. I excluded The FSL_ConcX.dll from windows Defender, and I also excluded the FlightsimLabs folder in ProgramFiles x86, AND I excluded the FSLabs folder in my main P3D folder. Also, I excluded the FSLabs_BAe-Concorde folder in SimObjects. BUT it still crashes if windows defender is on.

Edited by Aaron Kim

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

UPDATE: Now when I select Concorde, it shows this message no matter what!

Share this post


Link to post

A stab in the dark, but something that happend to me recently. Although my sim didnt crash, it was running nice and smooth with sudden dives in FPS down to 1.5 !

I opened Microsoft security essentials, whitch looks the same as Windows Defender (?), settings tab, then MAPS,

(Microsoft Actice Protection System). This was set to basic membership. I changed it to 'i dont want to participate'. Also as you've done, excluded the whole C:/FSX (P3D) file from being scanned. Its now back to normall smoothness.

 

As for installation location, ''Programe Files''....Now, ive been off the flightsim scene for 10 month or so, so things may have changed, but to my knowledge you should not install it in that location as the ''programe files'' are protected from ''write to file'', not allowing changes to those files.....even as admin.

Might also be worth checking your history / quarantined files to see if any Concorde X related files have been caught.

 

Share this post


Link to post

Hello Aaron

There is an Option in the Windows Defender control panel called  "Controlled folder access"  Is this option turned on ?

Its possible the latest Windows update has reset this option back to the default On position 

If so, Turn this Option Off,  Then launch Prepar3D and test 

Share this post


Link to post
12 hours ago, Poppet said:

If so, Turn this Option Off,  Then launch Prepar3D and test 

Actually, I already have this option off.

Share this post


Link to post
Posted (edited)

Just ran P3D today and tested if Concorde works.

UPDATE: Nope, nothing works.

This message pops up.

29595483_155665475260099_317662405674877

 

Edited by Aaron Kim

Share this post


Link to post
16 hours ago, MaDDogz said:

As for installation location, ''Programe Files''....Now, ive been off the flightsim scene for 10 month or so, so things may have changed, but to my knowledge you should not install it in that location as the ''programe files'' are protected from ''write to file'', not allowing changes to those files.....even as admin.

Well, i installed it in the ProgramFiles x86.

Share this post


Link to post

I uninstalled, rebooted, then ran P3D, but it STILL showed the message. I turned off windows defender, when installing, and I also excluded some files. But, you guessed it, it shows that message. :( UGH

Share this post


Link to post

UPDATE 2: You know how FsLabs says to fly the J3 Cub then load concorde? Well, I just loaded concorde straightly, and it WORKED!!!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now