Sign in to follow this  
Heathrow to Dublin

WAMA Fslabs and pmdg problem : not working

Recommended Posts

Posted (edited)

Just bought this.  The PMDGs and FSLabs A320 do not seem to work.  Cockpit making awful sounds in a320 when entering plane and no landing gear displayed on their models when leaving (a320 and 747).  Entering the PMDG 737 makes it go absolutely hawire with shaking.  It's as if an earthquake was shaking the plane.  You can enter it once, but if you leave and enter it again it goes bad.

Shame.  How do I get it to work?.  Disappointing.  .

 

Edited by Heathrow to Dublin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

Hi,

missing or non-functional 3D model features like gear or control surfaces are pretty common with complex aircraft. Because of this fact, and because loading complex 3D models puts an unnecessary strain on your simulator, you can (and should) replace the parked model with a more lightweight one (preferably an AI model), using the database editor. 

Selecting an aircraft: can't speak for the FSLabs, but I don't have any issues with selecting PMDG aircraft for flight. If I understand you correctly, then the aircraft starts shaking when you use the "Enter" button? What simulator are you on? Which entering mode do you use (default or instant)? What happens when you select it from the main drop down list and press "I want to fly this aircraft"? 

Generally speaking, loading complex aircraft must be handled with care - with WAMA and otherwise. For example, PMDG planes are running a custom boot sequence, where their programmatic components are initialized. I can imagine that interrupting that or switching to it from an unstable state will result in trouble. Personally, I don't jump in and out of those. I only select/enter an aircraft of that type if I mean it.

Requests for refund must be directed at the shop where you bought it.

Best regards

Edited by Lorby_SI

Share this post


Link to post
Share on other sites
Posted (edited)

Hello again,

Jumping: I have been testing this with the PMDG 737 now, and I see what you mean. The problem is, that this shaking is not an issue caused by WAMA. Even if WAMA is not running, when you are in the NGX, save that flight, then select another vehicle, and once that has loaded, use P3D to load the previously saved flight containing the NGX, then the same jumping happens. It even continues if I load another vehicle after that, that one is jumping too. I am using WAMA too, but I never noticed this. Probably due to the fact that I am not really jumping in and out of those aircraft a lot, I just select them from the list and fly. 

Looks like the NGX just doesn't like it when you switch to another aircraft and back again using saved flights. It works correctly though, if loading the NGX flight is your first action in the sim. 

As stated above, complex aircraft need to be handled with care. It is likely that when using aircraft with complex programmatic components, multiple uses of the Enter/Leave feature will lead to problems. The initialization sequences of those aircraft have to be left alone and do their thing, or bad consequences arise. And it seems that in case of the NGX, they should be run only once in certain usage scenarios.

What about the FSLabs - is it the same with that aircraft? Does loading/entering it work correctly if it is the first and only thing that you do?

If you are using P3D, please do also try the option to change aircraft "instantly" with the checkbox on the database editor dialog (halfway down on the right side of the window). This doesn't change anything for the NGX, but it might for FSL.

Best regards

Edited by Lorby_SI

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this