Sign in to follow this  
ZKOKQ

WMA Simconnect Error

Recommended Posts

Posted (edited)

Hi Oliver I am experiencing simconnect error wma on shut down of P3D V4.3. This started happening after upgrading.

Also, if I edit something in database, I get an unhandled exception when I hit "Close"

Would this be due to the new 4.3. I believe LM altered the handling of simconnect ?

Also after updating just the P3D client, my database in WMA was completely empty.

Any help woud be appreciated.

 

Julian

 

Edited by ZKOKQ

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Julian,

You mean the message "SimConnect Error - please restart WAMA"? That happens in other versions of P3D too. I am not sure yet if it has become more frequent in 4.3. The root cause is the fact that WAMA is compiled with the P3D V4.0 libraries. Otherwise I would have to compile a separate version for each point release, there are many people who are reluctant to update to a new version and are still using the old ones. This is especially common with commercial customers.

Sorry, but I can't reproduce the other issues. After upgrading to V4.3 yesterday, WAMA just continued working like nothing had happened. My database is intact and I have no errors in the database dialog. The only thing that I could imagine is that you inadvertendly deleted (or that something destroyed) the WAMA files folder in "C:\Users\...\Documents\WhereAreMyAircraft_P3D_V4 Files", where the database is saved. 

I can't troubleshoot any exceptions without seeing the stack trace. So I suggest that you send me your proof of purchase, the WAMA error log and the stack trace of the exception (button "details" on the error message window) to the email address that can be found on the last page of the user manual.

Best regards

Share this post


Link to post
Share on other sites
18 minutes ago, Lorby_SI said:

I can't troubleshoot any exceptions without seeing the stack trace. So I suggest that you send me your proof of purchase, the WAMA error log and the stack trace of the exception (button "details" on the error message window) to the email address that can be found on the last page of the user manual.

Many thanks Oliver, will send the log and purchase details if/when it happens again.

Yes the database being empty was a strange one. I should have backed it up, my bad 🙂

 

Be in touch

 

Julian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this