Jump to content


Beeping noise and autopilot won’t engage

Recommended Posts

Hi, when I request gsx they ask me to shut down my engines as usual. I do, but when they are off I hear a beeping noise (beep, beep, beep, beep), after a while it stops but when I turn my engines on again and takeoff. Then my autopilot won’t engage, what’s the problem and how can I fix it? Thanks.

Share this post

Link to post
Share on other sites
2 hours ago, Philipljung said:

Found out, I just had to turn on my apu before shutting down engines. Of course!

Make sure to fly the tutorial a couple times to either refresh your memory, or give you a solid foundation of knowledge.

The beeping is caused by not having a source of power to transition to (as you've found out), and the beeping is letting you know that you're going to drain the battery if you keep whatever you're doing up.

As far as not being able to engage the AP, that drop in power knocked things offline that you aren't setting back up properly, which would be covered by the tutorial.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...