imwaite

Cannot connect to XPlane 11

Recommended Posts

Cannot connect to xplane11. Tried many times. Reinstalled P2ATC - no difference. Very frustrating

X-Plane 11.26r2 (build 112601 64-bit)

XPUIPC Version 2.0.3.5 64 bit
XPWideFS Version 2.0.0.2 64 bit
X-Plane Version: 11260

Log file - shows tried to connect twice

Program StartedPilot 2 ATC (P2A) - version 2.5.0.5_x64_R3  10/14/2018 19:10:30
Application frmP2AMain starting 10/14/2018 19:11:00
Loading Form
Main form opened: Pilot2ATC 2018 v. 2.5.0.5_x64_R3      Navigraph - AIRAC cycle: 1811
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Loading Map Control
LoadMapControl: panel 1
Creating ucMap1
SQLiteVersion: 3.8.11.1 | 2015-07-29 20:00:57 cf538e2783e468bbc25e7cb2a9ee64d3e0e80b2f | INTEROP_CODEC INTEROP_EXTENSION_FUNCTIONS INTEROP_VIRTUAL_TABLE NET_40 PRELOAD_NATIVE_LIBRARY THROW_ON_DISPOSED TRACE TRACE_PRELOAD TRACE_SHARED TRACE_WARNING USE_PREPARE_V2 WINDOWS
ucMap1 Created
ucMap DockFill set.
Setting Map Mode
Done Loading Map Control
Loading FPL Control
FPL Control Loaded
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Joystick Device number 2 successfully activated.
Joystick Device number 0 successfully activated.
Joystick Device number 0 successfully activated.
Joystick Device number 2 successfully activated.
The SIM or FSUIPC/XPUIPC stopped functioning and P2A is Disconnected.
Error in frmP2AMain ConnectToSIM
System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'Timer'.
   at System.Timers.Timer.set_Enabled(Boolean value)
   at P2A_2018.P2ASimulatorFSUIPC.Init()
   at P2A_2018.frmP2AMain.f()
Simulator Disconnected. 10/14/2018 19:17:45
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Loading Joystick Devices - 5 devices loaded.
Joystick Device number 2 successfully activated.
Joystick Device number 0 successfully activated.
Joystick Device number 0 successfully activated.
Joystick Device number 2 successfully activated.
The SIM or FSUIPC/XPUIPC stopped functioning and P2A is Disconnected.
Error in frmP2AMain ConnectToSIM
System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'Timer'.
   at System.Timers.Timer.set_Enabled(Boolean value)
   at P2A_2018.P2ASimulatorFSUIPC.Init()
   at P2A_2018.frmP2AMain.f()
Application frmP2AMain ended normally 10/14/2018 19:18:36
Object of type SlimDX.DirectInput.Joystick was not disposed. Stack trace of object creation:
Object of type SlimDX.DirectInput.Joystick was not disposed. Stack trace of object creation:
Object of type SlimDX.DirectInput.Joystick was not disposed. Stack trace of object creation:
Object of type SlimDX.DirectInput.Joystick was not disposed. Stack trace of object creation:
Object of type SlimDX.DirectInput.Joystick was not disposed. Stack trace of object creation:
Object of type SlimDX.DirectInput.Joystick was not disposed. Stack trace of object creation:
Object of type SlimDX.DirectInput.Joystick was not disposed. Stack trace of object creation:
Object of type SlimDX.DirectInput.Joystick was not disposed. Stack trace of object creation:
Total of 8 objects still alive.
 

Edited by imwaite

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The log snippet would indicate that XPUIPC is not working correctly.  

Here is a link to a known working version of XPUIPC:

https://www.dropbox.com/s/yfanpmy2y3brzfz/XPUIPC and WPWideClient 2.0.0.0.zip?dl=0

After unzipping the downloaded zip file, copy ONLY the XPUIPC folder to the X-Plane plugins folder.

Then be sure XPUIPC is working by finding it in the X-Plane Plugins dropdown menu after starting X-Plane.

If that doesn't do it, here are some other things required to allow P2A to connect to the SIM:

1.    Make sure you are running the latest version (2.5.0.5R3 as of this writing)
2.    Be sure you are connected to the internet
3.    English-US Language installed and set as Primary Language
4.    Working Microphone installed and set as Default Sound Input device in Windows
5.    Valid Call Sign – Try using the default call sign of Mfg: Beech; Tail Number: N431VB.  Press the Save button.
6.    Try running the program in Administrator mode by right clicking on the Pilot2ATC.exe file and selecting “Run as Administrator”

Dave
 

 

Share this post


Link to post
Share on other sites

Thanks Dave, reinstalling XPUIPC worked a treat. Now fully working again. thanks.

Ian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now