Recommended Posts

Hello!

When I trie to reload the Database for P3Dv4.3 LNM is showing the window where it shows the progress but it stops working and not responding. I had this several times, the solution was to restart but this seems not to work anymore. I run LNM as Admin.

LNM is on latest version.

Thank you!

Edited by Rhinozherous

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Klaus,

a broken BGL or a bug in LNM.

Try to exclude all add-ons in the options dialog on tab "Scenery Database" first and check if that happens with the default scenery too. Simply exclude the whole "Addon Scenery" and/or all add-ons in other directories as a first step.

You can also have a look at the log file (C:\Users\YOURUSERNAME\AppData\Local\Temp\abarthel-little_navmap.log on Windows) and check which BGL was read last.

From the manual:

Quote

Crash while loading the scenery library database: You can exclude scenery directories in the Options dialog on the Scenery Library Database tab if loading of an add-on BGL causes the program to crash. Do not restart the program after it shows the crash dialog and instead load the log file which is typically C:\Users\YOURUSERNAME\AppData\Local\Temp\abarthel-little_navmap.log. The path may vary depending on your Windows installation. Search for the last line in the log-file that looks like:

[2016-10-14 22:58:21.903 default INFO ] unknown: ==== "404 of 521 (77 %)" "APX41080.bgl"

Now search for APX41080.bgl and exclude its directory from loading in the Options dialog.

Best,

Alex

Share this post


Link to post
Share on other sites
On 12/4/2018 at 11:00 PM, albar965 said:

Hi Klaus,

a broken BGL or a bug in LNM.

Try to exclude all add-ons in the options dialog on tab "Scenery Database" first and check if that happens with the default scenery too. Simply exclude the whole "Addon Scenery" and/or all add-ons in other directories as a first step.

You can also have a look at the log file (C:\Users\YOURUSERNAME\AppData\Local\Temp\abarthel-little_navmap.log on Windows) and check which BGL was read last.

From the manual:

Best,

Alex

Excluding didnt help, still crashing.

In the meantime I updated to 2.2.2 but the same problem appears.

Edited by Rhinozherous

Share this post


Link to post
Share on other sites

Never mind... I found the conflicting folder and excluded it, now it loads!

It was the Orbx FTX Vector folder.

Thank you!

Share this post


Link to post
Share on other sites

Can you try to send me the files by email which cause the crash?

If you don't know the exact folder you can send the me the whole excluded directory if not too big.

That would help me a big time.

Thanks in advance

Alex

 

Share this post


Link to post
Share on other sites

I excluded the whole "Prepa3Dv4/ORBX/FTX_VECTOR" folder. Unfortunately this one has several GB in size 😋 and I didnt know which file exactly created the crash.

But I also have a problem with the FTX Vector update currently... ORBX released an update a time ago and on my system it loads forever, so I wasnt able to complete the update so far. Maybe this update interferes with the database.

Share this post


Link to post
Share on other sites

OK. No hurry. Let me know if you find the offending bunch of BGLs.

LNM might show errors on loading but it should not CTD or otherwise blow up. I hate crashes.:mellow:

Alex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now