Jump to content

macwino

"Chart function unavailable" message in USA (resolved)

Recommended Posts

When I launch the RXP GTN 750 in P3D v4.4, I get a "Chart function unavailable" message. The startup screen also indicates that charts are unavailable. I am at a major US airport. I have tried both the Worldwide (Jeppesen) and North America (Garmin) databases in the Device Options pane and both give me this message. I thought that charts were available for North America - and I indeed have them with the older Garmin database used by the F1 unit. 

I re-downloaded and reinstalled  the Garmin Trainer installer for v6.50.1, chichis the one used by RXP,  but I still get the charts unavailable message. Is there something I need to do to activate the charts in North America? Or have I been mistaken about their availability?

Thanks,

Robert

Edited by RXP

Share this post


Link to post
Share on other sites

Hi Robert,

You might want to cross-check whether the chart you are looking for is included in the DB in two different ways:

  1. Open a file explorer to "C:\ProgramData\Garmin\Trainers\Databases\fc_tpc\CHARTS\". This is the default DB installation folder and you can see all individual charts file by ICAO names.
  2. Launch the Garmin trainer standalone and see whether you can access the chart you are looking for.

I'm wondering whether the Chart are unavailable because of 'expiration' date too. Can you change the simulator date to say June 2018, and make sure the GTN device settings use 'Simulator Time' instead of 'Computer Time' to cross-check?

Share this post


Link to post
Share on other sites

Hi J-P,

I wasn't as clear as I should have been when I posted early this morning. The problem doesn't involve a specific airport or chart. It is a global problem  - "global" meaning all of North America which is where I understand charts ought to be available. Thus the startup screen indicates in yellow text "Charts Not Available" and I get a message alert to this same effect on final launch of the 750.

Nonetheless, I ran the tests you suggested. The individual charts are in the folder you indicated, including the charts for the dozen or so airports I tested. The standalone Trainer displays the charts. And changing the sim date to June 1, 2018 doesn't alleviate the problem.

I also checked and confirmed that the problem exists for planes which have no GTN, such as the default Mooney Bravo, where I added the RXP GTN as a popup. And it also exists for those planes where I used the RXP tool (which is amazing) to substitute the RXP GTN for the F1 GTN. This includes planes by A2A and Carenado.

The only step I can think of that I haven't yet tried is to uninstall and reinstall the RXP 750 and 650.

Thanks for your assistance.

Robert

Share this post


Link to post
Share on other sites

Hi J-P,

I just wanted to let you know that I uninstalled and reinstalled the RXP 650 and 750 and it made no difference. I still get a Charts Not Available message on the opening Database screen.

Robert

Share this post


Link to post
Share on other sites

Hi,

This is peculiar. Let's check it is not trying to read the database from your older trainer you've still installed.

Can you confirm the AIRAC dates displayed when ran in FltSim (not standalone but our gauges) is displaying the 1803 cycle?

Otherwise, this means the newer trainer is somehow using the older trainer 6.21 database files, therefore, it won't find the charts because in the older trainer these are 'packed' in a virtual drive file (a .ISO in disguise - 'card' ), whereas the newer trainer charts are files in a folder.

What affects the trainer regarding the 'database' path is two fold:

  1. You are using the RXP environment variables to redirect/override the paths.
  2. There was a problem during installation with the Garmin trainer registry key

Here are the keys to check the paths for:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Garmin\Trainers]
"DataPath"="C:\\ProgramData\\Garmin\\Trainers\\"
"BinPath"="C:\\Program Files (x86)\\Garmin\\Trainers\\"
"DBDataPath"="C:\\ProgramData\\Garmin\\Trainers\\Databases\\"

 

Share this post


Link to post
Share on other sites

Hi  J-P,

The RXP 750 is using the 1802 database, which I added long ago for use with the F1 GTN, not the 1803 database used by the RXP unit.

Also, in the Registry, the first two paths are there and correct. And there's also a third entry at the top for "(Default)" with "(value not set)." 

However, the third path you mention - the one for  "DBDataPath"="C:\\ProgramData\\Garmin\\Trainers\\Databases\\" -  is not there at all.

So I suppose I need to add this path and perhaps that might fix the problem. If so, do I go to Edit>New and select one of the options  in the list and enter the missing text in the Data field? I need your help here if that is the fix so I don't mess things up any further.

Thanks,

Robert

 

Share this post


Link to post
Share on other sites

I think this will work:

  1. Open notepad.exe.
  2. Copy/paste the following verbatim.
  3. Save as "fix_gtn_db.reg"  (not .txt, but .reg)
    NB: if not possible with notepad, just save as .txt then manually rename afterward to .reg)
     
  4. Double click the .reg file, this shall update the registry.

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Garmin\Trainers]
"DBDataPath"="C:\\ProgramData\\Garmin\\Trainers\\Databases\\"

 

More in-depth information may be found here:
https://support.microsoft.com/en-ca/help/310516/how-to-add-modify-or-delete-registry-subkeys-and-values-by-using-a-reg

 

Edited by RXP

Share this post


Link to post
Share on other sites

I'm glad you got it sorted out. This won't explain why the Garmin trainer has failed to create the registry entry in the first place, but at least, it is working now and will certainly help other customers using the forum search function in the future!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...