Dscho

Weird behavior of rudder pedals at takeoff run

Recommended Posts

Posted (edited)

Hello Mooney pilots,

bought recently the M20 Ovation and have serious problems with keeping the aircraft straight on taxiway or runway. I am aware of p-factor, propwash and torque of the engine etc. At low speeds situation is somewhat manageable, but at higher speed during the takeoff run it is almost uncontrollable: the aircraft veers to the left (caused by p-factor etc.) then I apply right rudder: no reaction, the a/c still veers leftwards, applying more right rudder, again no reaction, more right rudder then suddenly the aircraft turns VERY sharply to the right, then kicking fully down the left pedal has absolutely no effect, the aircraft goes wildly the right only after a while the aircraft starts to turn back. It looks like that there is a (too long) time lag between a control input and the reaction of the flight model. First I thought, that the null zone of the rudder is the culprit, but narrowing the null zone to 5, showed no effect. And yes, of course I have calibrated all control axes. My questions to you Mooney pilots are:

1 Did you experience the same behavior?

2. Did I miss a particular setting? ( I am with P3D v4.4)

Experiences and comments are highly appreciated - thank you,

Dscho

 

Edited by Dscho
typo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

many thanks Tim - although my prob looks a bit different, i will give it a try!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now