Resolving Micro Stuttering (Some Suggestions)

Recommended Posts

Posted (edited)


I can confirm the driver solution can and often does work.

I too experienced micro stutters after updating to v4.4. These were particularly annoying as they were occurring regularly every 3 secs which, for me, effectively destroyed any immersion. Before starting a flight I noticed their presence by switching to slew mode and then started a slow pan through 360 degrees. These barely discernible hesitations at exactly 3 sec intervals were then evident.

Much of this has been covered before, but I thought it might be helpful to outline my own experiences. Please feel free to add your own solutions.

The solution:

1. Graphic Driver updated to latest set using the ‘Clean install’ route provided by GeForce Experience (haven’t used DDU in a while, but this is a perfectly valid, arguably more effective, alternative way to achieve that clean install). The only driver components I select for installation/updating are the driver itself and PhysX, if needed.

While it is now possible to carry on without having to reboot following a graphic drive installation/update, it is still a good idea to do so. Also, many a time I have resolved irksome performance issues in Prepar3D by simply restarting the operating system.

2. Delete the Shaders folder content (NOT ShadersHLSL in P3D root). This should always be done following a graphic driver update. Yes, the shader cache will have to be rebuilt by P3D, and this takes a little time, but it’s worth it. It’s handy to create a desktop shortcut to this folder. I would suggest that this is considered each and every time there is a significant product changes to a texture set like, for example, clouds. This will keep the shader cache content current without any redundancy.

3. Delete the SceneryIndexes_x64 folder content. This is probably unnecessary but it’s easy to do, ensures a well organised index, and is rebuilt quickly at next run. I do it quite frequently and always after making any changes to Scenery.cfg, whether this be manually or via the sim’s GUI. Again, it’s helpful to create a desktop shortcut to this folder.

4. Very rarely have I needed to delete Prepar3D.cfg but, if all else fails then this can be tried. Just be sure to backup this file first as it is needed for reference when re-establishing any settings or tweaks that may have been applied by the sim or manually by you.

Unfortunately, microstuttering can have many causes. One other suggestion would be to ensure your antivirus product, if active while simming, is configured to exclude the Lockheed Martin\Prepar3D v4 folder and any Prepar3D related products that might also be active during a simming session. I use ESET NOD32, have done so for years, and this has minimal, if any, performance impact on anything I do in Windows 7 and 10.



Edited by Cruachan
  • Like 1
  • Upvote 2

Share this post

Link to post
Help AVSIM continue to serve you!
Please donate today!

For me with 4.4 what got rid of the microstuttering was to disable Hyperthreading.

That is different than 4.3 which was smoother with HT on, with my system.

Of course that is all very-system dependent as was discussed in the other recent thread.  Your suggestions are very good across all hardware configs.

Share this post

Link to post


This evening, while troubleshooting some panel clarity issues affecting my Vertx DA62 I experienced the unwelcome return of those micro stutters, as described in my original post.

Rebuilding the sim's shaders followed by a quick system restart resolved it. In this instance, recompiling the shaders may not have been strictly necessary. A system restart, however, often works wonders and is certainly worth a try before attempting anything else.


Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now