svenks

"Acknowledge" missing...

Recommended Posts

Hi All

I have managed to get RCv4 and P3Dv4 to play along rather nicely, thanks to the various posts in this forum. But I do have 1 strange little item:

I have actually made 2 installations of RCv4, one WideFS based and one directly on my Gamer PC. I would rather use the WideFS one, as I really don't want too much stuff on my gaming PC.

And it does work OK, except the the "Acknowledge" menu point is missing when I use WideFS. This is annoying, as it often is the only clue you have saying "You may have missed something". Even stranger,

the ACK key combination (CTRL-7 for me) still works, even if the prompt is not there.

When I use the non-WideFS installation, all prompts are there...

ANy ideas, anyone?

BRGDS

Sven Sorensen, EKCH  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sven, strange problem. What are you using on the WideFS PC for RC. ShowText?

 

Share this post


Link to post
Share on other sites

Hi Ray

Thanks for taking time to look into this.

Further testing have shown me that the missing prompt DOES in fact appear - but it takes forever to appear!

My setup is this: RCv4 options: Displaytext ON, FSuipc: Multi-line Window ON, and hide all single line messages=true.

Then Showtext diplays the RCv4 text and FSUIPC5's builtin simconnect message window show the menu prompts.

However, if I do use Displaytext on the WideFS setup, RCv4 seems to wait for a long time for some event to occur.

Why this only happens in WideFS and not with a local RCv4 setup, I don't know.

Too bad, if I have to drop the DisplayText setting. As English is not my first language, I could easily get some numbers wrong.

If, you have any ideas, please let me hear them!

BRGDS

Sven

Share this post


Link to post
Share on other sites

Sven,

What's this DisplayText thing you refer to? Do you mean ShowText?

I've turned off my computers for the night but will check my settings tomorrow.

I have no problem running RC4 across a network and button presses are acknowledged immediately. You probably have something configured wrong. You don't need to have any windows for RC / Simconnect showing on the FS computer.

How are the two computers connected? Ethernet or wi-fi? Does the WideClient log or wideserver log show anything unusual?

Share this post


Link to post
Share on other sites

Sven,

You need to turn off the Display Text option in General. All should be okay after that.

JD included this in this locked topic years ago...

 

Share this post


Link to post
Share on other sites

Hi Ray

I see you did find out what I meant by DisplayText option 🙂

My experience is the same. With DisplayText OFF, the problem goes away.

However, as I said: Turning that option OFF, means that I wont have any means (except for "say again") for verifying what was said.

It has happened more than once that I've missed the last digit of the squawk code, and pressed ACK before I realized it was wrong = no "Say Again".

Oh, well. I will try to boost performance on the RCv4 PC (a virtual machine) and see if that might help, but I have no indications that the VM in question has any kind of ressource trouble.

I take it, that you don't use DisplayText ON?

BRGDS

Sven

Share this post


Link to post
Share on other sites

Hi Sven,

No, I don't have Display Text on. JD specifically says not to use it if responses are slow.

I suspect your virtual PC might be the reason. Do you have access to another old PC or laptop? RC requires very few resources. I don't know of anyone that has run RC4 / WideFS on a Virtual machine. Maybe you could ask Pete Dowson if there are any known problems running WideFS on such a system.

Share this post


Link to post
Share on other sites

I have been running this setup for years, without RC4 though. I have AS16, FSC and PFPX there as well, and never had performance issues at all.

That is why I also suspect that giving more ressources to the VM will not help  - and it didn't.

I am flying as we speak, and right now I had the problem, where I misheard FL 340 for 240.

Well, I can always go back to RCv4 on the FS pc. That will give me the option of seeing the text.

Thanks for you help,

BRGDS Sven

Share this post


Link to post
Share on other sites

Sven,

Can you show me a screenshot of what you're seeing on the virtual PC?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now