jeffhunter

n00b question - can't pan with hat switch

Recommended Posts

Hi,

Today I finally ditched EZCA2 and bought Chaseplane, however I cannot set the hat switch on my joystick (T16000M) to tilt or pan in CP preferences, and I cannot tilt/pan - full stop.

I don't seem to be able to post a screenshot.

I'm running P3D 4.4 on a Win 10 build 1809 PC.

I uninstalled EZCA before installing, and noted that during the CP install, it detected some vestigial remnants of EZCA and (presumably) deleted them.

If I try to set the hat switch to tilt or pan, when I move the switch, CP does not detect it. I can set any other axis to tilt or pan, but not the hat switch. This happens whether I have the View (Pan) set to "Hatch switch 1" in P3D settings or not, and also whether I've got the input set to Raw or DirectInput. I note that someone else found that they had to move their joystick (saitek) before moving the hat to set it, but if I do that, it just sets the joystick X or Y axis as the tilt/pan...

I don't have any joystick assignments set in FSUIPC, either.

Weirdly, if I use named assignments, CP recognises my hat switch, but not the named assignment: ie, if I input "tilt up" the dialog says "affecting 0 presets"...

Any ideas? I've searched the forum and elsewhere with no luck.

 

 

thanks,

jeff

Edited by jeffhunter

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now