mcphatty

GTN650 Pilot Stored Data Lost (resolved)

Recommended Posts

I'm having some trouble with the GTN650, and it seems to have started at or around the time of the latest update. On the GTN650 if I select the flight plan page (but only by clicking the current flight plan from the default NAV page. Going directly to flight plan from the home page does not cause this issue) or display the map, immediately I get a message saying "Pilot stored data was lost. Recheck settings." From what I can tell, no data is actually lost, and previous user settings seem to be intact.

This seems to happen every time I follow those procedures. I've tried reinstalling the GTN, tried applying the latest update, and tried multiple aircraft with no fix in sight. I also have the GTN750, and does not seem to be having this problem.

Any help is greatly appreciated!

/mp

Edited by mcphatty
clarification, typos

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

It is possible this is induced by a hidden bug with the AFMS settings with cascading effects. I've just mentioned this in other discussions and we've just found out about this too. Nevertheless, configuration is stored in the GTN non volatile memory file and it may get corrupted sometime. You might want to review the RXP GTN User's Manual 'non volatile memory' chapter for file names and see how it goes letting the GTN creates a brand new one from scratch (make sure to backup the existing one should you want to revert).

Share this post


Link to post
Share on other sites

Thanks! That did the trick, everything seems to be working as expected now.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now