sntman124

Just Flight aircraft not installing

Recommended Posts

I recently obtained a new computer (Intel i5 8600k) running Win 10 and successfully installed FS9 along with a number of add-on aircraft.  However when I try to install JF Airbus collection and JF Concorde Professional from the original discs the set up goes as far as the Install Shield box then disappears off the screen   and likewise from the Apps list in Task Manager.  I tried making the installer run in Win XP compatibility but it still will not work.

Does anyone please have any idea what might be causing this.

                                                                                                  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Couple guesses since it is a new setup you have.

Could be windows firewall anti-virus blocking the installer.

In which case you have to make an exception by going to; Action center/Windows update/Windows security/Virus and threat protection scroll down to virus and threat protection settings and click manage settings/scroll down to exclusions and click add or remove exclusions once there you can add an exclusion for your just flight installer.

2. Further there is also another exclusion by clicking control panel/ then windows defender firewall at the top left is a link Allow an app or feature through windows defender click on that and then aboev the box of apps is a link to change settings click that then you can add your app.

3. What I had to do was make sure to install FS9 on a different drive than the operating system was on Drive D -never on Drive C;Program Files (86)

I also had to take ownership of FS9 exe. But that may not be your cause if you see no permission issue. It just crashes blank to desktop.

If you have a third party firewall as I have like Zone Alarm they can lock the hosts file and it stays locked even if you shut it down and your installer will not be able to connect to Just Flight.

There is a setting at least in Zone Alarm in advanced firewall settings to uncheck the box next to Lock the hosts file.

I worked for two weeks trying to install FSDevelopers plane beechcraft v35 and the bendix radios and all the time it was the ZA setting once that was unticked it all installed like without a glitch.

This is all I have to say for now as I do not have more info and these are just my experiences in the frustration of trying to install programs that windows or a firewall doesn't explain to you what it does secretly to block things that you want.

Another thing Would be to download from Just flight your latest installer for your product.

Mine are all under my account because you have a new computer do not try to install from an old exe file down load a fresh installer from Just Flight. Could be their server thinks someone else is trying to install who is not you.

Regards,

Peter

Share this post


Link to post
Share on other sites

I recently had trouble with a Just Flight add-on too (the PSS 757), and from reviewing their support site, it does appear that firewalls are often the culprit.  I'd open a support ticket with them and see if they can help.

Share this post


Link to post
Share on other sites

Thanks for your replies.  I am a bit of a dinosaur when it comes to understanding computers and hate having to mess around with settings like firewalls etc.  I did install FS9 on my D drive and have McAfee installed and leave it to handle all the security on my machine.  I decided just now to take the simple route.  I fired up my old computer plugged in a USB HDD and copied all the installed JF files from the Aircraft and Gauges folders in my previous FS9 installation across to the new machine.  They obviously don't show up as installed progs in Control Panel but who cares - they work which is all I ask.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now