RXP

Autopilot Coupling Reports Discussion

Recommended Posts

Hi,

there is too much clutter in the various discussions and too many parameters to make sense of what is actually failing or not.

I'm therefore creating this discussion with a procedure so that we can gather information on the same grounds.

Let's put this to practice with a quick pattern you can fly in a few minutes.

Please report only if there is a problem with your system flying this pattern.

  1. Start with the Baron 58 at KVPS RWY19
  2. Select the procedure KPVS | RNAV 01 with transition: YOUNK.
  3. Preselect 2500 ft on the A/P
  4. Takeoff, positive climb, gear up, arm autopilot NAV + ALT modes
  5. Set simulator time acceleration to x4 (menu Options | Simulation Rate)
  6. Note how well it tracks with time acceleration, another time try x128 too!
  7. Before YOUNK, set time acceleration back to x1

Now depending:

  1. GPS Selected Auto / Engage APPR Enabled:
    right in the middle of the turn to ELISS, the APPR mode arm, the ALT stays, once G/S crosses it starts descending.
     
  2. GPS Selected Auto / Engage APPR disabled:
    right after the turn to ELISS when the G/S is live, press the APPR button on the autopilot. Once G/S crosses it starts descending.
     
  3. GPS Selected Manual:
    right after the turn MSG flashes, tells you to use PROC before APPR. Press the PROC button, enable the A/P APPR output, then press the APPR button on the autopilot.

NB: this works equally well in FltSim.


Once validated on your simulator, can you please fly this pattern again this time using the aircraft which is failing on you (lately there are reports about the Carenado Saab 340, Citation II and PC-12 causing problems with some of you).

Thank you for helping finding out whether there is a new XP11.31+ bug or something else with our plugin.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Jean-Luc,

So I just finished some testing.  I started with the Baron 58 as you stated and it had the following GTN750 settings plus .  Here are the main settings from the ini file...i did not include the window specific settings as they should not be relevant for this:

[GTN_750_1]
; comma separated list of render targets.
drawto = WINDOW, PANEL3D
; is the master device if true.
MasterDevice = true
LinkSimGps = true
; aviation db: 0: nav_db2_grm, 1: nav_db2, 2: nav_heli_db2_grmn, 3: nav_heli_db2
NavDbType = 1
VoicePref = MALE

 

I did everything as you stated.  I had NAV and APPR enabled after taking off.  The only thing that happened differently from what you have above is that I did not intercept the G/S until i turned at ELISS heading towards TYLUR.  After I passed ELISS the GTN went from TERM to LNAV+V moded and once I got to the TOD point on the map I intercepted the G/S and everything proceeded as expected down to the runway.

I then loaded up the Carenado S340.  I went through the same steps but when I engaged NAV mode nothing happened.  I then toggled Master Device off and back on and then NAV kicked in and everything went just as the Baron did.  But then I started thinking that I might have some different GTN750 settings than what the Baron has due to all the testing, etc over the last 2 weeks.  So I then went to the .ini file for the S340 as well as the Citation and made sure they were set exactly like the Baron.  Once I did that everything worked exactly like the Baron for both the S340 and Citation.  I exited and restarted the sim between each flight so that it was a fresh start and the planes were cold and dark.  So if anyone is having issues I would suggest that make sure the settings are like I have above and see if that works.

 

GregR

  • Like 1

Share this post


Link to post
Share on other sites

@ibgregr Thank you for the detailed test report.

Comparing the original settings and the ones you've flown with, the only difference I could spot is the original has the following in addition:

LinkCrs = true
LinkObs = true
LinkVor = true

I'm wondering if you try adding LinkVor = true and fly test again, then if you add LinkCrs and LinkObs and compare again.
 

Share this post


Link to post
Share on other sites

Ok..just completed the tests you asked for above.  Not sure why I had issues yesterday but I'm not sure what other settings I may have had in the GTN.  But with the settings below everything is working as expected without doing anything special.  I start cold and dark in the Carenado S340 and the flight goes exactly as expected.  I tried multiple times by exiting the sim completely and then starting up with a cold and dark cockpit in the S340.

 

[GTN]
; comma separated list of gauges
gauges = GTN_750_1

[GTN_750_1]
; comma separated list of render targets.
drawto = WINDOW, PANEL3D
; is the master device if true.
MasterDevice = true
LinkSimGps = true
; aviation db: 0: nav_db2_grm, 1: nav_db2, 2: nav_heli_db2_grmn, 3: nav_heli_db2
NavDbType = 1
VoicePref = MALE
LinkVor = true
LinkCrs = true
LinkObs = true

Share this post


Link to post
Share on other sites

And this is exactly the default Saab 340 settings if I'm not mistaken (the settings included with the aircraft and installed by default). Which is rather puzzling isn't it?

Share this post


Link to post
Share on other sites

Later today or maybe tomorrow I will just delete the .ini file and let it recreate it to see what happens.  That way we know for sure it is totally stock config.

Share this post


Link to post
Share on other sites

This morning I did a couple of tests.  First I just deleted the S340 GTN .ini file and let it get recreated on its own.  This did NOT work well at all.  I could not get NAV mode to work at all.  I toggled the Master Device setting and it had no affect.  I then went and got the default .ini file that was in the S340 zip file and the test flight with that one worked just as expected.  These are the default GTN settings that come with the S340:

 

[GTN]
; comma separated list of gauges
gauges = GTN_750_1

[GTN_750_1]
; comma separated list of render targets.
drawto = WINDOW, PANEL3D
; is the master device if true.
MasterDevice = true
LinkCrs = true
LinkObs = true
LinkVor = true
LinkSimGps = true
FuelType = JETA
OwnshipIcon = BUSINESS_JET
; aviation db: 0: nav_db2_grm, 1: nav_db2, 2: nav_heli_db2_grmn, 3: nav_heli_db2
NavDbType = 1
VoicePref = MALE

Share this post


Link to post
Share on other sites
On 3/17/2019 at 10:14 AM, ibgregr said:

LinkSimGps = true

This is the key to all this only because this aircraft uses the default FMS in the cockpit too. When having the default FMS in the cockpit XPlane 11 shuts down a whole series of 'overrides' which used to work before. 

Also a quick update I've also posted in a similar discussion in the GNS V2 FltSim forum: I may have found out what is causing this and I'm doing my best to have a test build today or tomorrow to try. There was definitely a cross-over of code between our XPlane and FltSim version which is impairing each in a certain way. This plus some idiosyncrasies in each platform autopilot implementation which cannot be 'just abstracted out' as we've done.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now