portanav

Addon Manager Check config files error

Recommended Posts

Why when I run the "Check config file encoding" in "Tools" do I get this error? The program and P3D4 works perfectly, but if I run this check item in "Tools", this is what comes up.

?Lorby-Manager.png

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

This file should have character encoding UTF-16 (UCS-2 LE BOM in Notepad++) and in your case it doesn't. This does not mean that the simulator won't work, the message is just telling you that something messed with this file that didn't know what it was doing. And it tells you this because editing files using an incorrect character encoding will ultimately destroy them.

Especially the add-ons.cfg's should never be edited, altered or written to - both these files are under control of the simulator. The only acceptable access to these files is either with the CLI or by creating an auto discovery package.

Learning Center -> Software Development Kit (SDK) -> Add-ons -> Add-on Packages -> "Distributing an Add-on Package"

Best regards

Edited by Lorby_SI

Share this post


Link to post
Share on other sites

Thanks Oliver.

The thing is I have never edited the file, and all add-ons are done either through the Lorby Add-on Manager, of the scenery program itself.

Share this post


Link to post
Share on other sites
32 minutes ago, portanav said:

Thanks Oliver.

The thing is I have never edited the file, and all add-ons are done either through the Lorby Add-on Manager, of the scenery program itself. 

Well, something did. I have seen installers change that file, although they shouldn't.

As long as your simulator works, it doesn't matter. In any case, you could just delete this file too, it is rewritten every time you start the simulator. (but only the one in AppData\Roaming, not the file with the same name in ProgramData\). Things will probably change yet again in P3D 4.5, if LM really fixes the problem with the addons being controlled by the wrong file, that is present in 4.4.

Best regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now