Sign in to follow this  
newtie

Duplicate airport entries

Recommended Posts

Hi Oliver-

Just installed FSDT KLAX and got this...

https://ln.sync.com/dl/bd378e030/9hzkffkb-es8fkkij-v9fqmvec-gvmc8v4j

What caused the duplication and how do I fix it?

 

Thanks,

Mark

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Mark,

sorry, no idea. Are the paths for both entries the same and are they in the same add-on.xml? Then I would just remove one.

Did you have that scenery before and was it reinstalled or was this the first time?

Best regards 

Share this post


Link to post
Share on other sites
11 minutes ago, Lorby_SI said:

Hello Mark,

sorry, no idea. Are the paths for both entries the same and are they in the same add-on.xml? Then I would just remove one.

Did you have that scenery before and was it reinstalled or was this the first time?

Best regards 

In the Addon Manager, these two entries are located on different layers, 142 and 140.

In C:\Users\Mark Jones\Documents\Prepar3D v4 Add-ons\FsDreamTeam KLAX_V2 it looks like this...

<SimBase.Document Type="AddOnXml" version="4,0" id="add-on">
  <AddOn.Name>FsDreamTeam KLAX_V2</AddOn.Name>
  <AddOn.Description>FsDreamTeam Los Angeles International Airport scenery</AddOn.Description>
  <AddOn.Component>
    <Name>FsDreamTeam Los Angeles</Name>
    <Category>Scenery</Category>
    <Path>C:\Program Files (x86)\Addon Manager\FsDreamTeam\KLAX_V2\Scenery</Path>
  </AddOn.Component>
</SimBase.Document>

In C:\ProgramData\Lockheed Martin\Prepar3D v4\scenery cfg my layers stop at 135.

So there you have it :>) I too have no idea!

https://ln.sync.com/dl/29bdf9cc0/7i7afjae-imbghdcs-ag7yw4f6-7wj3jeqx

 

Share this post


Link to post
Share on other sites

Hi,

there must be another add-on.xml, referencing the same scenery. P4AO has a feature to search for duplicates and possibly eliminate them, not sure if that helps though.

If you want, create a backup zip with P4AO and send it to me. Email address is on the last page of the manual. But it will have to wait until tomorrow night.

Best regards

Share this post


Link to post
Share on other sites

Hi Oliver

There are no other .xmls that contain or reference KLAX; searched my entire system. However, I did find an add-on.cfg that references KLAX.

ANYway, ran the remove duplicates and that did it. I've used your Addon Manager for quite some time and have never seen this happen so I thought I would run it by you.

Thanks for the help,

Mark

Share this post


Link to post
Share on other sites
7 hours ago, newtie said:

Hi Oliver

There are no other .xmls that contain or reference KLAX; searched my entire system. However, I did find an add-on.cfg that references KLAX.

ANYway, ran the remove duplicates and that did it. I've used your Addon Manager for quite some time and have never seen this happen so I thought I would run it by you.

Thanks for the help,

Mark

So there was a duplicate package reference in add-ons-cfg? Curious.

I don't think that a duplicate like that would cause much of a problem in the simulator, but better be safe than sorry.

Best regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this