Captain_Biscuit

No effects and can't open Immersion Manager

Recommended Posts

Hi.

I purchased and installed the 747 immersion package yesterday. Initially it seemed to be working. I could open the immersion manager and preview the effects. Didn't have time to try an actual flight until today.

I fired up my P3D V4.4 this morning to start a flight got to 36000ft and saw that no effects were visible. I tried to open the immersion manager from the program files folder and I didn't open.

So I decided to uninstall it from the VFZ central manager. Did a reinstall and tried again. Still the same problem, I get the message to enable the effects manager, I enable it, load up the 747-400 and try again to open the immersion manager, but it won't open. Only difference is this time I get a pop up message saying "The immersion manager was updated. please restart your simulator to see your aircraft's visual effects properly". Tried that but the same thing happens, same message pops up every time I try to open the immersion manager.

 

Also just to note, I am opening my P3D as administrator as was instructed and have disabled my antivirus and firewalls in an attempt to get it working.

Any help with this would be greatly appreciated.

Thanks,

Craig.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

I have same problem after windows 10 1903 update.

 

Thanks.

Jaecheol

Share this post


Link to post
Share on other sites

Thank you for reporting the issue! We have released a fix, simply run it one more time and it will update to the latest version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now