P3D crashes after choosing an airport

Recommended Posts

So, I just got a brand new PC. Did a fresh install of windows and Prepar3D. Everything fresh. I started installing all the addons and then when I tried to choose an airport and not the default one it crashed. I of course tried other airports and not just one. The default one works perfect. I'm running the latest windows and the latest Prepar3D version. I'm starting P3D as administrator. I'll put a screenshot what it says in the event viewer.

Please if you have any idea what it could be let me know. 



Share this post

Link to post
Help AVSIM continue to serve you!
Please donate today!

May we ask what airport you were trying to load other than the default?  Make sure the airport addon is compatible with your version of P3D.  You might want to reinstall the airport using Admin Privileges.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now