Jump to content

Sign in to follow this  
cleipelt

GTN 750 Extremely Laggy on new PC

Recommended Posts

I just finishing building a new PC and installed a fresh copy of XP11 with the Carenado Citation II. I bought the GTN 750 and installed it just fine, but I’m getting very bad lag (with and without pop up screen) even though I’m getting 70+ FPS and no lag in the sim. I haven’t tried using the 750 with any other aircraft because the Citation is the only add on I have installed, but I don’t think this is normal. Any tips?

Share this post


Link to post
Share on other sites

There is already a topic about this.

 

 


Hans Schmitz

Share this post


Link to post
Share on other sites
Posted (edited)

I saw that, but wasn’t sure if it was related since I am using a different simulator. I’ll read through it again. 

Edit: And unfortunately, after reading through that thread I don’t understand half the things that are being mentioned. This is my first PC build and first time ever using Windows, so I’m very new to everything on this side of the computer spectrum. 

Edited by cleipelt

Share this post


Link to post
Share on other sites

No worries. We are all here to help each other. The Flightsim world is very complex and there are so many variables one can get lost easily. 

Regarding the GTN, there is always the base trainer from Garmin no matter which platform or GTN product you use. This trainer is differently addressed by the available two GTN products. Thus, the results can vary substantially. 

On X-Plane with the RXP GTN you have a good chance of bypassing some current issues with the latest Win 2004 build. However, if you have issues have a look at the knowledge base this forum is. PM me as well if you think I can help. 

  • Like 2

Hans Schmitz

Share this post


Link to post
Share on other sites
2 hours ago, hjsmuc said:

This trainer is differently addressed by the available two GTN products.

The Garmin GTN trainer is used in the background with both the RXP plugin (XPlane) and add-on (FltSim) the same way.

For this part of the solution there is no difference between the two GTN products (XPlane and FltSim).

@cleipelt

We'll need more information, starting with the content of the RXP log files (see RXP User's Manual for file/path)


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
Posted (edited)

rxpGTN.xpl.log

20/05/15 02:26:19.278 16680 -    ] # win.xpl version 2.5.25.0
20/05/15 02:26:19.278 16680 INFO ] 
 

rxpGtnSim.dll.log

20/05/15 02:26:21.061 16680 -    ] # rxpGtnSim64.dll version 2.5.25.0
20/05/15 02:26:21.061 16680 INFO ] 
20/05/15 02:27:45.821 16680 INFO ] GTN 750.1 - TRAINER 6623

 

Got these from the documents folder... seems pretty empty but hopefully it's what you're looking for. 
 

Edited by cleipelt

Share this post


Link to post
Share on other sites

This seems normal to me.

  1. Can you try the GTN in the default Baron 58 and compare?
  2. What is the full windows version # you're running?
    (win10: Settings > System > About > OS build #)
  3. Do you use any 3rd party post processing tool (Reshade or similar)?
  4. What is your video card model / driver vers. #?
  5. Do you have both intergrated and discrete video cards?
    If so, please review the troubleshooting section of the RXP User's Manual.

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
14 hours ago, RXP said:

The Garmin GTN trainer is used in the background with both the RXP plugin (XPlane) and add-on (FltSim) the same way.

Hi Jean-Luc,

Now you are confusing me. Wasn't it a point that the RXP GTN addresses the trainer differently than the F1 one? With other words, if not, then my original point that a laggy trainer will affect both GTN add-ons in the same way. 

Am I missing something?

 


Hans Schmitz

Share this post


Link to post
Share on other sites

These are both the RXP GTN (X-Plane) and the RXP GTN (FltSim).

In both cases the RXP GTN implementation, whether for FltSim or X-Plane, is managing the trainer process 'differently' as you're saying!


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
2 hours ago, RXP said:

1. Can you try the GTN in the default Baron 58 and compare?

Just did a flight in it, had to use pop-up GTN since it's not integrated into the cockpit for me. No lag, seems to be working fine.

2 hours ago, RXP said:

2. What is the full windows version # you're running?
(win10: Settings > System > About > OS build #)

OS Build: 18363.836

Version: 1909

2 hours ago, RXP said:

3. Do you use any 3rd party post processing tool (Reshade or similar)?

No.

2 hours ago, RXP said:

4. What is your video card model / driver vers. #?

Video Card: NVIDIA GeForce RTX 2060 Super

Driver Version: 26.21.14.4587

2 hours ago, RXP said:

5. Do you have both integrated and discrete video cards?
 

I have no idea what this mean, but I believe it's integrated because I only have the one 2060 Super video card installed in my build.

Share this post


Link to post
Share on other sites

A video card in a PCI slot is typically discrete. A video card which is embedded in the CPU (like Intel UHD) is integrated.

If your computer has both, the GTN trainer might have been running on the lower-end integrated instead of dedicated higher-end NVidia. This is a Windows setting in this case and documented in the troubleshooting section of the RXP GTN Manual.

Since it is working fine with a default aircraft, I'd recommend you compare with a couple few others. This might just be a problem with the Carenado Citation II causing this, or the way it is configured?!?


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
14 minutes ago, RXP said:

A video card in a PCI slot is typically discrete. A video card which is embedded in the CPU (like Intel UHD) is integrated.

If your computer has both, the GTN trainer might have been running on the lower-end integrated instead of dedicated higher-end NVidia. This is a Windows setting in this case and documented in the troubleshooting section of the RXP GTN Manual.

Since it is working fine with a default aircraft, I'd recommend you compare with a couple few others. This might just be a problem with the Carenado Citation II causing this, or the way it is configured?!?

Okay, well then I definitely have discrete. My graphics card is not embedded into my CPU (AMD Ryzen 3700x).

I’ll look into the manual but it’s strange because I did another flight in the Citation and had no issues. It seems like it works normally sometimes, and laggy other times. I’ll do more comparing and get back to you. Thanks for the help so far.

 

  • Like 1

Share this post


Link to post
Share on other sites

Alright, doing another flight in the Citation now and the lag issues are back. Very slow response times on clicks in both pop up and cockpit integrated screen (5+ seconds). 
 

I’m confused what the problem is, since the only graphics card in my build is the 2060 Super, it’s a fresh install of X-Plane on a powerful PC, and I’ve seen other people use the GTN 750 in the Citation (this video for example).

As I mentioned I ran the 750 on the default Baron as a pop up window and had no lag issues, so why is this happening to the Citation? 

Share this post


Link to post
Share on other sites

Doing yet another flight and there was some lag at the beginning but it’s cleared up now and running well. So strange. Not sure what causing the lag to fluctuate so much. 

Share this post


Link to post
Share on other sites

@cleipelt This might indicate you're sometimes over VRAM budget and some other times not. Carenado aircraft are generally texture detailed but this takes more VRAM. Are you using the latest XP11B9 or XP11.41 release?

The former has a new VRAM monitor and this might help you finding out. The later can show an approximate figure of the VRAM used when opening the XP11 graphics settings. Alternatively, you might try lowering the texture resolution slider one notch or two and compare?

Worth trying out.

Otherwise, it can just be a problem with the SASL version they are using in the CII?

You might want to also isolate the sources of conflicts and compare:

1) create a XP11\Resources\Plugins.disabled folder next to the regular XP11\Resources\Plugins

2) move all 3rd party plugin subfolders from Plugins to Plugins.disabled.

3) keep RXP's plugins of course in Plugins

See if this makes any difference with the CII and move back the 'disabled' plugins one by one and compare if there is any causing a conflict then.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...