Sign in to follow this  
Guest 2002cbr600f4i

Autogen radius

Recommended Posts

I notice that on FSInsider in the 'What's your Frame Rate Part II' that there is mention of SmallPartRejectRadius. Basically if you add SmallPartRejectRadius=1.0 to the scenery section of the fsx.cfg this is supposed to remove rendered objects in the scenery that is less than, in this case the default, 1 pixel. If you make this number larger the pixel size is larger. Now I think I read somewhere that this number only refers to buildings and not trees. Has anyone managed to find a way of reducing the render radius for autogen trees? I fear that my framerate problems with autogen are to do with the distance it's having to render objects away from the aircraft. I'm still puzzled as to my framerate dropping so much with autogen from 30fps to 15fps on sparse.Steve

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

re: puzzlementYou are not alone on that puzzling question. I'd say it has to do with the way they're rendered. On my system, 'sparse' doesn't cut fps in half though. Wow, that's pretty bad. I wonder what hardware you are running. You probably are running the default .spb file.??re: SmallPartRejectI have messed with SmallPartRejectRadius some. I noticed no changes to AutoGen. The only change I could see at SmallPartRejectRadius=5.0 was that some aircraft parts were not drawn at a distance. But I gained no fps, so I switched back to default value.That's the only experimenting I did with that config key.RhettAMD 3700+ (@2310 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 2.5-3-3-8 (1T), WD 250 gig 7200 rpm SATA2, CoolerMaster Praetorian case

Share this post


Link to post
Share on other sites

Hi Rhett,Thanks for the reply. Yes, I messed a little with the smallPartRejectRadius and noticed it knocked out boats at a boat marina until I got real close. I think I set it at 10 to see what would happen. What frustrates me a little is that I can see some trees rendered away in the distance on top of a mountain or hill and I'm kinda thinking that I don't need to see tree's rendered so far from my aircraft as it adds nothing to my sim experience. If there was something like autogenRejectRadius that would be great as I am assuming I could improve on my framerate a fair amount.For your info I have done all the autogen tweaks, I don't think I have noticed any difference? Even with the TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=50, TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0 I still have major framerate hit. I think it must be to do with the autogen scenery engine that puts a heavy load on the cpu? I don't notice a big difference between sparse and dense autogen but I do notice a major difference between sparse and none.BTW I have changed the spb file.. as well as the default.xmlSteveAMD 2400, 1Gb RAM, Nvidia 7600GS 512Mb (AGP)

Share this post


Link to post
Share on other sites

I am puzzled for another reason. ON my system it absolutely zilch difference whether I turn on autogen to sparse or full or turn it off completely. the difference is maybe 1-2 fps. technically speaking, the % of autogen impact should be roughly the same on different machines. >baffled

Share this post


Link to post
Share on other sites

Hi, I think this kind of makes my point that autogen possibly is a drain on the CPU rather more than on the GPU (graphics card) so if your CPU isn't so fast you may suffer more problems? Just a guess?Just for your info I was getting around 27-30fps and as soon as I added autogen it dropped to around 15-16fps on sparse. This was the same even if I made the changes to the fsx.cfg. Yes I could see the difference visually (less trees and buildings) but the framerate dropped considerably.Interestingly, In FS9 I noticed the clouds tended to have a major impact on framerate but I notice in FSX this seems a lot better.Steve

Share this post


Link to post
Share on other sites

It seems to me that each system reacts differently to FSX.Simple vs detailed clouds cuts my fps by 3-5 points.However, autogen density does not, as long as I don't put the sliders over the middle to the right.

Share this post


Link to post
Share on other sites

Even with the>TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=50,>TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0 I still have major>framerate hit. >Steve>>AMD 2400, 1Gb RAM, Nvidia 7600GS 512Mb (AGP)Steve,I could be wrong, but I seem to recall reading that if you set the values to 0 that they use the default values. Try setting the 2nd value to 1 and see if that changes things at all for you.--Mike

Share this post


Link to post
Share on other sites

Hi Mike,Thanks for the note, funnily enough I just came across that note somewhere else as well.For your info guys I returned everything to default and started again eg restored original default.xml, removed fsx.cfg replaced the .spb file. I then went to nzone.com which gave specs for nvidia video cards near enough to mine and followed their settings. Suprisingly this worked very well. I now find I am getting good framerates. I slightly adjusted their settings to my preference.I think the upshot of this is that because FSX is so complex and there are so many variables to take into account it becomes very tricky to tweak things for your optimal performance. I think I may have been expecting too much from my system. I am happy now with roughly the following settings:1024x768 32AA & TriFilterering set in gameGlobalTexture: Ultra HighMesh Complexity: 60Mesh Resolution: 152mDetail radius:SmallScenery Complexity: Very DenseAutogen: Sparse (With fsx.cfg tweak set to 2000 trees, 500 buildings)Scenery Texture: 2mLand Detail:OnWater: 2xMid (love it!)Animated scenery: HighClouds draw: 60milesCoverage: High , DetailedAll traffic set to around 10-15%Was getting some exterior stutters so I set texture_bandwidth initially to 400, I think this made me CTD so I reduced to 200, slso added the bufferpools tweak to 5000000.I am getting around 15-20fps. I am happy with this. For me anything below 15fps is getting a little choppy.I like to switch on light bloom on some night flights, nice when on approach.Thanks guys for tips and help, I still would love to know if there is an autogen radius tweak though? Someone must know..CheersSteve>Even with the>>TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=50,>>TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0 I still have major>>framerate hit. >>Steve>>>>AMD 2400, 1Gb RAM, Nvidia 7600GS 512Mb (AGP)>>Steve,>>I could be wrong, but I seem to recall reading that if you set>the values to 0 that they use the default values. Try setting>the 2nd value to 1 and see if that changes things at all for>you.>>--Mike>

Share this post


Link to post
Share on other sites

>It seems to me that each system reacts differently to FSX.>Simple vs detailed clouds cuts my fps by 3-5 points.>However, autogen density does not, as long as I don't put the>sliders over the middle to the right.A more true word never said. It is both a symptom of how complex the hobby has gotten with all the various hardware configurations out there and at the same time an indication of how complex the programming task is for the ACES team.It's a pity that there was the decision to provide backwards compatibility as I believe that this makes their task hugely more complicated.Cheers,

Share this post


Link to post
Share on other sites

Hi Maxter,Yes I agree too, although I think they needed to add backward compatibility, if they hadn't to some level there would have been no end of complaints. I think ACES have struck the balance pretty well and covered most bases in terms of forward thinking and backward compatibility for those who have invested a lot of time in the hobby.CheersSteve>>It seems to me that each system reacts differently to FSX.>>Simple vs detailed clouds cuts my fps by 3-5 points.>>However, autogen density does not, as long as I don't put>the>>sliders over the middle to the right.>>A more true word never said. It is both a symptom of how>complex the hobby has gotten with all the various hardware>configurations out there and at the same time an indication of>how complex the programming task is for the ACES team.>>It's a pity that there was the decision to provide backwards>compatibility as I believe that this makes their task hugely>more complicated.>>Cheers,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this