Jump to content
Sign in to follow this  
TacomaSailor

How to start Sim with NO VR support?

Recommended Posts

Something is wrong with my Reverb G2 support for Flight Sim.  I want to start the sim with NO OpenXR - NO WMR - NO SteamVR support.  I do not want any of those apps/dlls to run.  The G2 / WMR environment for the sim had been working perfectly but I now need to test the sim with NO VR environment or support.  I cannot find a way to do that!
 

I start the sim with steam://rungameid/1250410 with NO VR support of any kind loaded.  But, SteamVR immediately loads and then the Sim starts loading all the WMR stuff and then goes into an endless loop calling OpenXR.

 

HOW do I start the sim as if OpenXR / WMR / SteamVR had never been installed?

The G2 is not connected to the CPU/GPU in any way. 

I can start the Steam version of Assetto Corsa and kill SteamVR when it tells me the headset is not attached.  After that Assetto Corsa runs on the monitor with no VR support just like before I installed any VR support.  Can't find a way to do that with Flight Sim!

Assetto Corsa runs perfectly under control of WMR/SteamVR and looks/acts wonderfully in the G2 virtual world.  So - I am pretty sure there is nothing wrong with the VR support on my system.

 

Edited by TacomaSailor

i7-9700K @4.9 GHz  / Gigabyte Z390 Aorus Pro Mobo / 32 GB DDR4 / RTX 3060 Ti 8GB GPU / AORUS FO48U 4k display
 SSD for Drive C and another SSD dedicate to Flight Sim / 1 GB Comcast Xfinity Internet connection / HP Reverb G2 / Tobii 5 Head & Eye Tracking

read about me and my sailing adventures at www.svmirador.net/WebsiteOne/ or at Flickr TacomaSailor

Share this post


Link to post

Have you tried unpowering or unplugging your G2 from your system? I normally have my G2 unpowered, because my cable is a bit flunky if I boot with it powered up but it works reliably if I turn on VR power afterwards when I want VR, and my system doesn't attempt to start any VR app when it is unpowered.


Ryzen 7 5800X3D | Gigabyte RTX 4090 Gaming OC 24GB | 32GB 3200MHz RAM | 2TB + 1TB NVME SSD | 2GB SSD | 2GB HDD | Corsair RM850 PSU | 240mm AIO | Buttkicker Gamer 2 | Thrustmaster T.16000M Flight Pack | 75" 4K60 TV | 40" 4K60 TV | HP Reverb G2 | DOF Reality H3 Motion Platform

MSFS @ 4K Ultra DLSS Performance with 2.0x Secondary Scaling |  VR 220% OXR OXRTK Custom FFR CAS 50% AS -40% | MSFS VR Ultra DLSS Performance - Windows 11

Share this post


Link to post

Tried all that and more - finally did a complete 127GiB reinstall of Flight Sim and WMR - now all works perfectly again

  • Like 1

i7-9700K @4.9 GHz  / Gigabyte Z390 Aorus Pro Mobo / 32 GB DDR4 / RTX 3060 Ti 8GB GPU / AORUS FO48U 4k display
 SSD for Drive C and another SSD dedicate to Flight Sim / 1 GB Comcast Xfinity Internet connection / HP Reverb G2 / Tobii 5 Head & Eye Tracking

read about me and my sailing adventures at www.svmirador.net/WebsiteOne/ or at Flickr TacomaSailor

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...