Sign in to follow this  
Geofa

CH Yoke and pedals in FSX

Recommended Posts

Whenever I start FSX it does not to detect the yoke and pedals (USB) I have to unplug them and plug them back in then they work. This is under Vista Home premium. Been like this ever since I got new PC and installed FSX. Just getting a bit tired of doing it.They show up in the control panel so I do not think its the OS.Anyone else experience this and if so is there a fix?I think this is software related so please dont move post if possibleThanksBill

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Under the same OS as you and have the same problem with the CH Yoke and pedals and my Lexmark printer. My logitech camera, and track IR do not.I would wager a guess that this is a driver issue from the manufacturer but maybe someone knows a remedy.

Share this post


Link to post
Share on other sites

Yes I also calibrated etc with it. I think you are on to something with the sleep issue. I recall back in the old days of XP this also happened :-)Will check it outThanksBillEdit: I checked all power management settings in device manger for every USB root hub/CH products etc and none of them have the power setting enabled to turn off the device, so it may be something elseEdit 2: I found in the power management settings that mine is set to balanced, and there is an item for USB devices that was disabled. SO I enabled it and went back to Device manager and see where the device was actually set to power power off, so I unchecked it. I will see what happens next time. If you dont hear from me then that solved it and thanks to G for the tip :-)

Share this post


Link to post
Share on other sites

I think I have it, working so far. I had the new control panel but hadn't added the yoke and pedals in. Try adding them in and save the mapping. When you run flightsim you'll have to configure the axis and the buttons again.

Share this post


Link to post
Share on other sites

>If you figure it out let me know too. Very infrequently my>rudders pedals(only) still go to sleep-haven't figured that>one out.>Ok here is what I have done based on your sleep tip and so far it seems to work:1) Run the CH control manager and make sure both yoke and pedals are recognized and calibrated. Exit2) Open control panel/Power Options. My default is set to balanced, but no matter what the menus are all the same for all the plans. Select "change plan setting" then "change advanced settings". On the drop down menu go to USB settings and open to the last item. If it is disabled change to enable and click ok out of everything...whew :-)3) Open your device manager and go to Universal Serial Bus controllers. Then look for anything that says USB root hub. Right click on each one and then check the power management tab and see what is checked or not checked. Uncheck the ones you want and it should work. I dont recall which one(s) are linked to the CH items so I unchecked them all for power management and so far its working.Good luck and I am off to the airport on vacation..Bill

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this