Sign in to follow this  
Guest DigitalNoise

DX9 vs DX10, jitters

Recommended Posts

Hi, I'm trying to get my rig working with FSX and DX10. I have the Acceleration addon, and the following hardware: Asus P5K, Intel Core 2 Duo E6850 (3.4GHz), 2GB PC6000 DDR2 RAM, POV GF8600GT 256MB (slightly oced). TrackIR PRO 4.The main problem I have with DX10, apart from AA trouble, is that the sim sort of jitters. The scenery seems to flow by smoothly, but as much as several times a second it jumps slightly in some direction. Using DX9 this is not an issue.Of course, I could stick to DX9, but being a geek, I can't rest as long as somethings not working as it should ;). Furthemore, I think I get slightly better frames in DX10, and I can enable bloom, which is sort of nice.Does anyone else experience anything similar, and how do I fix it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I stopped using DX10 because:- it gives me random jitters (very short pauses/freezes all the time)- progressive taxi doesn't work- it gives me random jitters (very, very short pauses/freezes all the time)- textures are all grainy (very apparent on airfields, where there aren't many colors, as if 'moving noise' is added)- it gives me random jitters (very, very, very short pauses/freezes all the time)I liked bloom and the nice water (didn't care that much for the jaggy VC-shadows), but I rather have a smooth flying plane than those 'wonderfull' DX10-additions...(Until now I have had NO USE at all of DX10... And I am not only talking about FSX. I might as well (and should) have installed XP on the new computer I bought a year ago... DX10 is the most overhyped piece of **** from 2007... The 8800GTX still is worth it's money, though, because EVERYTHING runs perfect under DX9...!)

Share this post


Link to post
Share on other sites

Right, so I'm apparently not the only one with this problem. And, since you are sticking with DX9, I assume there's no easy solution :(

Share this post


Link to post
Share on other sites

No easy solution indeed. But even it there was a solution, I'd stick with DX9, unless the noisy textures and progressive taxi are solved too. But I doubt that will happen since this is it: the next big thing that will happen in FS-land is FS 11.BTW DX9 performs better than DX10 above cities on my computer (even when I turn bloom and shadows off in DX10), so... DX9 isn't a bad or mediocre choice! (I do have problems with lots of trees, though, but I have had those problems since I have FSX. DX10 is better above trees... Ah, there is always something to complain about ;) )

Share this post


Link to post
Share on other sites

according tohttp://www.nvidia.com/page/geforce8.htmlyou have540/612=88% of core speed of the top end1190/1500=79% of shader speed of the top end700/1080=65% of memory speed of the top end128/384=33% of the memory bus width of the top end22.4/103.7=22% of the memory bandwidth of the top end8.64/39.2=22% of the texture bandwidth of the top endso with only a mid-range DX10 card at best, you need to dial down settings in DX10 mode. I suspect if you disable bloom or some other high-impact setting the stutters/jitters will go away.you get what you pay for. you cannot overdrive systems with specs like these.

Share this post


Link to post
Share on other sites

Thanks for the info. So it would seem that it is the bandwidth that perhaps is the bottleneck, at least compared to high-end cards. I've tried without bloom, but got the same results. Also worth noting is that the the exact same settings for DX9 and DX10, I still get jitters with DX10.However, the other poster, J van E, has a 8800GTX which I suppose is high-end, and he still has the same jitters.I'm therefore forced to conclude, at least for my system, that DX10 is not worth it. Which is weird, as I thought the whole point of DX10 for FSX was to allow the graphics card to take a larger portion of the load for more advanced graphics, for a simulator which is largely CPU-bound? In other words, I had anticipated better, or at least the same performance with DX10.

Share this post


Link to post
Share on other sites

I suspect if you disable bloom or>some other high-impact setting the stutters/jitters will go>away.I have a 8800GTX, but accompied by a E6600, which was quite nice a year ago, but isn't the best right now, I know. Still, DX9 is smoother than DX10 on my system. I really don't have all sliders maxed out, on the contrary, traffic is almost off (10% GA and cars), clouds are at their lowest, mesh and stuff is just above medium and water high 2x (that is a big one). Bloom and shadows are off too (although they seem to give no impact with DX10). But still I have to turn off ALL autogen to get a smooth flight in DX10. I can turn on Autogen to Extremely dense (with the above settings) and still get a smooth flight in DX9! When I say smooth I am not talking about fps! Smooth is NOT the same as high fps! Even 15 fps can be smooth. (I have an average of 20-25 with DX9 though.) However, DX10 gives me stutters, no matter what the fps is: it may be 25 (so the system isn't taxed too much) or 13: but those stutters (which seem quite random, meaning it's not every 2 seconds: sometimes it is 3 seconds, sometimes 5, somtimes 2, etc.) are always there. So with my settings DX9 performs nicer (and in some circumstances better) than DX10.

Share this post


Link to post
Share on other sites

Thats my feeling exactly. As an experiment i locked the FPS way below what was achieved with unlimited (although unlimited fps performs better), but still there was jittering...

Share this post


Link to post
Share on other sites

Do you still have jitters when you turn of ALL autogen? I said that cured my jitters, but I can't check it right now and I am not 100% sure...

Share this post


Link to post
Share on other sites

thinking out load, and taking the other data point about Autogen, the memory bandwidth required by Autogen might be causing this. Perhaps the autogen cfg tweak where you turn down the cell maximums would help.its not that DX10 doesnt move some load to the GPU, its that your mid-range GPU is a compromise of performance to hit a price point. you have to be realistic about that.

Share this post


Link to post
Share on other sites

I dont get gitters if i lock the frame rate to about 25 - 30. Else i get really bad gitters.

Share this post


Link to post
Share on other sites

Ok, I've testet various settings.Just turning off autogen leaves me still with jitters. I must reduce the global scenery settings to low to completely eliminate jitters. Medium low, but without autogen gives me some jitters, even without AA and AF, and I get 70-80 fps. This is flying the Acceleration Mustang at ENDI. Turning on AA and AF brings the fps down to ~35 when looking ahead, bot does not noticably worsen the jitter effect. This is with high global texture resolution, but without shadows, bloom, etc.Running the same test with DX9, I noticed I actually get some jitter here too when having unlimited fps, but by limiting it the jitters disappeared, and the sim runs comfortably at "ultra high" scenery settings with fps locked around 20-25.I then tried running the same high settings with DX10 at the same location, and this time there were no jitters. I had not rebooted the computer in between, just restarted FSX to toggle DX10.I'm not really sure what to conclude...

Share this post


Link to post
Share on other sites

Jitters....Dont give up, I used to create huge Photoscenery files and ran them with a lowly 128MB card (current is 512mb)and learned how to run Jitter free(Before FSX).The first thing to verify is that you dont have something else running in the backround, AntiVirus, Fraps, Various Motherboard Monitors and the like including auto-updating services etc. Make >sure< those are all off. That Includes some of the Video driver services. When you can verify that then start swaping out a few of the variouse current driver revisions. I know its a pain but you may get results or you may just find that FSX/dx10 is broke.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this