Sign in to follow this  
Wnuk

For those with menu crash issues, possible solution found?

Recommended Posts

Like many of you, I was having full screen menu crash issues in FSX since I switched video cards from ATI to nVidia. In trying many differnt things to fix it, I stumbled upon a repeatable way to stop them for me. I am running FSX with Acceleration & UTX installed on a Win XP SP2 32 bit machine with an 8600GT video card using the 169.21 drivers.To repeatably stop my full screen menu crashes in FSX, I setup through the Nvidia Control Panel my level of Anio (16X) and level of AA (8X) in both my global settings & FSX program settings. Now the key to fixing the menu crashes for me was to make sure that Antialias mode in the control panel is set to "enhance the application setting" in both the global & program settings. Then start FSX and tick the Antialias box under the settings category to "on". I also check Anisotropic Filtering in FSX settings.This fixes my menu crashes. I can instantly cause crashes again by turning off the "enahnce game settings" in the Nvidia Control Panel (both globally & program settings) and the unchecking the AA box in FSX settings.I'd be curious if others of you with the menu issues can try this and see if it helps. ThanksJim

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

That's a strange "fix" and it's amazing to me that you're able to reproduce it. I have the Nvidia 8800 GTX cards in my system using the latest WHQL drivers (169.25) and have AA and AF set to Application Controlled. "Enhance the application setting" is turned off and AA and AF are turned on in the FSX settings. No menu crash, ever. Why does your FSX crash and mine doesn't? I hope you don't have your sliders maxed out in your scenery settings and/or turned up autogen and AI settings. That could cause problems since FSX is CPU intensive and you could cause you to run low on memory. In any case, glad you were able to fix your problem and I hope it fixes others who may be suffering the same problem.Best regards,Jim

Share this post


Link to post
Share on other sites

My settings are almost all just around mid range. Some a bit higher some a bit lower. Why some people have the menu issue & others don't is beyond my knowledge but I post this in hopes that what I discovered might work for someone else having the same issues.Jim

Share this post


Link to post
Share on other sites

This is really interesting because since Nvidia's 169.21 drivers for my 8800GTS card the menu crashes have gone way down but still occur occasionally. Usually the crashes occur either when changing date and time or switching airports. Now I can't wait to try your suggestion. I'm hoping this is another piece to the puzzle. I still think there's something in sp2 that triggers it and that it's not all due to Nvidia. However, that's never going to get fixed according to MS so we'll just have to solve it ourselves.Keep up the good work.Lee

Share this post


Link to post
Share on other sites

"I still think there's something in sp2 that triggers it and that it's not all due to Nvidia."Lee, I do hope the possible fix works for you too. In regards to the above quote, you would certainly be correct in your assumption if the menu crash occurred to everyone who installed SP2. But it doesn't. As I stated in a post several months ago when this issue first came up, I had a similar crash in FS9 whenever I opened the kneeboard and then the NAV page. It was an immediate crash to desktop. I fixed it by completely uninstalling my video card drivers and then reinstalling them. I personally think this is the problem here. Have you ever uninstalled your drivers completely and then used a driver cleaner like the popular one on Guru3d and then reinstalled your drivers? That's what I do whenever I upgrade my drivers and that's probably the reason I have never had the menu crash yet. I should add that your sound card drivers could cause the same problem if not properly installed since video and sound card drivers are all competing for memory address space and there may be some conflicts. You might consider reinstalling them too and make sure no anti-virus program is running in the background while you are doing it.Best regards,Jim

Share this post


Link to post
Share on other sites

Oh yes Jim, I always do complete cleaning when installing new drivers. I'm totally current in all drivers on my dual core. One small thing I've noticed is a few more menu crashes when I'm running unlimited fps as opposed to limiting it to 27, which is what I use. What could that be due to?It's probably a driver issue, but what sets it off?Lee

Share this post


Link to post
Share on other sites

I'm sure I have a clean driver install also. I switched from ATI to nVidia & only have one nVidia driver installed. I'm thinking it is a driver issue & suspect it has something to do with Antialiasing.I can also get rid of the menu crashes (and see better AA & AF effects in FSX) by using nHancer. If I set both the global & FSX profile settings to exactly the same, menu crashes in full screen are gone AND I can turn off the FSX AA box.I'm puzzled as to why these things work but have been able to repeat failures by reversing these settings.Hoping others can benefit by it also.Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this