Archived

This topic is now archived and is closed to further replies.

Guest tcable

OOM- what's the best bang/buck on eliminating them?

Recommended Posts

I'm running with everything full right (that's right. Everything) for now. Even at major airports, I'm getting 20fps. Have not tested ATL, ORD, LHR, JFK yet. It's a new system.I'm getting OOM errors though under XP32. I know that's it's a memory addressing issue not amount of memory :) In my case, 4gb with a 512 video card.What is the best stuff to reduce to eliminate these errors? I have no non-default AI right now, and my old XP system has not had an OOM in forever. (loaded with addons and WOAI plans)Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Move your sliders a bit to the left. Easiest and cheapest way to eliminate OOM errors.I your'e looking for some othe solution, you'd better give us some info on your present hardware and software platform.Ulf B

Share this post


Link to post
Share on other sites

I think Ulf is right.Best bang for your buck is FREE! Move sliders to the left, in this order (bang for buck-wise):Autogen to DenseScenery Complexity to DenseRoad Traffic to 20%Leisure Boat Traffic to 10%Freighter Boat Traffic to 20%First off, this will most likely create a more realistic world environment. Secondly, FSX is drawing road traffic that you can't even see (i.e., it's behind you!) Same for boats. Why spend memory on that?I think these settings alone should eliminate your OOM's. I am assuming you are using 2mb or more of RAM.Good luck,

Share this post


Link to post
Share on other sites

>I'm running with everything full right (that's right.>Everything) for now. Even at major airports, I'm getting>20fps. Have not tested ATL, ORD, LHR, JFK yet. It's a new>system.>>I'm getting OOM errors though under XP32. I know that's it's a>memory addressing issue not amount of memory :) In my case,>4gb with a 512 video card.>>What is the best stuff to reduce to eliminate these errors? Have you applied the /3GB /userva=2560 switch yet?

Share this post


Link to post
Share on other sites

I'm running the same way as you. XP32, 4gb memory with the 3gb switch applied (see above), 8800 GTX video card w/768mb memory. All on a TripleHead2Go setup. A couple months ago, I accidentally discovered a way to prevent OOM's altogether.If you run FSX in Windowed mode (which I do on my TH2G setup with a 4th 22" monitor on the side for charts, FSCommander, etc), open up Windows Task Manager and monitor the FSX.EXE file memory usage. It will continually increase over time, the speed depending on how many other apps you may be using, etc. I used to get OOM's when mine reached about 1,300,000. But I discovered that when I minimized the FSX window to the desktop, the FSX.EXE memory usage would drop all the way to the 36,000 range. Then when I re-opened the window (by simply re-clicking the FSX tab on the taskbar), it would STAY low and start slowly climbing again, with no adverse affects to FSX. Try it.I posted a question about this a couple months ago when I discovered it, but never got an answer as to why it does this. In any case, I can easily prevent all OOM's this way. Do it especially about 50 miles from your arrival airport to reset the memory. No more OOM's when all those AI aircraft at your destination airport, or the airport itself, start getting "called up" for memory availability in FSX.Of course...if you don't want to fly in Windowed Mode, you can disregard all of the above.FalconAF

Share this post


Link to post
Share on other sites

I have not applied any flags, though my install has PAE enabled (never saw that before on XP32). This is a temp OS install until Vista64 arrives (Customer feedback freebie). That's been the plan for now so I'm 'only' installing PMDG, LDS and UT. I won't worry about any third party AI since the default is pretty well represented.It's fun to have the horsepower to play like this. All sliders Full right AND I can fly the PMDG 747.I'll try those ideas. I've got so little tinker time right now due to work. It's tough enough to get the system running and have a bit of time just to fly around. The oom's can happen fast sometimes.

Share this post


Link to post
Share on other sites