Sign in to follow this  
SteveW2

Dai's fs9gauges.h problems...

Recommended Posts

Hi All, I am trying to compile gauges with Dai Griffith's latest fs9gauges.h without success. I keep getting "....: C0265:'helpid': undeclared identifier" messages. If I use the standard Microsoft included gauges.h I don't have any problem with 'helpid's but then I have SHOW or HIDE LISTELEMENT problems...Any one got a newer gauges.h that solves these problems?Arne, you out there? I think you have written about this topic sometime ago before.thanks,Steve Weihersweiher at shaw dot ca

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Steve,If the errors you are getting are in the mouse definition:MOUSE_TOOLTIP_ARGS(GPS_Args)MOUSE_TOOLTIP_ARG (MODULE_VAR_NONE, 0, NULL, NULL, NULL, NULL, NULL, NULL)MOUSE_TOOLTIP_ARGS_ENDThe second line here is mandatory, at least with MSVC.net it is. You can eliminate the whole block if you don't want a tooltip.Doug Dawson

Share this post


Link to post
Share on other sites

There is an error in one of the gauges.h files concerning the helpid. If you have a program that will compare the two statement, you can find the correct one.Maybe Bill Leaming will see your post and tell you what to fix.W. Sieffert

Share this post


Link to post
Share on other sites

What code is at your line where the error is indicated? Just to sort out potential problems.Arne Bartels

Share this post


Link to post
Share on other sites

Hi Arne! and thanks to everyone,I am still just using a VCVARS32.bat and nmake to compile gauges.I 'inc' Dai's fs9gauges.h in my main .c file. Any lines containing HELPIDs in any sub gauges result in the error and compiler stopping. When I use Microsoft's gauges.h I get no such error but then I get errors for every SHOW or HIDE LISTELEMENT I try and use. I found and older, FS2k version of gauges.h you wrote sometime back that gives me no errors (same gauge compiles fine), so I am using that but it is missing some of the 2k4 functions. It just appears to me that Dai's newest fs9gauges.h must have a minor error. I will see if Doug's fix (above) works and if not will start comparing gauges.h files I have to see if I can fix. Thanks for the help.take care,Steve

Share this post


Link to post
Share on other sites

Would you mind trying this one? Since almost all xxxgauges.h from Dais tutorials are actually edited by me, I'm very interested to know where's the problem. There was an issue with the definitions around the mouse-rects I think. Check the #defines MOUSE_PARENT_BEGIN to MOUSE_CHILD_FUNCT.Arne Bartels

Share this post


Link to post
Share on other sites

Hi Arne,thanks again for the file, off to work.. on the LAX run tonight.Will try tommorrow, asap.take care,Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this