Sign in to follow this  
Guest darrenecm

fs9 debug in vc++

Recommended Posts

HiI'm trying to figure out how to debug the sample c gauges from the fs2004 sdk. I'm using visual studio 2005 c++. The gauges will compile and run just fine but I can't get into debug mode. Here's a bit of output when I run debug:info for 'fs9.exe' can't be found or doesn't match. No symbols loadedfs9.exe': Loaded 'C:Program FilesMicrosoft GamesFlight Simulator 9fs9.exe', No symbols loaded.'fs9.exe': Loaded 'C:WINDOWSsystem32ntdll.dll', Symbols loaded (source information stripped).'fs9.exe': Loaded 'C:WINDOWSsystem32kernel32.dll', Symbols loaded (source information stripped)..........'fs9.exe': Loaded 'C:Program FilesMicrosoft GamesFlight Simulator 9oleacc.dll', No symbols loaded.I loaded the symbols from microsoft. Now I'm only missing symbols for fs9.exe and oleacc.dll.Anybody know what I can do about this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You don't need those symbols to debug your own gauges or the sample ones. Just set a breakpoint in the sample gauge, run and you should hit the breakoint when the gauge is loaded.

Share this post


Link to post
Share on other sites

That's what I thought too but when I set a breakpoint and run a box pops up and says:info for 'fs9.exe' can't be found or doesn't match. Nosymbols loaded. do you wish to continue.I continue and the breakpoint automatically gets disabled. It says:the breakpoint will not currently be hit. No symbols loaded for this document.I just want to be able to step thru the sample code to get a better feel for whats happening.

Share this post


Link to post
Share on other sites

Where are you trying to set the breakpoint? In fs9.exe or in your own dll?

Share this post


Link to post
Share on other sites

Have you just tried continuing? Your breakpoint might well be disabled until your gauge dll is loaded at whih point it will be active.

Share this post


Link to post
Share on other sites

Yeah, I've hit continue but it never breaks. I guess its not my biggest problem right now. At least I can still make new gauges. Its just nice to be able to see how variables change as you go along.Thanks for the help anyway.

Share this post


Link to post
Share on other sites

I've found that the changes made in the FS 9.1 update prevent loading a debugger with FS9. With the NoCD patch it runs OK.RegardsBob ScottATP IMEL Gulfstream II-III-IV-V L-300Santiago de Chile

Share this post


Link to post
Share on other sites

I had this problem once.I found that if the name of my project as listed in Solution Explorer, was different to the name of the main C/C++ file that generates your .obj. .gau and, more importantly, the .pdb file (.pdb contains all your debug symbols), things did not work. Look at your Project name and make sure it's the same as the resultant build filenames that are being generated.I can now debug .gau files with blissful ease within the sim and productivity in tracking down those pesky code gremlins has vastly improved :)Hope this helps- Darren Evans

Share this post


Link to post
Share on other sites

I am trying to debug my gauge and it says it has loaded the symbols for my gauge, but for nothing else.The breakpoints are not hit and Visual Studio says:"The breakpoint will not currently be hit. No symbols have been loaded for this document"Any ideas?

Share this post


Link to post
Share on other sites

Have you first tested the gauge works at all in FS? Run it installed on a panel and see if it loads ok there.Are you using Express or VS 2005?

Share this post


Link to post
Share on other sites

>I've found that the changes made in the FS 9.1 update prevent>loading a debugger with FS9. With the NoCD patch it runs OK.>Confirm that. Also FS9.1 contains an internal debugger that will (surprisingly) sometimes co-operate with you instead of just giving you a CTD if you do something stupid. I'd been trying to register a DirectSound object and every time I failed it came back with'FS9 Debug not registered. will not be played'.Friendly, for once!-Dai

Share this post


Link to post
Share on other sites

Found it :)I had to set the Debug Information Format to "Program Database for Edit & Continue (/ZI)"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this