Sign in to follow this  
Guest Patrick_Waugh

Emissive Textures

Recommended Posts

I am having some trouble getting emissive textures to work, and so I thought I'd post what I'm doing to see if anyone can spot the problem.I detailed the engineering hull, and finished it.http://i91.photobucket.com/albums/k282/Ben...riseModel04.jpgThen, I worked on the shuttle bay doors, as a separate part.http://i91.photobucket.com/albums/k282/Ben...riseModel03.jpgSo, I created a 256x256 psd file looking like this:http://i91.photobucket.com/albums/k282/Ben...s/Bay_Doors.jpgand exported a dds of the above (DXT3 with alpha), and a dds light map that looks like this:http://i91.photobucket.com/albums/k282/Ben...ay_Doors_LM.jpg (DXT1)I then put the LM in the self-illumination map slot, and the diffuse in the diffuse, and adjusted the FSX material parameters to allow bloom, and bloom with copy, just as in the SDK (I thought).Then, I fliped the textures in the vertical.While it all lines up, when I go to night, there is no self-illumination.What should I check?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You didn't mention choosing the emissive type:AdditiveAdditiveUserControlledAdditiveNightOnlyAdditiveNightOnlyUserControlledBlendBlendUserControlledMultiplyBlendMultiplyBlendUserControlled

Share this post


Link to post
Share on other sites

I did blend.I notice that in Photoshop there are two save as .dds options. They seem to work differently, and once I create a .dds sometimes I am not able to open it with the ACES imagetool.Strange. I think probably something is wrong with my .dds.I'm going to have to re-read it all and do it step-by-step and verify I have an alpha channel etc.Thanks for the idea.Patrick

Share this post


Link to post
Share on other sites

>I did blend.>>I notice that in Photoshop there are two save as .dds options.> They seem to work differently, and once I create a .dds>sometimes I am not able to open it with the ACES imagetool.Like myself, you most likely have both versions installed.The one you want to use is here (from the nVidea installer):C:Program FilesAdobePhotoshop CSPlug-InsFile Formatsdds.8biThe one you don't want is one that came with Photoshop, because it doesn't support the latest DX specifications:C:Program FilesAdobePhotoshop CSPlug-InsAdobe Photoshop OnlyFile FormatsD3DXTextureFormat.8biI simply renamed the original plugin to D3DXTextueFormat.8bi.OLD :)

Share this post


Link to post
Share on other sites

Still no joy.Here are my settings:MaterialEditor1.jpgMaterialEditor002.jpgMaterialEditor003.jpgBoth the diffuse texture and the self-illumination map are DXT1What am I doing wrong?Patrick

Share this post


Link to post
Share on other sites

Hi Patrick,My turn to help :)You are not doing anything wrong. The texture emmissivity (self-illumination) simply does not work. As it happens, 2 yrs ago I figured out why it doesn't work and how to correct it. It seems that makeMDL simply overwrites the emissivity when a texture is assigned (texture-less material emits light fine). You can fix that by modifying the ASM file when it's created by makeMDL and then re-compile. It works perfect every time. There is a thread on this in the forum, just search for "self-illuminated" and look for my topic.Cheers,

Share this post


Link to post
Share on other sites

>You can fix that by modifying the ASM file when it's created>by makeMDL and then re-compile.That's fine for pre-FSX, but the new FSX models aren't SCASM constructed. Instead they use DirectX (.X) to compile the .mdl file.

Share this post


Link to post
Share on other sites

>Both the diffuse texture and the self-illumination map are>DXT1The diffuse color bitmap MUST be DDSDXT3 or DDSDXT5 (you may as well use the latter since there's no filesize difference and the compression algorithim for DXT5 produces fewer artifacts).The self-illumination can be DDSDXT1 either with or without Alpha.

Share this post


Link to post
Share on other sites

Well, I turned the DXT1 to DXT3 with the ACES tool, but still no joy.Would seem that since there is no Alpha channel in the diffuse that there is no need for it to be DXT3. But with you telling me that it must, then I am suspecting that is the problem.Should the diffuse have an alpha that looks like the night map? Seems strange to me. Also, when I compile should I turn off the "Use .bmp extention"? I've tried it both ways, with no effect.Patrick

Share this post


Link to post
Share on other sites

Per Bill's suggestion, I flipped the .dds files (a step I had neglected as I thought the output filter had already done it) and ureka, it works.Thanks all for the help. Now I can texture this puppy. I can see I have a lot to learn about FS materials. So many options.Patrick

Share this post


Link to post
Share on other sites

The two textures needed to be "flipped vertically" when doing a Save As to the FSX texture folder.The reason is that all images sent to the video card must be "flipped vertically" by the CPU UNLESS they are "pre-flipped." That is the entire purpose of using DDS files to begin with: to save CPU cycles by having all textures "pre-flipped..." ;)

Share this post


Link to post
Share on other sites

>Per Bill's suggestion, I flipped the .dds files (a step I had>neglected as I thought the output filter had already done it)>and ureka, it works.Imagetool will only "vertically flip" textures that aren't already .dds format. Imagetool "assumes" that .dds files are already flipped! :)To save confusion, I use only .psd files in Max/GMax, then "flip and Save As" .DDS files directly from Photoshop using the nVidea .DDS plugin.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this