Sign in to follow this  
Guest

How to avoid autogen excluded by ground polygons?

Recommended Posts

Dear All:My ground polygons in my scenery are excluding the autogen scenery, is there a way to avoid the autogen excluded by ground polygon without to delete my polygon?Thanks.Alfredo Mendiola LoyolaLima Peru

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Are u using ASD, and are you identifying those polys as "airport polygons"? or does this happen with any ground polygon? Bob B

Share this post


Link to post
Share on other sites

Hate to break it to you, but you will have to create autogen with the tool called Annotator.Aerial or Terrascene or custom resampled bmps cause all autogen to be lost.We have done 1000 AGN tiles by hand for our upcoming CYQT release, 500 to go...... yawn!!!!To top it off, you will find that custom models cause havoc with the created autogen, as well as the fact that you will have to slice in, by hand, modeled trees and buildings in the vacinity of airports and any exclude areas you have marked.Have fun!!!!!!!See you in a couple of months. http://members.rogers.com/jkanold/jimlogo.gifhttp://members.rogers.com/jkanold/flyurl.gif

Share this post


Link to post
Share on other sites

Hi there,Using the annotation tool will not solve this problem! The autogen objects will again be excluded.The only way I know to go around this problem is to move the refpoint associated with the offending poligon away from the required autogen objects. The problem is not the poligon itself, autogen only looks at refpoint. In same cases this is a good solution but be carefull with the visibility parameters!Good luckjmf

Share this post


Link to post
Share on other sites

Dear Jmf:could you explainme or give an example to solve my autogen excluded scenery by ground polygons (ASD polgyons, ariport polygon and no airport polygon).Thanks.Alfredo Mendiola LoyolaLima Peru

Share this post


Link to post
Share on other sites

HI there,I will try to explain quickly as I have to go now.When you draw a poligon, you usually define a refpoint which is in the middle of the object itself. The local (scaled) coordinates are then to the left, right, up and down from this local reference. You then define the visibility parameters V1 and V2.Now, what you need to do is to move this refpoint away from the poligon which stays in the same place. You put the refpoint in a place that is nearby but does not have to have autogen objects. This is easy if you are close to the sea for example. One other option is to put the refpoint in the middle of a runway or any other big object where you don't want autogen anyway.Doing this will result in the autogen objects being excluded only where the refpoint is.But be aware that you need to test the visibility of such poligon because you might be passing through the refpoint but haven

Share this post


Link to post
Share on other sites

Hi again,What I have just advised is almost correct! ;)This approach does not solve the problem!The correct approach is still moving the refpoint away as I just described but use the very same points for the poligons. to draw the poligon on the correct place then use a transformcall to put the refpoint back into the original place. This will trick fs into thinking there is nothing there!Sorry for the confusion!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this