Sign in to follow this  
Guest

gmax scenery bluring out terrain textures

Recommended Posts

Hi all , I have just released my fs2002 SW UK scenery for the Visual flight VFR photo scenery and have a big problem. With the scenery installed it causes the terraine textures to blurr to the lowest resolution. this problem has been reported by a number of users and is intermittent i.e. it doesnt happen all the time, it can somtimes be cured by flipping from full screen to windowed and back a few times but not always. there is a discussion here with more details on the problem http://www.visualflight.co.uk/forums/topic.asp?TOPIC_ID=387. I would love to get this fixed as the scenery looks great when its working. I have tried converting the textures to DXT format and compressed the bgl's with bglzip.exe with no effect. Any ideas on this would be most helpfulcheers Nick Ryall

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Nick,can You post a screenshot or two to see what is going on? Maybe there are two things going on here, one is if users have GeForce card and use drivers 40.xx and up, the second requires a little fix in FS2002.cfg in [Terrain_detail] section (but it is not only distance there). The last one I can provide You some hours later, when I will come home.Meanwhile, You can also try installing a new fresh FS2002 to another directory and instal *only* Your scenery there; no other scenery, no planes, just default scenery and Yours and try to examine what happens. This way I also found those corrections in FS2002. I had a similar problem with CellGrid textures when numbers were looking like potatoes...Best regards,Goran BrumenFS Slovenija 2002 teamhttp://slovenia.avsim.net

Share this post


Link to post
Share on other sites

Thanks for the reply, I suspected it may be a Nvidia issue as so far all who have reported it use Nvidia cards, mine is a gforce 3 with 41.09 What driver would you use ?Here are some before and after screen shots

Share this post


Link to post
Share on other sites

Hi!I have good results with 40.72 WHQL (WHQL drivers do work properly with FS, except 41.09, at least with GF3!), but best results I got were with 30.80 WHQL (maybe 30.82, do not remember which is WHQL). I would degrade my driver down to 30.82 but the picture is more natural in 40.72, so I am keeping up with it. All drivers for my GF3 I have downloaded from www.guru3d.com.The problems I get with 4y.xx drivers are usually related to DXT1 textures. The worst thing I get is that textures are converted to some funny checkboards, I can see whole bitmap on object's side instead of region defined, etc... But these anomalies do not appear if FS is restarted; they appear mostly when I made jumps from another airport to another.Anyway, I use bilinear filtering just to avoid those blurry textures and of course distance is to the max, around 12.5 if I remember. I will post settings from my FS2002.cfg later, okay?Best regards,Goran BrumenFS Slovenija 2002 teamhttp://slovenia.avsim.net

Share this post


Link to post
Share on other sites

great I wil try them I TRIED 30.87 today but no better

Share this post


Link to post
Share on other sites

Hi, here are promised settings from FS2002.CFG file

[DISPLAY]UPPER_FRAMERATE_LIMIT=20AntiAlias=1TnL=1[TERRAIN]TERRAIN_ERROR_FACTOR=10.500000TERRAIN_MAX_VERTEX_LEVEL=19TERRAIN_TEXTURE_SIZE_EXP=8TERRAIN_AUTOGEN_DENSITY=5TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=1TERRAIN_DEFAULT_RADIUS=9.500000TERRAIN_EXTENDED_RADIUS=4.000000TERRAIN_EXTENDED_LEVELS=1[SCENERY]IMAGE_COMPLEXITY=5DYNAMIC_SCENERY=1DYN_SCN_DENSITY=5DAWN_DUSK_SMOOTHING=1

I hope You'll find some use from these settings.Regarding detonator's pay attention to remove it properly!!! On www.guru3d.com You can download Detonator 40.xx destroyer to remove those settings completely. After that, You can use 30.82 but really, the picture is a little worse in 30.82 than in 40.xx.BTW, have You allready tried the newest drivers, 42.30 WHQL?Best regards,Goran BrumenFS Slovenija 2002 teamhttp://slovenia.avsim.net

Share this post


Link to post
Share on other sites

I have tried 30.82 and 40.72 still get the bluring and now someone has reported the problem while using a Radeon so I think we may be on the wrong track here. It is even causing the default terrain textures to blur as well so its definatly somthing to do with my scenery objects. All are Gmax created bgls

Share this post


Link to post
Share on other sites

Hi,please do try my cfg settings and see if it gets any better. My VTP scenery in default FS2002 was awful, those settings gave me shraper lines and textures.Best regards,Goran BrumenFS Slovenija 2002 teamhttp://slovenia.avsim.net

Share this post


Link to post
Share on other sites

well thanks for your help but its still happening with your settings . Ill try the newest driver but dont hold out much hopethanks again Nick

Share this post


Link to post
Share on other sites

Hi Nick,I indeed think you are right and that the drivers and settings have nothing to do with it.The problem is that a piece of scenery is interacting with the mesh scenery (default or custom texture). I have been thinking about it a bit and have you checked if the texture type has an influence? By default GMax uses TEXTURE_AIRCRAFT, while for scenery TEXTURE_BUILDING is better. It's just a wild guess, but maybe it helps....Arno


Member Netherlands 2000 Scenery Team[link:home.wanadoo.nl/arno.gerretsen]Arno's FlightSim World for scenery design hints, tips and other tricks...

Share this post


Link to post
Share on other sites

Yup as usual Arno is on the right track check and see if you are useing texture_building and see if that helps(it should). Dan

Share this post


Link to post
Share on other sites

Thanks Arno this sounds promising, I have checked the texture type in the .asm source file and its TEXTURE_AIRCRAFT . How do I change that to TEXTURE_BUIDING, in Gmax ? or do I have to edit the asm file by hand and recompile thru BGLC.exeNICK

Share this post


Link to post
Share on other sites

HMM I thought it would, I did a test and changed the texture_aircraft to texture_building and im sorry to say the problem is still there. Do you think it could be that some of the objects have parts below ground level not just sitting on top ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this