Sign in to follow this  
Guest

Ground2k - lwm-areafill in FS2004

Recommended Posts

Hello,i'm trying to modify default-lwm-rivers in Germany (not the small vtp-lines). I converted the mistyped LOD13-Area with Ground2k. There is a button called F1, where i can fill an LOD13-Area with land.To eliminate the shorelines is no problem, i exclude the layer 8.Then I draw a new LWM-Polyline in the usual way.If I do so, everything seems to be perfect. The river is shown correctly, but if I use the flightplanner or the gps-system from FS2004, FS2004 will crash. This also happens, if I make changes in the weather system. Maybe it has something to do with the drawing of the Microsoft-Maps, cause all these parts from FS2004 are working with a Map, where I can see my new rivers.The part of the new river, where the AreaFill is used, does NOT appear.In FS2002, i never have seen this problem and all is correct. No crashes.I have restricted the crashes on this areaFill-command. All other things are ok (except the new layers, but this is no problem) ;-)What's wrong?Thanks,Rainer.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Rainer.I can confirm that the 1x1 areafills do not show in the default GPS gauge, and seem to not display LWM masking in those areas. I don't note the crash of the sim, but they definitely don't show. My test area was small, but I believe you when you say it causes the sim to crash on your computer.I'm assuming this is a problem with the gauge, more than with the LWM code... but FS2004 is a different animal, and many things are changed... even some things we were assured would work, are now found to not work.We need a new scenery SDK ( to replace the old FS2000 Scenery SDK ), and we need a new comprehensive terrain SDK, as the FS2002 Terrain SDK has some innacuracies, and is incomplete regarding the different types of line structures.Dick

Share this post


Link to post
Share on other sites

Hi Dick,thanks for your answer. These crashes happens with standard-planes and standard-gauges within the new microsoft-maps (included in weathersystem, flightplanner and gps). Second, you have to do changes in these sim-parts.So my northgerman-rivers-scenery (ngerrivs.zip) is not FS2004 compatible. :(I sent Christian Fumey an email with an error-description and the scenery-lwm-source. Maybe he knows a solution.Now I will look for other solutions for this problem. Maybe with vtp2 polys or other lwm-commands.Greetings from Germany,Rainer.

Share this post


Link to post
Share on other sites

Yes, I can confirm that LWM have changed slightly in FS2004. I have not looked further into this though.Cheers, Christian

Share this post


Link to post
Share on other sites

Hello Rainer,just to add something to the confusion:My tests with 'areafill' and LWM-masks were without a problem - no change to FS2002.But I have exactly the same behaviour - crash of FS2004 when displaying any map - when I include my own airport AFD bgls.Maybe you could check this?Cheers,Edgar

Share this post


Link to post
Share on other sites

Hi Edgar,i have tested it with no other scenery - as the usual microsoft-sceneries - activated. No other changes in standard-scenery.cfg as my own rivers, where no afd-bgls are included.Please confirm that you have no crashes with lwm-areafills1x1. Are they designed with ground2k? Which version? Have you really tested this with some changes in the maps and filled out a complete flightplan? Changing the weather in your area without crashes on the side, where the map is displayed? If this is really correct, then i have to wait until Christian will look at my sources. But there can't be an error... normally ;)Maybe, you can download my ngerrivs.zip and test it? Go to EDDH or Meppen (I don't know the icao-code in this moment).Ciao,Rainer.

Share this post


Link to post
Share on other sites

Hello Rainer,I will download your scenery later this weekend.I use Ground2k. I believe the version is not important, the produced *.asm files, which are compiled to bgl libraries, stay the same.I filled out flightplans in the changed area, although I did not touch the weather-page with the weather stations. I just used general themes.But I will retest it with my scenery.Cheers,Edgar

Share this post


Link to post
Share on other sites

Hi Edgar,yesterday I experimented a little with my scenery. It's hard to check out all things.At least my results are:If I only areafill a cell, there seems to be no problem. But if I draw a new lwm-polyline (lwm without shore at height -9999) above it, the crashes return.Have you placed new lwm-polylines in your scenery?Ciao,Rainer.

Share this post


Link to post
Share on other sites

Hi Rainer,just rechecked my scenery and had a look at your scenery. Its a fine piece of landscape!Unfortunately I have to correkt myself: I get crashes in the weather and the normal map as well. And I can repeat your crashes.But in an interesting twist: I get them only once!Sample: I choose Kiel as airport. after loading the flight, I choose the weather map (or the normal on), FS crashes.I repeat this: Restart sim, goto Kiel, choose the same map - everything is stable.The I slew to the North Sea, choose a map and FS2k4 crashes.The same applies for my scenery.Very strange indeed!As for your questions: Yes, I did use lwm-polies (with fixed and with -9999m heigth) and mixed them with AreaFills.Cheers,Edgar

Share this post


Link to post
Share on other sites

The same here - the LWM areafill (water) makes that area (land) disappear in the maps. FS2004 has crashed a couple of times, but always and only immediately after the installation of new bgl-files into the scenery folder. It rebuilds the database, starts loading terrain and crashes at about 57% loaded. Restarting the sim at this point makes everything work fine, and it will not crash if I exit and restart again. I have never had crashes when opening the map or the GPS!BamceEFHN

Share this post


Link to post
Share on other sites

Hi Rainer.A thought:Perhaps the problem is caused by mixing areafill commands with regular LWM polys.The areafills could be tried as a separate project ( aa_Rainer_AreaFills ) and the LWMS compiled separately ( Rainer_LWM_Polys ).The naming convention would force the areafills to be accessed first, then the LWM poly file would overdraw that.That might be worth a try.Dick

Share this post


Link to post
Share on other sites

Hi Dick,no luck with this experiment. I have tried it last week before I wrote here first time. I can't remember, if the crashes happens with ONLY this Areafill-bgl or if you have to add an area-lwm-polyline-bgl. It's possible to use lwm-polylines instead of the areafills and a ground2k-function called "imbrications" to avoid these crashes. Maybe at the following weekend I will release my new crash-free-rivers at the avsim-library.Please excuse my bad english. It's hard to write in a foreign language.Ciao,Rainer.

Share this post


Link to post
Share on other sites

Hi all.I've just come across what looks like the same problem; a custom-written BGL containing a LWM works well in the TDF previewer and in FS2K4, but usually crashes the map/weather editors. I've noticed that the crashes are less frequent but not eliminated if a TDF (shoreline) BGL covering the same area is removed.Has anyone got any news on this? I'm using a recently-downloaded copy of the FS2K2 SDK, so the BGLC version should be as up to date as it's possible to get.The tool I've been using to generate these is one I've written. It will take a resampler-style .inf and .raw file (which do not need to be cell-aligned) as input and output cell-aligned .inf, .raw, .raw landmap and watermap and corresponding .inf, LWM and TDF source for any shorelines, an ASD2-compatible shoreline map and EZLandclass project files. If anyone's interested, I'll add a Windows GUI and upload it.If I could just get the LWM working properly...Regards,Jim Keir.

Share this post


Link to post
Share on other sites

Hello Jim,I think the solution is to avoid areafill bgl-commands completely and replace them with 'hand-drawn' LWM polygons. At least I have no crashes anymore when I followed this advice from Rainer.Cheers,Edgar

Share this post


Link to post
Share on other sites

Hi Edgar.The 1x1 areafills just don't agree with the map.The LWMs are different for the default BGLS in FS9... and we'll probably need to wait for the terrain SDK to clarify the changes.I've used 4x4 areafills without crashing the sim, but the display is not right in the map view... for example, a landfilled area will show correctly, but the water polys on top of the landfill won't show in the map ( even if they are different BGLs ).Drawing a huge land poly around the water polys works, as you and Rainer indicate. That landfill could be a separate BGL, named something like "aaLandfill.bgl" to both identify it and to make sure it is before the water LWM polys in the datastream.Dick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this