Sign in to follow this  
bob.bernstein

VTP polygons with custom textures

Recommended Posts

Hi all, looking for a recap, perhaps an update to the August discussion on vtp polygons in fs9. At that time folks were talking about vtp2 polygons with custom textures crashing the sim at night...and vtp1 polygons not working.I'm just now experimenting with this type of design...so I made a point of learning to work with vtp polygons this weekend. VTP1 polygons did not display, which matches with the august discussion. VTP2 with custom texture using format of dxt1 + alpha showed with a black rather than transparent area. VTP2 with custom texture using indexed (8bit) color and setting one color to transparent (and making a copy of the texture named ...sp....fa....etc)resulted in proper display but crashing the sim at night....again matching some of the previous discussion. Has anyone found a method to properly display transparency in custom textures using either vtp1 or 2 in fscof, without any crashing at all?Bob Bernstein

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Bob.VTP1s don't appear in FS2004. They don't crash... but the darn things just don't want to show up.VTP2s are fine:http://forums.avsim.net/user_files/40998.jpgI've attached a zip file with the poly code, BGL, and the texture. Take off from C59 at night, and head north.For FS2002 there was some concern about VTP1s not showing at night, but this was due to some misinformation in the SDK. Here's the texturing format:TextureDataStart label word BeginTexture0 label word VTPTextureName "Santa.bmp;Santa.bmp;Santa.bmp;Santa.bmp;Santa.bmp;Santa.bmp" VTPTextureType 3, 0, 0, 4 EndTexture0 label wordTextureDataEnd label wordEnclosed in quotes, 6 semicolon-separated names ( in this case all the same ). "Winter.bmp;HardWinter.bmp;Spring.bmp;Summer.bmp;Fall.bmp;Night.bmp"Dick

Share this post


Link to post
Share on other sites

yep, I agree yours works great, mine has limitations....yet my texture looks same as yours..Always fun...I did try to determine if my crashing on startup was due to not including all the seasons with my texture...as I'd filled all the spots on the texture box in ground2k. Doing so fixed my crashing during the day but it still crashed at night.I'm studying the differences...thanks as always for the help....When creating your texture did you use one of martin's utilities to code the black as transparent?Bob B

Share this post


Link to post
Share on other sites

Hi Bob.I usually save my bitmaps as 24 bit, uncompressed TGA from PaintShopPro7... then use MS's imagetool to convert to 8-bit mipped with alpha.Resampled slices with CUSTOM names need to be vertically flipped after you make the autogen ( which is not flipped ). Otherwise you need to save a copy of each texture for autogenning.Vertical flipping can be done by XNView very well. Then they can be alphatized ( black color only, I think ), by one of Martin's tools... then MS's Imagetool can batch process them as 8-bit mipped for CUSTOM textures with transparent alpha for VTP2 placement.I think Martin's tools are fine, but make sure you have his latest DLLs, as some earlier versions had problems.Elrond Elvish was thinking of making a tool to automate the alphatizing, flipping, mipping, 8-bitting... but I don't believe he ever got to it.==================As long as you're experimenting, why not try to place my texture somewhere... or copy and rename it as the texture names you need, and see if the sim is still crashing. If so, then it's not the textures but the code.Dick

Share this post


Link to post
Share on other sites

Hi Bob:not to confuse the issue (and I think it's probably better to use Rhumba's basic step-by-step approach first) but I have used a somewhat different approach which works well in FS9 (though autogen doesn't show up in FS2002). I haven't actually tried whether it works at night too - I'll check later tonight - but it works well for all seasons with one set of textures only. Also, I'm using DXT1 textures, not 8-bit extended.Here are the two threads:http://forums.avsim.net/dcboard.php?az=sho...id=14697&page=2http://forums.avsim.net/dcboard.php?az=sho...id=14554&page=3Also, Luis provides an elegant use of grayscale gradients to blend photoreal with adjacent default landclass in this thread:http://forums.avsim.net/dcboard.php?az=sho...id=14623&page=2Cheers, Holger

Share this post


Link to post
Share on other sites

Hi Holger, just wanted to note that you say you use dxt1 format for textures, but you don't explicitly state if you are trying to use the alpha channel to display as transparent. This one feature appears not to work with dxt1, and therefore eliminates it as a suitable file format for my project.Bob B

Share this post


Link to post
Share on other sites

Hi Bob,I posted here, about a week ago, that I used DXT1 with alpha to get the blend between the CUSTOM textures and the default LandClasses. I was wrong! Just after seeing your post, I checked my texture folders and I can confirm that I use 43KB DXT1 for central tiles and 87KB 8-bit with alpha for the border tiles that need to blend with the LandClasses.Kind Regards, Luis

Share this post


Link to post
Share on other sites

Thanks Luis, I was suspecting exactly that as I went back over these threads this weekend. Nice to be sorting it out.B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this