Sign in to follow this  
arno

Reflective textures in FSDS2 scenery objects

Recommended Posts

Hi guys,I have in vain tried to produce a reflective result with textures on FSDS2 scenery objects.I have made what I believe are correct bitmaps via tga files and converted them to DXT3 Alpha.Also marked the texture as "reflective" in FSDS2 - but no success.I can see that the grayscale used in the alphachannel affects the texture transparency but no reflective surface shows.I have a ASUS Radeon 9800XT graphics card installed.Anyone, maybe Arno have a clue?BestBjorn

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I remember reading "somewhere" that in order for textures to be reflective on scenery onjects, they must be saved without mipmaps. This may not work though, and it may be a limitation of FSDS2, or perhaps of the FS scenery engine - I'm not sure which.ANyway, it's worth a try.- Martin

Share this post


Link to post
Share on other sites

I have read somewhere that DXT 3 with alpha supports Transparencys.DXT1 with alpha supports shiney textures.Have used this to some effect to acheave this end.Joe W.

Share this post


Link to post
Share on other sites

Hi Bjorn,I don't use FSDS myself anymore, but in GMax you can only have reflective textures if you set the texture type to aircraft. If it is set to scenery it does not work (this is more something in the FS scenery engine I guess). So I think that is your problem as well. You could try to set the texture type to 2 (which is aircraft) in the TextureList command.

Share this post


Link to post
Share on other sites

No, that is not true. DXT3 is used both for transparancy and reflection. That is why you can't combine them directly. Normally the alpha channel gives transparancy, but if you add a command for reflection, it will become reflection.In theory you can also use DXT1 for transparancy and reflection, but then alpha channel is limited to 1 bit then (on or off) so that doesn't give the desired result in most cases.

Share this post


Link to post
Share on other sites

You can make an object both transparent and reflective and have specular level, like glass, by adjusting the qualities of the material. The image map (with alpha)is set to having the reflectivity properties, and the base material is adjusted for the level of transparancy and specular. This process works in either FSDS2 or Max. You must however, apply these as different materials to separate polys. If you are trying to apply the process to say just one, two faced poly, like the side of a building, it won't work if you are relying in the transparancy to make your windows. You will have to cut the window polys and apply the glass material to those polys and apply a different material to the solid parts of the wall. http://forums.avsim.net/user_files/58996.jpgLou

Share this post


Link to post
Share on other sites

Thanks for the tips Lou,What I am trying to archieve is a reflective coating on a building part - cube - covered on the sides with a bitmap.This part has no windows and I desire to archieve an shiny aluminium look.My bitmap has been "doctored" into a DXT3 Alpha and set as "Reflective" in FSDS2 but the surface just looks "normal" only more or less transparent depending on the alpha grays I use.The polys themself does not become transparent - just the bitmap "coating" so this lead me to believe the bitmap is OK.Is my problem related to FSDS2 Part Property settings or maybe the bitmap itself? (I have filled its alphachannel with a single gray color)Bjorn

Share this post


Link to post
Share on other sites

Have you tried setting the texture type to aircraft as I wrote before? In GMax that is the only way to get reflection working, if the texture is set a scenery type it does not work.I don't know if FSDS allows this change in the GUI, otherwise you might need to tweak the source a little bit :).

Share this post


Link to post
Share on other sites

Thanks Arno,Will look in my scasm 2.88 manual if there is a way to assign textures as aircraft type. In FSDS2 I cannot find anything in the GUI.Bjorn

Share this post


Link to post
Share on other sites

You must look for the TextureList command in the SCASM source. It will now have the type set to 6 in one of the parameters (I think it is the first). You must change it to 2.

Share this post


Link to post
Share on other sites

Could you paste here how the TextureList command looks when you export from FSDS? Maybe the reflective part is not there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this