Sign in to follow this  
Hornit

FS Genesis Landclass problem

Recommended Posts

I had worked on a scenery a while back in fs 2002 last year before I went to fs9 and have been using FS Genesis US landclass since it came out. The landclass enhancement is really good for the most part but I think i have stumbled into something a bit weird and cant come up with an explanation so i thought I would run it by the "gurus" here. I use Airport for Windows latest version and a few other design programs for macros etc so Im pretty familair with scenery design but not quite as well versed as some of you obviously are. What is happening is that whn I use the FSG landclass bgl I seem to lose some or all of the nice new grassy polygon the default airports sit on. I dont use a new polygon on my creations, just usually exclude the buildings I want gone and add my own taxiways and grass where its needed. In these screenshots you can see the problem, the grass polygon(default) goes away or gets changed dramatically with the use of the new LC bgl. I thought it was due to me adding things like excludes/flattens etc, but thats not the case, it happens at other airports I fly around also. Sometimes it is only a portion of the polygon that is affected. http://www.x-plane.org/users/hornit/lh.jpghttp://www.x-plane.org/users/hornit/lh1.jpg If I remove the LC bgl the grass is back! You can see this at other airports also, I tried it at KPSM, Pease tradeport in Portsmouth, NH and its very evident. I have done only limited testing but it affects at least some of the sceneries i am working on so I would like to fix it if possible. This Landclass is a great enhancement and I would really like to use it. I have posted over at the FSG forum but thought others might like to know or at least test this to see if they also have the problem. I may have something screwed up but i dont think so. All I have to do to duplicate the problem is reinstall the FSG LC bgl and the problem is back. Justin does not think it should have any effect, but its obviously doing something.Hornit

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Hornit.This site has the CTD fix for airport textures ( Joachim's terrain.cfg fix ).http://jobia.bei.t-online.de/crashdes.htmLook for:crashto.zipfor the zip file that has the terrain.cfg fix and the airport textures.This will fix the problems with Justin's landclass.Actually, his landclass is fine, it's the Airport Backgrounds that are the problem. All the airport background numbers in the default terrain.cfg are fakes. All ABs are the same masked blending... doesn't matter what number was used in the VTP poly. This masking has several problems, one which you have discovered.Joachim's terrain CFG fix adds actual textures instead of the masking/blending to make the ABs. This will also solve some seasonal CTDs in the sim. Do a search on "seasonal CTD" in the main FS forum for more info than you'd possibly would want. ;)Our good friend Holger promoted this fix against some opposition, and was vindicated when we found seasonal CTDs in the default scenery. I also recommend changing all instances of MaskClassMap in Joachim's terrain.cfg to "MaskClassMap=0".If you do this, Justin's amazing landclass ( and everyone else's ) will be fine.Dick

Share this post


Link to post
Share on other sites

Wow, thanks! Now I have one more question since I dont read german :)How much do the airport background textures change? I happen to really like the ones that we have in the default. Can i still use the default ones? Just curious, going to look at the fix now!Hornit

Share this post


Link to post
Share on other sites

Well I applied the fix and yes it solves the problem but why did we go and change the background textures? Were they the reason for the problem? IMHO the patch textures are far less pleasing than the default. I tried changing the textures to my liking and it appears to crash the sim. not sure what is up with that, but went back to default for now. All I did was to pick one of the textures I liked and rename it to the ones i did not, not sure why that is not working. I personally think the default airport textures were a huge step in the right direction and if it means I have to go back to the default LC then i guess that is what i may do. I find it hard to believe we cannot have those nice textures AND the proper display of add-on LC without dorking up something else. If anyone has any ideas about making this work I'm all ears.Hornit

Share this post


Link to post
Share on other sites

There is no other fix.There are no default background textures. They are a blended mask, and they cause the problem. All the airport background numbers in the terrain.cfg file are only for backward compatibility... they are all the same blended mask, and the appearance depends on the underlying landclass.They cause the seaonal CTD problem ( crash-to-desktop ) as well. Somebody might come up with a different set that would please you, or you could make your own.The appearance of the default Airport backgrounds are nice, but they cause problems. If you decide to avoid all addon landclass, you could still have the program crash unexpectedly at seasonal changes in the sim.Dick

Share this post


Link to post
Share on other sites

Im now succesfully taking the textures I like and renaming them to the convention used in the crash patch textures. Seems to work ok actually and I am just about finished. Thanks for all the advice and help its appreciated! Just for the record I dont think i ever had a crash which I could attribute to this problem ,but I admittedly usually manually set up my weather and seasons, so I dont see the transition at all.Hornit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this