Sign in to follow this  
scott967

FS9 ILS problem w/ FS2k2 airport?

Recommended Posts

I don't know if this is a known issue, but I installed an airport addon (mke2004.zip) consisting of 4 scasm excludes (genexclude) and a main scasm scenery file, and an AFCAD2 file.I had a problem with ILS LOC not being displayed in my A/C, so I went to work.There are 4 ILS systems at KMKE, 2 on 110.3 and 2 on 111.5. One of each was not being received, though they were showing up on the gps.So I removed the new AFCAD to use the default: same problem.I dug deeper. One thing I discovered, is that if the excludes are loaded, it kills the AFCAD visual scenery, regardless of scenery.cfg level. So, I disassembled the excludes, and then used excbuilder2 to build AllObjects excludes of the same size in FS9 XML. Now my AFCAD visual objects were showing, but still missing ILS.I disassembled the main scenery file. It contained a lot of FS2k2 visual scenery (runways, taxiways, etc) and also some FS2k2 navaids (ILS and beacons). It also had a facility menu entry. So I edited the navaid and facility stuff out and reassembled. Now at least the ILSs are working. I don't think I've caused any problems on a quick slew, but will have to do some actual game play to make sure.So, has anyone experienced this before? Is the cause understood? Maybe having 2 ILS on the same freq on the same FS2k2 airport is causing FS9 to hiccup?Here is what I removed from the scenery file:; ----------------------------------------; VOR/ILS Section; ----------------------------------------; frequency 110.30; LatRange( N42:49:09.33 N43:04:05.00 ); ----------------------------------------ILS2( 110.30 14 D2 0.00 IBLY ILS_19R N42:55:55.17 W087:53:50.51 220 187.79 N42:57:14.92 W087:53:35.60 220 3.00 910)ILS2( 110.30 14 D2 0.00 IMKE ILS_01L ; 80 W087:53:47.40 220 0 100.00 100.00 0 100.00 0 Gen_Mitchell_Intl ); ----------------------------------------; Miscellaneous section; ----------------------------------------; LatRange( N42:49:09.33 N43:04:05.00 ); ----------------------------------------IM( N42:55:52.19 W087:53:56.30 220 0)MM( N42:55:29.00 W087:54:00.63 220 0)OM( N42:50:25.85 W087:54:57.17 220 0)MM( N42:57:38.57 W087:53:36.45 220 0)OM( N43:03:29.27 W087:52:30.79 220 0)MM( N42:56:12.92 W087:55:17.72 220 0)OM( N42:54:36.25 W088:02:10.53 220 0); ----------------------------------------scott s..

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The same frequency on opposite ends of the same runway problem is known. If you use FS2K2 SCASM style programming, you will get the problem. You need to use FS2004 XML style programming to fix the problem.See the basics of scenery design pinned at the top of this forum for the tools necessary for XML style programming.W. Sieffert

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this