Sign in to follow this  
Guest tasnvs

Autogen theory

Recommended Posts

Hi guys. Was wondering whether anyone might be able shed light on the following two issues relating to autogen. (1) What are the reasons for autogen objects not sticking? I've experimented with the annotation files of default and photo scenery ground tiles and noticed that some times building objects will not resolve in the FS environment. Size is a definite cause. Big objects just won't show. Density is another factor. This should only influence how many objects are displayed a given distance, but I get sense that too many objects will prevent some from showing. This is apparent after introducing trees. Buildings that once showed, no longer stick. (2) Why do some autogen buildings sink into the terrain? This seems to be related to level/story height. One-to-two story buildings actually look like they vary between half and four stories to me. I think therefore that half and one story buildings might be vulnerable to sinking where the terrain slops away. The effect is to produce buildings that only have their roof showing. Also, the roof textures flicker as if they're suffering from a z-bias problem. If anyone's noticed these problems or has any solutions, I'd appreciate the input. Cheers, Matthew.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The number of vegetation rectangles is limited to 600 per tile and buildings to 300. If you also use library objects, the sum of buildings and library objects are included in the 300 limit.I have had problems with row houses which may or may not show depending upon the length/width ratio.George

Share this post


Link to post
Share on other sites

Hi Guys.Yes, Agent is the one I'm now using. It's a beut! Thanks for the tip though.Ta for the figures on autogen objects George. The problem I'm finding is that I can't get very many objects to show. I've not used any XML objects and may be 20 or so medium sized factory-style buildings. The ground tile are not surrounded by areas heavy in autogen either.Another thing I've noticed is that if I edit an annotation file that I've created by changing some of the building sizes (say in a row of houses), the new ones won't show in full - just some of them.Cheers,Matthew.

Share this post


Link to post
Share on other sites

Hi thereJust a thought. Have you got the "AutoGen Density slider in the display options, set to MaxCheers Norman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this