Sign in to follow this  
Guest abent

OK...Since no one will answer my question...

Recommended Posts

about how to get missing autogen to reappear after a placing a texture in G2k4...LOL :D ...how do I get rid of autogen completely in an area so I can add my own custom buildings? Catching my breath...Thanks,Adam

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you tried an exclude? That should clean the area nicely :).About your other question (must have missed that one), you new polygon made with Ground2k4 probably does not support autogen. Autogen does not work on VTP polygons that have a user defined texture.

Share this post


Link to post
Share on other sites

Arno to the rescue again! Hi Arno. The texture I used is a default MS texture (105 Y Medium City Ubran Grid Wet). It's weird as some places I put the texture, buildings/trees appear. In other places there is some autogen mainly around the outside edges of the texture and in some spots none.Yes, I could try an exclude...doh! Ofcourse, I'd rather fix the autogen problem.Thanks,Adam

Share this post


Link to post
Share on other sites

Hi Adam,Do you have other addon scenery active in that area? Some scenery can also have an excluding effect on the autogen. For example ground polygons created with FSSC or AFW.

Share this post


Link to post
Share on other sites

Hey Arno...no scenery within a few Microsoft miles. Some of these textures are several miles from any models I have created whether ground objects or otherwise. A mystery to me. Things just seem to have gotten very strange since Ultimate Terrain - no blame - I love UT. However, I don't seem to recall any problems like missing autogen or missing city night lights before UT. Who knows...Thx,AdamEdit: BTW, I only use Gmax, not FSSC or Airport for Windows if that helps.

Share this post


Link to post
Share on other sites

Adam,I have found that UT sometimes has excludes that are a little large near default bridge objects they've excluded. Anything nearby like that?Jon

Share this post


Link to post
Share on other sites

That is a very interesting suggestion Jon. I will go look now but come to think of it, several of these areas are near rivers which would naturally have bridges. I don't suppose there is much then that can be done about it as I would know of no way to exclude an exclude :( . By the way, the screen shots of your Victoria/Vancouver project blow me away. I'm dying to be able to create ground textures like your Ogden Point. After looking at something like that, my work appears cartoonish by comparison.Thanks very much,Adam

Share this post


Link to post
Share on other sites

Adam, have you tried disabling all other addons, including UT, to see if the problem disappears?Jon

Share this post


Link to post
Share on other sites

Adam,I had the same problem when I was doing Johannesburg Intl. In the end, I placed all my Gmax objects by changing the XML file's "altitudeIsAgl=" to FALSE and to insert the elevation of the objects in the "alt=" field.For some reason, the missing autogen then returned.RegardsJohan

Share this post


Link to post
Share on other sites

I'll give that a try right away. Thanks John!Johan, thanks very much. If I start up FS without UT as per John's suggestion and the problem persists, I'll give yours a go. Actually I'm using BGLC now as the scenery is done in the 2002 gamepack but it's no problem to expotr in XML format.AdamAdam

Share this post


Link to post
Share on other sites

Disabling UT brings back all autogen. Hmmm...any suggestions gents?I don't want to leave UT disabled for obvious reasons but need to find a way to overcome this. As previously stated, enabling MS bridges does not fix the prob. Could there be any other UT setting that might affect this?I appreciate all the help. Adamhttp://forums.avsim.net/user_files/128995.jpg

Share this post


Link to post
Share on other sites

I'm absolutely certain it's UT's night lighting that causes the autogen removal. When you think about it, the only way that UT's night lights could appear above photoreal scenery tiles is if they are modeled objects. My guess is that every light is a tiny low poly object textured with a bright color. It's really a very innovative approach. In the FS world, there's this automatic exclude area for autogen around any object. For a tiny object that exclude area wouldn't be large but those lights are going to be on road areas adjacent to places you're going to want to put houses or vegetation. I was stumped when, after releasing my Phoenix Photo Scenery, users were coming back with complaints about the scarcity of autogen. For those that have watched my evolution as a scenery designer, you know how much value I've put into creating huge amounts of autogen houses and vegetation over large areas. Many of you are probably using my autogen editor. So you can imagine how baffling that was to me to hear that my scenery lacked autogen. In the end the solution was for the users to turn off UT while flying over the scenery. Not a desirable solution but one that worked. There is mixed feedback as to whether simply turning off the night lighting gives you back all the autogen you expect. I don't own UT so I can't look into how they turn on or off features but, if the lights are truly modeled objects, they'd have to exist in .bgl files in UT's scenery directories. If those .bgl files are mixed in with other files that define active scenery they'd have to be moved or renamed to keep FS from loading them. Perhaps they keep the lights in a separate scenery area that can simply be disabled. However, if they turn off the lights by simply changing a texture then the excludes would still remain. I'm very curious about how it works.Art

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this