Sign in to follow this  
Guest sgreenwood

Importing SRTM data into MICRODEM

Recommended Posts

Dear all:I want to import SRTM dato to microdem, but SRTM data is in .hgt format.Is there a way to convert that format or import it in Microdem to use MDEM2BSQ to create FS mesh terrain?I want to make test to make my Peru Mesh terrain in South America when all the data be ready.Thanks.Alfredo Mendiola LoyolaLima Peru

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Alfredo,I'm new to this format, but I found out that you first select File/Data Manipulation to open the data manipulation window.From that window select Resample/Dem/Dem General. This will open another window from which you need to select the path to your heightfield file in the top dropdown and "SRTM Heightfield" from the bottom dropdown.Next click open and you will se a window with pre-filled data. It contains UTM info, SW corner coordinates, etc. Review it but you shouldn't need to change anything. Select OK and a new window will open in which you will give your DEM a name. No further information is needed.Have fun!Regards,Steve Weatherwax

Share this post


Link to post
Share on other sites

Gentlemen,The data I've downloaded is in .hgt.zip format. MicroDem can read these zip files directly using "File - Open Dem".Once opened, use "File - Save Dem - MD Dem" to save it in the format required for MDEM2BSQ.Menu options "Calculate - Map Window Corners" and "Analyze - Header" provide the information you need for the .inf file.Search MicroDem Help for .hgt and view the "SRTM Height Files" entry for a bit more info. (at least in ver 14.37.29.1, Dec 23 2002) Steve

Share this post


Link to post
Share on other sites

Steve,Thanks for the tip. That sure is an easier way to do it.Regards,Steve Weatherwax

Share this post


Link to post
Share on other sites

Thanks for your help, i'm importing US SRTM data and is incredible.I hope that the SRTM data for South America be available soon.Thanks.Alfredo Mendiola LoyolaLima Peru

Share this post


Link to post
Share on other sites

Hello Cazador!Which is exactly de source of this Elevation model? is this international data or Peruvian specific data? it would be greatfull to get now real peruvian Meshes because available mesh's are not satisfiyng, making only airports and lakes to craters...Which LOD would be generated?Have you tried getting data from the IGN or is this to much expensive? i hope you get a good work... pay- or freeware, it doesn't matter ;-)SaludosFrancis

Share this post


Link to post
Share on other sites

Dear Francis:I'm importing the GSTOPO30 data with Microdem to edit it and rebuild point by point the elevations of specific area, for example the main airports surround.I'm working eidting the Anta Huascaran mesh terrain i have completed 1/4 of the mesh area.The IGN doesn't has DEM files for Peru, but i'm wainting the South America SRTM data to generate the All Peru Mesh terrain with LOD8 to preserve good frame rate and good texture load times.Today i created a mesh terrain with the Mount Rainier SRTM cuadrant N46W123 and the mesh generated by the Terrain SDK was very good, and the improve on the terrain was big.Thanks NASA and USA!!!!Thanks.Alfredo Mendiola LoyolaLima Peru

Share this post


Link to post
Share on other sites

Waiting for Argentinian mesh here too!--Daniel R. CareriUshuaia, Tierra del Fuego, Argentina

Share this post


Link to post
Share on other sites

HelloI just downloaded the Microdem Terra base II 6.02 and installed. The problem here is that wwhen loading files in the *.hgt format, I don't get in any place an option as to save or convert to DEM format....I am just wondering what is going on....any help will be much appreciate it.Rafael

Share this post


Link to post
Share on other sites

Hi Rafael:here's how I do it (there may be other ways):1) Goto 'File > Data Manipulation', then2) 'Import > DEMs > Single DEM (standard Series)'3) Choose Files of Type 'SRTM heightfield' and go to your data directory and highlight the .hgt file you'd like to import.4) Before clicking on 'Open', highlight the name of the file, without the '.hgt' part, and press Ctrl-C (copy)5) Click on 'Open', then press Ctrl-V (Paste) when asked for a name for the new DEM. This way you get the same name for the .hgt and .DEM file, which makes it easier to handle when dealing with more than one file at a time.Hope that helps,Holger

Share this post


Link to post
Share on other sites

Hi Holger,Thanks for your reply, but it seems that I am talking either of a different type of files or another Microdem program or version...>here's how I do it (there may be other ways):>>1) Goto 'File > Data Manipulation', thenSee in my snapshot that this option on the File menu doesn't exists at all, and it doesn't exists in any other program menu.The file I have loaded has an extension of HGT as you can see and I am using the Microdem program /Terra base II 6.02 verion that I just downloaded a few days ago.http://forums.avsim.com/user_files/2552.jpgThanks,Rafael Sanchez>2) 'Import > DEMs > Single DEM (standard Series)'>>3) Choose Files of Type 'SRTM heightfield' and go to your>data directory and highlight the .hgt file you'd like to>import.>>4) Before clicking on 'Open', highlight the name of the file,>without the '.hgt' part, and press Ctrl-C (copy)>>5) Click on 'Open', then press Ctrl-V (Paste) when asked for>a name for the new DEM. This way you get the same name for the>.hgt and .DEM file, which makes it easier to handle when>dealing with more than one file at a time.>>Hope that helps,>>Holger

Share this post


Link to post
Share on other sites

Hi Rafael,How are you bringing the data into MicroDem?Following the approach I suggested above:>The data I've downloaded is in .hgt.zip format. MicroDem can read these >zip files directly using "File - Open Dem".>Once opened, use "File - Save Dem - MD Dem" to save it in the format >required for MDEM2BSQ.The Save option is available as illustrated in the attached image.Steve

Share this post


Link to post
Share on other sites

Thanks for the tips, I emoved the progra and installed again and load the zip format file instead of the hgt file directly and now works, the only thing is that the pictures shows in gray scale and not in colors...Rafael

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this