Sign in to follow this  
Holger

Using CDED data - help!

Recommended Posts

I've been trying to learn how to create mesh using the new Canadian .75 arc-second data. What I'm trying to do first (just to get the hang of this stuff) is to create a mesh bgl from a single DEM file from the GeoBase.ca site.I opened the DEM in MircoDem and saved it as a 16 bit BSQ file. I then ran it through resample etc to get a bgl file. So far so good. The results aren't so good though. I get this:http://forums.avsim.net/user_files/50188.jpgPart of the mesh is very good, lots of detail, but there's that huge annomaly. I get similar effects with other CDED dems I've tried.This is the inf file I used, based on the sample that Holger posted for me:[Destination]; LOD = {Auto, 0..n}; LOD = Auto tells the resampler to pick the closest LOD to the;source;cell size. Specifying a number will force an LOD. This can;be used for undersampling or oversampling.LOD = 10DestDir = "C:Documents and SettingsKen PetersMy DocumentsKenDEMprojectsEast Vancouver island"DestBaseFileName = "092f08_0100_demw"UseSourceDimensions = 1[source]Type = ElevS16LSBSourceDir = "C:Documents and SettingsKen PetersMy DocumentsKenDEMprojectsEast Vancouver island"SourceFile = "092f08_0100_demw.dem"NullCellValue = -9999Lat = 49.500000Lon = -124.5000000NumOfCellsPerLine = 1201NumOfLines = 1201CellXdimensionDeg = 0.000208333333333333CellYdimensionDeg = 0.000208333333333333ScaleinMeters = 1.0Can any one tell me what's going on?PS, Note to Holger: there's a new version of MicroDem just posted that reads the Canadian DEMs correctly, including the correct rows and columns.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

OK, I figured it out. The problem is the ScaleinMeters parameter is wrong. It should be 0.1. The scale is in decimeters - who uses decimeters?Today I figured out how to merge the CDED DEMs and I made my first decent mesh file!Here's a screenie of Horn lake, Vancouver Island:http://forums.avsim.net/user_files/50244.jpgThanks again for your help Holger!

Share this post


Link to post
Share on other sites

Hi Ken,you think you're having problems? This is the Chilliwack/Hope area set up with the new version of Microdem:http://forums.avsim.net/user_files/50245.jpgTurns out we're victims of a bug in Microdem. As much as I like this software and its rapid-fire updates, there doesn't sem to be much in the way of beta testing - I know, it's freeware (and essential for FS mesh design, IMHO), so I stop the complaints right now :-bla What seems to be the problem is that Mircodem interprets the CDED1 elevations in decimeters but saves the 16-bit BSQ (and regular MD .dem too!) as meters. Ergo, we end up with a mesh that's 10x higher than it should be ;-)So, the anomaly is the elevation of the compiled LOD10 mesh, wheras the extent in your screenshot is perfectly fine. Remember the bit about only fully covered LOD10 grid cells being displayed. Here's a TMFViewer screenshot of your tile, 092f08w.http://forums.avsim.net/user_files/50246.jpgAnd here's the map view with the compiled mesh installed; you can determine the coverage by the contrast in detail between the surrounding LOD7 mesh and the new LOD10 tile.http://forums.avsim.net/user_files/50248.jpgThe visible detail in FS (here with Terrain_Max_Vertex_Level set to 20), is a little less spectacular than your screenshot but it's more accurate too. Here's the eastern edge of CAT4:http://forums.avsim.net/user_files/50249.jpgWhat to do about the Microdem bug? Well, I always keep a copy of the previous build so I'm reverting back to that and keep using the 3DEM geotiff route. However, I tried setting ScaleinMeters = in the .inf file to 0.1 and that seems to be working too (though the DOS window gives a warning about "possible loss of precision"). Any other ideas, anyone?Cheers, Holger

Share this post


Link to post
Share on other sites

Ooops! yet another crossing of posts ;-)Congrats, Ken, looks great!Cheers, Holger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this