Sign in to follow this  
Guest

Terrascenery 2.1 keeps hanging on render

Recommended Posts

I have been trying now for a couple of days now to get Terrascenery to work. I read and followed instructions explicitly. I am trying render a 40 X 40 square mile of area. I followed the instructions on Ken Salters site as how to setup for rendering purposes. The first time I ran it it seemd to have almost completed the process and was at stage 4 of 4 on the day render. It had just started to write to disk some targa files and froze up. So I had little choice but to reboot, becuase of no keyboard response at all. When system booted up scandisk started up and told me that there was a invalid long Dos filename. That I needed to run Scandisk for Windows. This I did and it found a damaged file where Terrascene was installed. It was called a output file. That scandisk needed to repair the file and in order to that. The file would have to be deleted.No problem in doing that. I had terrascene setup to save the tsp project file before starting with the render process. So I started a fresh render of the project I had saved. This time however it got to about stage 2 0f 2 in the daytime render and froze up again.So what do I need to do? Start from scratch with another project? reinstall Terrascenery? I have 128 mb of ram, I know that it is recommended to have 256mb. Also I have over 4 gig of space free on the drive where FlyII is installed. I have over 8 gig free on the drive where terrascenery is installed , this being where my windows OS is installed. Does terrascenery need to be installed on the same drive as FlyII? I have to sympathize with Richard Hill somewhat with some of his earlier posts here. But Im not ready to throw the towel in yet. I have seen alot of the work others have been succesful in using Terrascenery. This program is amazing in what it can do. Im sure that it is something that Im not doing correctly. But I cant put my finger on it. Also I am letting Windows handle the system resources , and Im shutting down all programs that may be running in the background before trying to render anything. Any Ideas?TonyWhy Oh .... Why cant I ????FlyII! ver. 2.30Directx 8.1nVidia drivers 28.32ECS K7S5A SOCKETA /DDR/ AUDIO/ATX MB, DDR 128MB PC-2100 266MHZ MEMORY ,AMD ATHLON T-BIRD 1.2GHZ 256K FSB266 PGA , NVIDIA GEFORCE2 MX-400 64MB 4X-AGP

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Tony,This may or may not help, but it worked for me.Make sure that the 'One image per globe tile' box is not checked, and try again. (This came from Todd) Is the area contained within a globe tile boundary?Colin

Share this post


Link to post
Share on other sites

Colin, Here are two screenshots of my settings and actual area chosen to render. I hope the area image gives enough detail for you to see. Let me know. TonyWhy Oh .... Why cant I ????FlyII! ver. 2.30Directx 8.1nVidia drivers 28.32ECS K7S5A SOCKETA /DDR/ AUDIO/ATX MB, DDR 128MB PC-2100 266MHZ MEMORY ,AMD ATHLON T-BIRD 1.2GHZ 256K FSB266 PGA , NVIDIA GEFORCE2 MX-400 64MB 4X-AGP

Share this post


Link to post
Share on other sites

bumpTonyWhy Oh .... Why cant I ????FlyII! ver. 2.30Directx 8.1nVidia drivers 28.32ECS K7S5A SOCKETA /DDR/ AUDIO/ATX MB, DDR 128MB PC-2100 266MHZ MEMORY ,AMD ATHLON T-BIRD 1.2GHZ 256K FSB266 PGA , NVIDIA GEFORCE2 MX-400 64MB 4X-AGP

Share this post


Link to post
Share on other sites

Hi Tony!Just a little thing caught my eye:you have checked the "use existing segments" button. Are you sure your TGA segments where done before and therefore, already exist in the output folder?Sorry if this is evident to you! A small attempt can't harm anyone.Pascal :+

Share this post


Link to post
Share on other sites

Thanks Pascal, This may be the problem. I guess I can say that no they arent there. As this is the first time I have tried to use Terrascenery. I would add this though. The screenshot isnt actually mine. I copied and pasted it from the tutorial site. I took their advise on how to setup for Rendering. Maybe this needs to be looked into? I hope this works for me. I will let you know how it goes.TonyWhy Oh .... Why cant I ????FlyII! ver. 2.30Directx 8.1nVidia drivers 28.32ECS K7S5A SOCKETA /DDR/ AUDIO/ATX MB, DDR 128MB PC-2100 266MHZ MEMORY ,AMD ATHLON T-BIRD 1.2GHZ 256K FSB266 PGA , NVIDIA GEFORCE2 MX-400 64MB 4X-AGP

Share this post


Link to post
Share on other sites

Ahhh... thing come clearer!!In fact, you have taken the render box screenshot from my tutorial (this pictures reminded me something, didn't know what... :-lol )!Sorry for beeing responsible for your mistake! In fact, my tutorial is NOT for normal TerraScene use. (It's an ENHANCED TS Tutorial)It explains how to use TS in several steps with some heavy Photoshop adjustments in the middle. I launched TS a first time, but didn't slice the scenery so I could repaint the files before slicing again. The box on the screenshot is for the final slicing. Only then I asked TS to "use existing segment"This said, I would not advise to use my technique if it's the first time you try TerraScene.What probably happened here is that TS looked for some picture files inside his output folder, but couldn't find them.There is another scenery tutorial on Saltydog's web site, but don't use it, it's only for older versions of Fly! II and Terrascene.In fact, TerraScene is VERY easy to use! You can keep default parameters for land and line types. Uncheck "use existing segments", AND be sure "relief shading" option is CHECKED (else you won't have any moutain shading). You may want to "delete segments after merge" (i.e, delete the small image files used to create the big one), you usually won't need them afterwards.Also, give a name to your scenery in the project option (you can access here the shading and snow parameters if you want to change them). And go...An important advice yet: after the Fly! slicer finishes his job, go to the Fly! II/Data folder. Look at folders date, and DELETE ALL FOLDERS WHICH WERE CREATED AT PRESENT DATE!That's all! If you want later further customization, read the TS manual, it's very clear (no need for another tutorial). TS is powerful and customizable. You can even make some beautiful maps with it, just need to add the cities/places names!Hope now TS is going to work fine for you!Cheers!Pascal :+

Share this post


Link to post
Share on other sites

Pascal & Meco, Would it have any effect on the render if I have already used DexImport to place a runway that Randall made for me? I did this before I tried to use Terrascenery. Can I leave it there? This is a non-existant Airport in the FlyII database. But it does exist in reality, it is I96 in Columbia, Ky which falls in the 39 X 39 square mile area that I have chosen to render. Also I would like to use the option for water mask , due to the fact that there are two rather large lakes in the area. So if I can use water mask option , should I do this in another step before I do the final render? TonyWhy Oh .... Why cant I ????FlyII! ver. 2.30Directx 8.1nVidia drivers 28.32ECS K7S5A SOCKETA /DDR/ AUDIO/ATX MB, DDR 128MB PC-2100 266MHZ MEMORY ,AMD ATHLON T-BIRD 1.2GHZ 256K FSB266 PGA , NVIDIA GEFORCE2 MX-400 64MB 4X-AGP

Share this post


Link to post
Share on other sites

Im done with the first phase. But upon reading the post from Meco , I noticed something. I need to clarify something on the last phase. When it comes to making the pod. I noticed that Meco has the FlySlice box checked again as one of the options. Do I leave this box checked or not?Sorry to be such a pain. But its actually working correctly for me now. It went thru the first phase of the render with no hang up. :-jumpy :-jumpyTonyWhy Oh .... Why cant I ????FlyII! ver. 2.30Directx 8.1nVidia drivers 28.32ECS K7S5A SOCKETA /DDR/ AUDIO/ATX MB, DDR 128MB PC-2100 266MHZ MEMORY ,AMD ATHLON T-BIRD 1.2GHZ 256K FSB266 PGA , NVIDIA GEFORCE2 MX-400 64MB 4X-AGP

Share this post


Link to post
Share on other sites

Guess what??????? I got it!!!!!!!!!!! :-jumpy :_jumpyI did everything just as you said to do, and it worked perfectly. I was getting some flashing at time. But I think thats from another addon. So I did some searching in archives and found the solution. This makes the time and energy worth the effort. Had I known that Terrascenery was so easy to use before this, I would have been using it along time ago. It is so realistic now. Unbelievable to fly in the same area where I lived for over 25 years. All of the roads, farms, rivers ect... are exactly where they exist in reality. I was up till 2:30 am testing it out. Yes this part of my I96 project. Im debating whether to try water mask or night time render next. I guess I have a decent system after all. It didnt really take all that long for the render. Total time approx 3 hours maybe. Having said all of that. I would recommend for you or Pascal to copy bits and pieces of this post for a begginers tutorial for Terrascenery. Everything else I had read before seemed to be so complicated to do. Anyone could do it if they use your procedure. Also putting a couple of screenshots for you to see. They are of Green River area, but without water mask implemented. I will put some other up as I go along. TonyWhy Oh .... Why cant I ????FlyII! ver. 2.30Directx 8.1nVidia drivers 28.32ECS K7S5A SOCKETA /DDR/ AUDIO/ATX MB, DDR 128MB PC-2100 266MHZ MEMORY ,AMD ATHLON T-BIRD 1.2GHZ 256K FSB266 PGA , NVIDIA GEFORCE2 MX-400 64MB 4X-AGP

Share this post


Link to post
Share on other sites

Tony, congratulations! :-beerchugNow you can buy another HD !! :-lolMeco and Tony,Day scenery >>> use existing (button)means that TS uses the big tga image from the output folder, and don't regenerate it.Use existing segment (box)means that TS rebuilds the big image from the small segments (the number of segments depends on "max segment size" option). They must already exist in the output folder.Meco, are you sure that TS doesn't relaunch the slicer on the third screenshot? If not, I'm not sure it's because you checked off "use existing".You're right: we must displace the whole Data folder before to slice, just deleting the folder afterwards is not enough, especially if you have already some other folders in it. My mistake!The render in three steps seems to be a good way for those with few RAM ! Good tips indeed!Pascal :+

Share this post


Link to post
Share on other sites

TonyGlad that you got it.Something I do (having a 40gig HD) is save the smaller tga images to a folder, so that I can go back and edit them and re-slice. That

Share this post


Link to post
Share on other sites

Pascal, Thanks for the Info. Ditto on the extra floders. I installed a couple of the add-ons Daves NY, SanFran and one of the other enhanced sceneries. Dont recall which one it was. Anyway I moved them to a temp folder just in case. So when I did the render for I96 area I noticed a brand new bunch of folders in the data folder. They all had similar numerical order as the ones that I removed. So I take it is safe to delete these? With no effect on the enhancments made by the recent render? Yes I can see the need for another 40 gig hd in the near future. :)If it wasnt for Meco's directions on how to do the render. I was just about ready to give it up. I really want to thank you guys for all the help. TonyWhy Oh .... Why cant I ????FlyII! ver. 2.30Directx 8.1nVidia drivers 28.32ECS K7S5A SOCKETA /DDR/ AUDIO/ATX MB, DDR 128MB PC-2100 266MHZ MEMORY ,AMD ATHLON T-BIRD 1.2GHZ 256K FSB266 PGA , NVIDIA GEFORCE2 MX-400 64MB 4X-AGP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this