Sign in to follow this  
Guest

What do you make of THIS "engtrans.log" entry?

Recommended Posts

Voice = 10, NumTokens = 23AI Ix = 1RMSG = 1008, intval = 13867812RMSG = 1008, intval = 13867812RMSG = 13, intval = 0RMSG = 1010, intval = 102RMSG = 211, intval = 0RMSG = 1017, intval = 1199RMSG = 241, intval = 0RMSG = 1007, intval = 34RMSG = 11, intval = 0RMSG = 1015, intval = 0RMSG = 230, intval = 0RMSG = 1005, intval = 73RMSG = 184, intval = 0RMSG = 35, intval = 0RMSG = 205, intval = 0RMSG = 1016, intval = 16RMSG = 69, intval = 0RMSG = 1016, intval = 15RMSG = 5, intval = 0RMSG = 116, intval = 0RMSG = 1014, intval = 13465244RMSG = 147, intval = 0RMSG = 1010, intval = 102....This logged following CTD upon entering SF Region AI Startup with full OT installed...If I turn the AI traffic slider back to "0" before loading, the startup breaks with an error, no CTD this time, but still does not display error status window. I have "debug" as first line in flt3.cfg, BTW... I can Ctrl_Brk and continue to load and fly around, but no window appears to give me cause of the error...and it is a little unnerving to fly about the SF Region with no AI activity. I have to surmise that the error lies with AI initialization, but I am unable to pinpoint the direct cause. I have reinstalled FUIII w/ FUII Scenery several times. My system configuration is as follows: FUIII(patched)/with FU2 and Full OT scenery on OS--Windows 98SE, DX9.0, VIA HyperionMB--Gigabyte GA7VAXPDRAM--512 MB DDR333 (PC2700)CHIP--AMD Athlon T-Bird 1.2GHz @133Mhz hostAGP--GeForce3 Titanium 200(DDR)64MB @4x Fly First...Play Later...--Noel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Noel,This has happened to me in the past. I have Fu3 installed as yours (Outter terrrain and Hires SF). Also have Fu2 installed by itself. There are 2 files available here at the library author Hennie van Rooyen, flight3.zip and airports1.zip.When I followed his instructions, the problem went away. There's only one draw back though, icons for certain airports are not on the map so setting up a flight plan for them or seeing them on the nav map can't be done.Interestingly, this seemed to "deaden" the ai and radio traffic in the outer terrain, so that package(outter terrain ATC by Markus Brunner) I re-installed as original and the freeze on AI screen came back. That was the end of my experimentation with this old Fu3 issue.There are several old posts about this same subject and if I remember correctly it came down to 3 conclusions: Fu3 has an airport icon limit, Fu3 has an AI traffic limit, Fu3 doesn't like it if airports share the same frequencies, even if the airports are in the different hi-res regions or outer terrain.Another fix was to convert some airports as POI's(Points of Interest) icons. I can't remember who it was came up with that ingenious fix.Noel, the above was things as I can remember. I'm sure the many wise guru's here can shed more light on this subject, and give more accurate facts.Oh, I left the outer ATC package active is, just hitting the ctrl-break to continue loading. I got to have the o/t radio,s, very boring flights otherwise.One more Jimmy B observation, activating some outer terrain packages seemed to cause the ai traffic load screen lock differently. Some would cause it to happen when starting flight from hi-res SF(Sea would load fine if starting flights from there) and another would cause the lock when starting from Sea-Hires, but not Hi-res SF.I never looked into seeing exactly what package/s was causing this. Just went back to flying, enjoying the sim.I think some folks here do not install the outer terrain to avoid the locks. Take care,Jim B.

Share this post


Link to post
Share on other sites

If I convert everything into English here :-) would I be correct in stating that you are both talking about the "freeze" during AI startup ? I used to have this problem, but it seems to have disappeared.Chris Low,ENGLAND.

Share this post


Link to post
Share on other sites

Hi, Chris!Yes, indeed. You are correct! BTW, I forgot to mention in the first post that once FUII Hi-Res scenery is installed, and I enter FLED to check the SF area airports, the parking spot "Barond", "BaronP", and "F-22" are not accepted as valid.Fly First...Play Later...--Noel

Share this post


Link to post
Share on other sites

Hi, Jim!Thanks for the reply. I am curious though, why FUIII would place a limit on the number of icons when they (LGS) stated that one could build an unlimited number of airports. I am wondering if there is a coding issue within the Flight3.exe/engtrans.dll, sndresv.h that can be resolved by a little creative editing. I simply don't understand where to look because the "error window" at AI startup freeze will not appear to give me the faulty function call/constant. I will look over the two files you mention by Hennie to determine what changes to the resource files he made to resolve this issue. I do not relish the idea of losing any of the features of FUIII...More would be much better. I am trying to get the existing bugs worked out and discover how to expand FUIII to allow X-continental/oceanic flights.Fly First...Play Later...--Noel

Share this post


Link to post
Share on other sites

Noel,I am aware that "Baron" isn't accepted as an AI plane in the FU3 high resolution scenery areas. That's why I changed all of these to "Windhawk" in my San Francisco airport upgrades.Are you aware that you can still see F22's in FU3 (together with Concordes and Blackbirds) ? Jouko Huovinen developed an excellent AI Enhancement Package that allows these AI planes to once again fly around in Looking Glass airspace :-) You will find this package in the FU3 file library.My version of the modified MODELS.RES file uses "F18p" to represent "F22D".Chris Low,ENGLAND.

Share this post


Link to post
Share on other sites

>Turn off the accelerator to see the 'error window'.>>B.AdamskiMy first reply was deleted by the "New Forum"I will try again here...It works...See what you make of this:FLIGHT3 caused an invalid page fault inmodule FLIGHT3.EXE at 016f:00484894.Registers:EAX=00000000 CS=016f EIP=00484894 EFLGS=00010206EBX=00ccc390 SS=0177 ESP=00a9fbb8 EBP=00000000ECX=0000004e DS=0177 ESI=00d6c3e4 FS=42f7EDX=00000066 ES=0177 EDI=00000000 GS=0000Bytes at CS:EIP:8b 40 10 85 c0 74 10 8b 4c 24 08 39 48 08 74 09 Stack dump:00484822 00000000 00ccc390 00ccc390 00d6c3e4 00fc0c34 00484604 00000000 00ccc390 00d65850 00d6c3e4 00000000 0000004e 0045703a 00000000 00ccc390 Fly First...Play Later...--Noel

Share this post


Link to post
Share on other sites

Hi Chris,I had already modified all the SF area airports' parking spots with a variety of AI and their corresponding radio frequencies. Having modified all airports in SF, Sanfran, and Outterr that were in conflict, I am still having trouble with the debugging the CTD and error info. (See my response to "Super Bee" below). -Noel Rusnell, USAFly First...Play Later...--Noel

Share this post


Link to post
Share on other sites

Addendum,I am trying to trace the stack to find out where in the program there is the conflict. I am yet unsure as to what resource file is the culprit or what faulty value is being called by the Flight3.exe program.Fly First...Play Later...--Noel

Share this post


Link to post
Share on other sites

Bogdan, that's brilliant - how did you work all this out?I checked all the frequencies for UK-South and can't find any clashes. BUt a few people are now finding lockup on AI start-up. I hope that the next set of editing fixes this.So I too was looking for the dialogue box and couldn't find it. But I think you have just solved it.RobD.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this