Sign in to follow this  
Guest habu2

Saving Graphics Options Stettings

Recommended Posts

Hi, I lurk here a lot but rarely post - until now.I have been semi-happily chugging along with FU3 installed on an old Celeron 300 system OC'd to 450, and a Voodoo III card.I just built a new system around an nVidia 6800 256 MB PCI-e card, and installed FU3. Everything seems to work fine (so far) with one big exception: every time I start up the game my resolution is set to 640x480 and no 3D acceleration. I can reset the resolution and accel on in the Options menu; I can edit the fu3.cfg file to set opt_3dhw_last_hw 1, opt_hw_acceleration 1 and opt_video_resolution 4; but if I exit and re-enter the game I am back to a low-resolution, non-accelerated video profile. I even set fu3.cfg to read only but that did not help.How do I make the graphics settings persistent?TIA, Greg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Greg,I assume that when you are done changing your graphics settings you hit accept and not cancel?I am a V3-5500 veteran myself. Great card in it's day... and the best ever for FU3. But I now use a ATI 9800 Pro and have no experience with nVidia cards. Maybe Bob Stiles who currently uses a nVidia card or someone else like Chris Low who has had nVidia cards can chime in here. How is your card configured outside of FU3? I imagine you have the AA & AF cranked up for both OpenGL & Direct3D?Another thought... a long shot... is your config file set to read only by any chance? Any other critical files?I like your tag line:"Reality is for people who can't handle Simulation"That is great! http://forums.avsim.net/user_files/110020.gif

Share this post


Link to post
Share on other sites

My apologies, Greg, but I have no solution to this. As I read it, it's the simulation that isn't saving the graphics settings, not the system itself. I do not have FU3 currently installed, so I can't play around with it and try to figure out what's up.But I would think there would be someone on this forum that has FU3 installed and is using an NVIDIA card and can help out here.[table][tr][td valign=top]http://www.avsim.com/other/usaribbon.gif[/td][td valign=center]Bob "FlyBert" StilesAVSIM Moderator[/b][/td][/tr][/table]"Don't stall on me, I have to soar!"~Richard Harvey, 1/21/2003

Share this post


Link to post
Share on other sites

Greg,I would echo Tom's words regarding hitting the ACCEPT button after you have changed the graphics settings. If that isn't the cause of the problem, then I am puzzled. I used an Nvidia GeForce 3 Ti 200 before my current ATI Radeon 9800 Pro, and it worked great.By the way, when you get this working properly, I really would follow Tom's other suggestion. Switching on FSAA and anisotropic filtering really does make a HUGE difference to the quality of the graphics in FU3.Chris Low.

Share this post


Link to post
Share on other sites

Hi Greg,Since about 2 months I am using a nvidia GEForce FX5200 ,Updated driver 6.14.10.6177 with DirectX 9my config settings are: (updated via the game)opt_3dhw_last_hw 1opt_hw_acceleration 1opt_video_resolution 2Resolution 2 is for 1024 x 768, this is the max. for FU3.I think your problem is setting to resolution 4 that is unknown and so the game is reset to default 0 (640 x 480) I use opt_video_resolution 1 (800 x 600) mostly to keep a acceptable framerate at high model population. Set first your config file back to read/write.Last resource: rename fu3.cfg to another name and restart your game. FU3 will generate a new file - try this and look at video settings.After normal quit of the game the file has the new values.The new values are not retained after a crash to desktop.But I think you know all that. :-)hope all this help :-wave agtim

Share this post


Link to post
Share on other sites

Andre,Something tells me that a system based around an Nvidia GeForce 6800 will not have too many problems with low framerates ;-)Chris Low.

Share this post


Link to post
Share on other sites

Hi Chris, sure the 5200 is not a strong one and my mainboard is AGP4 only :-( so that's why I'm using 800x600 :-wave agtim

Share this post


Link to post
Share on other sites

Wow, thanks for all the replies!Yes, I am definitely clicking Accept after setting options.For opt_video_resolution I was going by an old printout I had from Mike Magatagan's site (that should take a few of you back down memory lane) which listed:0 = 512x3841 = 640x4002 = 640x4803 = 800x6004 = 1024x768I'm guessing these values were for FU2, and changed for FU3? I will try resetting it to a value of 2.I did set fu3.cfg to read-only in an attempt to prevent the program from overwriting my manual changes, I'll remove that as well. I did not know FU3 would auto-generate a new .cfg file, that is interesting.I have a 'profile' set up for the nVidia card which forces all settings (FSAA, anisotropic, yadda yadda) all to their max values and assigned to the flight3.exe executable and, as Chris noted, the game looks spectacularly new and frame rates are *not* a problem :)BTW, this system is going to replace the one I built years ago for American Airlines' C.R. Smith Museum, see this link for details: http://www.habu2.net/crsmith/cr_smith.htmThanks again guys, I'll report back this evening with my findings.

Share this post


Link to post
Share on other sites

agtim was right, opt_video_resolution 2 works. All is well again.I have also installed sanfran2004 and seattle2004, and several new aircraft. Everything seems to be working just fine. Thanks to everyone!

Share this post


Link to post
Share on other sites

Good to hear that you got it all worked out, Greg. http://www.handykult.de/plaudersmilies.de/...y/xyxthumbs.gifI was pretty sure the forum would come through for you, even though the moderators were fairly useless. :-)[table][tr][td valign=top]http://www.avsim.com/other/usaribbon.gif[/td][td valign=center]Bob "FlyBert" StilesAVSIM Moderator[/b][/td][/tr][/table]"Don't stall on me, I have to soar!"~Richard Harvey, 1/21/2003

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this