Jump to content

Adam_WMids_UK

Members
  • Content Count

    21
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

Profile Information

  • Gender
    Male

Flight Sim Profile

  • Commercial Member
    No
  • Online Flight Organization Membership
    none
  • Virtual Airlines
    No

Recent Profile Visitors

332 profile views
  1. Thanks vadriver! Sorry about the slow response... despite setting notifications as on, AVSIM doesn't notify me! I should probably check the email address it is sending to! I HAVE actually had the problem you linked to in the past too and sorted it by removing duplicate scenery references as discussed in that thread. This is different though - it isn't the indexer which is hanging - that is working fine (or at least doesn't report any errors!). The problem I'm having is a hang when I click the green 'Enable' button on the ATC Prompt window in the sim. After the "test" messages are spoken for each voice, it opens the flight plan trainer window in the background and hangs. If I close the window having added a blank text file to the appdata directory for VOX the initialisation completes and VOX runs fine. Not sure why! Thanks for the time you took to search for me - when I tried I couldn't find this issue anybody else had had! Regards Adam
  2. Cheers for the advice. That was my initial thinking too - I uninstalled all scenery changes. This started months after I'd installed HF2 (shortly after it was released). Everything had worked fine for ages until then. I only installed HF3 to see if something had changed in the default scenery, knowing that HF3 would default it again. I'd already tried removing any added scenery in HF2 at that point. That is what got me thinking it must be something different. Problem is that uninstallers don't always return everything back to its pre-install state. I suspect if I completely killed my sim, scoured my appdata, program data and windows registry for anything sim related, and then reinstalled the lot, it would probably fix it. I'm just not sure I can be bothered with all that! Cheers Adam
  3. I did edit the above, but my edit didn't save. Now I don't have an edit option either... " I didn't bother with HF3 or sim director as I don't use VR which was what the majority of the updates were for." SHOULD have read... "I didn't bother with HF3 as I don't use VR or sim director which were what the majority of the updates were for." Regards Adam
  4. Yep P3Dv4.5 HF3... but it was doing it on HF2 also. I had HF2 for ages with no issues. I didn't bother with HF3 or sim director as I don't use VR which was what the majority of the updates were for. Then when I started getting this hanging during initialisation on HF2, I figured installing HF3 with the content and scenery too might default something and fix it, but it didn't help. Cheers Adam
  5. Hi Jay Thanks for the info. Very odd with how it has suddenly started doing it. At least I have a work around by leaving the empty text file there and just closing the trainer when it opens. I've checked and the trainer isn't open by default. Even in the background. It fires up when Vox is initialising! Appreciate your help on it! Adam
  6. Hi Jay Odd that the flight plan trainer opens behind my simulator window (wouldn't know it was there unless I minimise the sim) when I start VOX - and it opens just at the point VOX hangs... AFTER the voices all said "Test". VOX definitely seems to be waiting on the trainer, which is causing the hang. To give a clear, concise summary of the behaviour after hanging: - If I just wait, it just hangs. - If I switch to the flight plan trainer and click close, it gives the error message "Cannot initialise voice recognition. Ensure that you have a US English compatible recogniser selected. See help file". - If I switch to the flight plan trainer and click "General Training" and complete the training, then close the trainer, it gives the same error "Cannot initialise voice recognition. Ensure that you have a US English compatible recogniser selected. See help file". - If I create an empty text file called speechadapt.txt and put it in AppData\Roaming\Internal Workings\VoxATC P3D 4\, then enable VOX, switch to the flight plan trainer and click close, VOX completes initialisation and seems to run normally. The text file remains unchanged and is not deleted and is there for next time. - If I create an empty text file called speechadapt.txt and put it in AppData\Roaming\Internal Workings\VoxATC P3D 4\, then enable VOX, switch to the flight plan trainer and complete the "General Training" and then click close, VOX completes initialisation and seems to run normally. The text file remains unchanged and is not deleted and is there for next time. In all eventualities outlined above, the trainer reappears when I re-enable VOX, even after sim restart or windows restart. In response to your question I checked and both my speech recogniser and default voice (Microsoft David Desktop) are set to US. I DO run some of my addons over the network, such as ActiveSky, my VA's ACARS and Navigraph charts desktop. However, VOX is all installed locally. I don't even have the network server/client installed or setup. I'm completely at a loss with this one.... what I really can't get my head around is why it suddenly started doing it. I can only put it down to a windows update I think, because I have uninstalled everything else I can think of that I may have added since it last worked! I'm beginning to wonder about the MS redistributable libraries/runtime environments for C++, or VB or something.... wondering if they have been updated in a recent update and are not working with VOX like they used to. What build of Windows 10 are you on? I'm on Windows 10 Pro, version 1909, OS Build 18363.778 (info from About your PC at the bottom - find it by searching for system information) Thanks again! Adam
  7. Hi Jay! I REALLY appreciate you working through this with me. I know this isn't an official support forum and I am very thankful. I have been running P3Dv4 as admin since forever. I DID have English UK selected as my installed speech recogniser so have changed this to English US (after installing it) in windows, but this made no difference and it still throws the same error if I close the flight plan trainer after enabling VOX. I have also discovered something.... if I create an EMPTY file called speechadapt.txt in the path the error log says it can't find one.... it DOESN'T fix the problem... BUT, if I then click the close button on the flight plan trainer, VOX initialises and my AI aircraft load!! Annoyingly, I can't spend any more time on it right now to see if it then goes on to work correctly or not. But will try it more thoroughly later or tomorrow. I do have some questions though which might help me make progress, but PLEASE, if you've had enough of this one, you've already been very generous with your time and I don't want to put on you, so just say! 1. Does your flight plan trainer start up when you enable VOX in the sim? 2. Do you get a logged error if error logging is on and you click close on the flight plan trainer after enabling VOX in sim? 3. Do you have a speechadapt.txt in AppData\Roaming\Internal Workings\VoxATC P3D 4\? 4 If you do have speechadapt.txt, what does it contain? Thanks again for your help and I fully understand if you don't have time to go exploring the above! Cheers Adam
  8. Hi! My hardware configuration hasn't changed since I built this computer a year and a half ago. I have a number of devices for sound. I have a sound chip on my graphics card, onboard sound on the motherboard, a USB wireless dongle to a wireless headset with mic and a dedicated sound card which is my main device. When simming, I put most sound through my sound card to my speakers and put VOX only through my headset - using that mic. This set up has always worked fine in the past for me for both this PC and the PC I built previously. I have now tried putting the sound purely through the sound card, using a plug in mic direct into the sound card to test that way too, ruling out the headset and other devices. Despite using a different device, I get the exact same result, so I don't think it is hardware related. I checked in appdata\Roaming\Internal Workings\VoxATC P3D 4 for the flightspeech.txt and that hadn't been created. However I saw your next comment regarding running as administrator.... Well my account IS an admin account.... but for good measure I went to the exe files in the root folder for VOX and right clicked each one and set to run as administrator on the compatibility tab. I find now, having done that, that my flight plan trainer WILL function correctly. I got very excited at this point and tried launching my sim and firing up VOX.... only to find that it STILL hung on initialising after all that! Another thing I have noticed is that VOX is opening the flight plan trainer window behind my sim window when I click the "enable" button. Not sure if it has always done this, I can't remember. However, I have found that if I click enable on the VOX prompt window, then switch to the flight plan trainer window and click the close button, while it is still hung on initialising, the "initialising message disappears and it replaced with: "Cannot initialise voice recognition. Ensure that you have a US English compatible recogniser selected. See help file" In addition to this, more lines appear in the error log after the ones already posted above: I'm about to go and look into this error and to check what the "help file" has to say about it! Cheers Adam
  9. Hi! I double checked the speech calibration in Windows and that worked. When I tried to generate a training session from a flight plan it failed to generate the session for some reason, hanging with the bar part way full. I've now uninstalled VOX and have noticed it leaves a whole load of stuff in app data, so I've deleted that too. and am about to try a complete new install. I'm trying reinstalling Voxpop too. I've already uninstalled and reinstalled my headset for good measure, but it is working with everything else and always worked with VOX in the past. Just curious... what made you think it could be mic? Cheers Adam
  10. Nope.... sadly, changing the mic setting to turn off applications can take exclusive control made no difference. Don't suppose anybody knows what would normally come next in the log file after "init recog start "? My log shows nothing after that line. That is where it stops. If I know what comes next normally it might give me an idea of what might be hanging! Cheers Adam
  11. Cheers for the reply! I have just checked and VOX has accessed my mic today - interestingly, not in the last few times I have tried it... but then, I have had this issue about 5 days now! Screen snipping below shows VOX can access the mic and has done today (apologise about the size of the image... not resize controls on the forum!): I did find the allow applications to take exclusive control was ticked though, so just trying again now with it unticked.... I have set up several web conferencing applications recently so maybe one of those changed it. If not, it is the same mic I have always used successfully and is set as the default input device. Will report back! Adam
  12. Hi All I've used VOX for many years now and have worked around a whole host of issues over this time to keep it working. This latest one has me stumped though... When I click the green enable button to start VOX, I hear the voices being tested and then the message "7.42 initializing....." remains showing, but nothing happens after this. In the past I have had fatal errors and have been able to identify the issue and work around or resolve it, but this isn't throwing a fatal error.... simply hanging. I'm running on a high end PC, windows 10, P3Dv4.5, Vox 7.42 The error log is showing the following: I have tried a range of things so far and can't seem to get any other result: 1. Uninstalling any scenery added since it last worked fine 2. Reinstalling VOX 3. Regenerating the index after the above 4. Trying with several different aircraft and at several different airports, including combinations which I know have worked fine previously. 5. Clearing the sim scenery index and having the sim rebuild it, then generating the VOX index again. 6. Checked my sim's addons.cfg, exe.xml and dll.xml files in program data and appdata folders for anything new in those which might be running in the back ground 7. Trying with and without a route loaded into the sim's flight plan 8. Screaming helplessly at my PC in frustration. My other sim software still all functions fine. I haven't (and won't) roll back any recent windows updates... but I would assume that if one of these had broken something, then somebody (or several others) on here might have already have posted... Any ideas would be gratefully received! Kind regards Adam
  13. The latest version is partly working for me. I can not get the GA to work with it - VOX just seems to be unable to assign a callsign to certain GA aircraft (which triggers a fatal error) and despite hours of messing, I haven't managed to work out why (yet :-p !). It also needs the Airliners BGL to be moved to the scenery > world > scenery folder. I'm on P3Dv4.3 and VOXATC 7.41 Regards Adam
  14. Thanks for both of your inputs guys. I wonder if duplicate bgls for scenery is the issue here. I have addon airports from both Orbx England region and also UK2000 and there is also a bgl supplied by Just Flight's Traffic Global to add extra stands to the default airports in the sim. I THOUGHT I had disabled/removed duplicates I didn't want, but may have missed something. This theory would fit in with the issue with fsaerodata as if the RNU simply scans bglsthen it would find duplicates in the fsaerodata bgls and installed airports. I have looked for a tool to search for duplicate afcads but can't find one. Simple Airport Scanner from Jon Masterson is not P3Dv4 compatible. I'm going to give fsaerodata a whirl and see if that helps at all... esp. after having had fun today trying to tune the ILS at EGHQ only to find the sim freq was incorrect! If I find a solution I'll update here. Regards Adam
  15. Hi Mad_Mac No... not using fsAerodata. I HAVE installed the FSL A320 which asks you to update the Magvar data with 3rd party software BUT (thinking this may have triggered the issue last time I installed the A320) I declined to install the Magvar update this time when I reinstalled everything including P3D (i.e. since purging all flight sim data and starting over). I forgot to add I am using Voxatc v7.41 Cheers Adam
×
×
  • Create New...