Sign in to follow this  
Guest KFD

USB CH Pro Pedals.

Recommended Posts

Hi All,Been having a great time flying my new B1900 around Princess Julianna Airport in the Dutch Antilles. Great Aircraft - Thanks PMDG. So impressed I went down to Fairoaks Airport Transair shop and bought a set of Rudder pedals.Problem is: I seem to have the brakes locked on. The differential braking seems to work but acceleration is slow and I get the red warning in the bottom left of the screen that the brakes are on. It sometimes flicks to "Differential Brakes" - so I know the pedals are connected. I've tried to use the tops of the pedals to deselect the brakes and I've ised the "." command to stop the brakes. I've tried to change the command too but no joy. Anyone any ideas - hope I havn't wasted

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Kevin,Be sure to reverse the brake axises in FS joystick settings! ;-)Hope it helps,

Share this post


Link to post
Share on other sites

Mats,You've lost me there! Why do I need to reverse the brakes axis? More to the point - how do I do that? I also need to disable the twist on my joystick as I get the rudder etc twice over!Kevin

Share this post


Link to post
Share on other sites

OK Kevin,In FS Options->Controls->Assignments, then Joystick Axes tabSelect your pedals in Joystick typeScroll down to Left brake axis and Right brake axis and tick the boxes in the 'Reverse' column, that should fix the problem.Sorry for jumping in Mats :-)Yes you will have to disbale the rudder axis on your joystick or you will get problems.HTHDave

Share this post


Link to post
Share on other sites

Hi Kevin,You need to get familiar with the Controls pages.I have two attachments. Both are related to the following path on your drop down menus:Options-Controls--Assignments---Joystick axesOptions-Controls--Sensitivities---JoystickYou have to chose your controller and make the changes in these menus to get things working right. Follow my screen shots and you should get there.Hope this helps.Cheers,JohnBoeing 727/737 Mechanichttp://www.precisionmanuals.com/images/forum/ng_driver.jpg

Share this post


Link to post
Share on other sites

Mats, Dave and John,Thanks very much for your help and pointers. Works OK nowKevin

Share this post


Link to post
Share on other sites

Kevin,Glad you solved it. Sorry to give you such a sketchy explanation. I was in a hurry to close down my work comp so I just threw in that answer. You got some qualified help though! ;-)One suggestion though. Download the CH Control Manager from CH products. Use that little program to do the tweaking of your Pedals settings. And set the Null zone to 0 in FS. I think that will imrpove your experience even more!Cheers,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this