Sign in to follow this  
Guest JohnWilkins82

Paint kit question

Recommended Posts

Hello PMDG I want to say first of all thank you for such an amazing aircraft. Good job! I am having trouble getting photoshop cs2 to save the 747400_fuse_layout template in dxt5 format. I have downloaded and installed the nvida plugin for photoshop. After I have cut and copied from the fuse_left psd file using the fuse_cut_template into the fuse_layout. I tried to save the file by selecting save as and then D3D/DDS under the format dropdown. Then I click save and I get an error stating

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Sorry, John I've never run into that error message, I also use CS2. You do not save alpha layers with the fuse textures since FSX changes how alphas are handled. Save as DXT5.

Share this post


Link to post

Pete Thanks for the help! I had to rotate the image 180 deg and then flip it horizontally to get it to show up as it should. Just fyi. Off to paint the queen. Thanks againJohn W

Share this post


Link to post

Dear Pete, Sorry to keep coming back but I hit another snag. The landing and tail lights do not look right. Please see the attached screenshot. Any thoughts as to what I am doing wrong? Thanks again John W

Share this post


Link to post

Dear Pete and Vin, I am confused about how you save the alpha channel. There is a Alpha channel checkbox on the Photoshop save menu but that generates an error messages about to many channels to export. I tried turning turning on the visibility of Alpha channel 1 on the channels tab (I am working with the PMDG_747_Externals file as it is faster to test changes with) but still get the all lit up tail. Below is the step by step of what I am doing. Click save as in PhotoshopSelect D3D/DDS as file formatUncheck Alpha channel checkboxClick saveIn the NVIDIA dds format v8.23 box select DXT5 ARGB 8 bpp | interpolated alpha Select 2D texture Select no MIP mapsClick saveCopy over network to fsx computerLoad FSXLoad PMDG 747Swear Any thoughts would be greatly appreciated. I have attached screenshots of both save menus. Thanks again John W

Share this post


Link to post

Here's the save options you should be using;http://forums.avsim.net/user_files/181437.jpghttp://forums.avsim.net/user_files/181438.jpgAs for alphas, I mis-spoke earlier. Alphas are saved in the DDS file for the left and right fuse textures and the external texture maps. You can open the DDS files in your installed livery folder and copy the alpha layers for the fuse and external maps and paste into the alpha layer of your DDS textures. These are saved as DXT5 files.Let me know how this all goes.

Share this post


Link to post

Pete That did it. I discovered that if you save the .dds textures first, then add the alpha and save it again, no error message. Thanks again for your help. John W

Share this post


Link to post

Great! Post a screen shot of your livery when you're done.

Share this post


Link to post

Hello all, I've also had a dabble at the paint kit, was looking forward to it.Reading this post did help, because the read me that comes with the paint kit doesnt tell you to flip the images 180 plu horizontally before u save them. (otherwise you get a wierd paint scheme!)Also the images of how to save the format (DXT5) was handy.Maybe an idea to update the readme?As for my creation, RNLAF T-264 Prins Bernhard, currently a KDC10 in active service, but now as a beautiful PMDG B744 ;)Still need to fiddle to perfection, but for thee most part she's doneBest Regards Geordie

Share this post


Link to post

I am sorry to drum up such an old issue, but I am missing something in this thread.I did download the plugins as well. I am using Photoshop CS3 Extended edition, yet I do not have a chance to save a texture in DXT5. The plugins are installed because I can save any other texture successfully, yet when i go to save one of the fuselage textures, I get the same error message as the original poster.It's kind of hard to save as a DXT5 when you do not even have a chance to select that option. I'd use DXT-BMP, but i already made that mistake once -- DXT-BMP cannot save files properly for FSX, as all of the textures come out solid black within FSX.So it's back to Photoshop CS3 . . . . STEP: Edit the texture as desires.STEP: Select FILE then SAVE ASSTEP: In the pulldown menu, there is only one DDS option available. It reads: "D3D/DDS (*.DDS)"STEP: Click SAVEThis is where I run into the jam. USUALLY the next step is the step where I select the DXT5 option (it's an NVidia window of some sort that pops up and gives me the type options), but I cannot get that far because I get the error the original poster has: "Too many channels to export (5)"I never added any channels. In fact all i did was add a couple of logos, a custom registration and the main color of the plane is solid. Simple enough.Nothing in this thread helped, except to let me know I am not alone in this. Any ideas? Maybe the answer was in the images that were posted by the replies, but those images are now broken.

Share this post


Link to post

I don't know if this will help you. But in messing around with a' Default Jet Ranger' template some one had made I ran into the same thing.The plugin' seems to be happy with everything up to the 'Alpha Channel' anything more than that and it won't export.So RGB,Red,Green,Blue and the Alpha are o-kay. But the one marked 'Gold Selection' had to be removed for it to export.So you may want to check these...I dont' own the 747 for FSX yet, but I'am trying to get a handle on the texturing process for FSX.Jeff

Share this post


Link to post

chris,After step 1 you must then perform a merge all layers. You will then be able to proceed with the rest of the DSS format save. Make sure you select No MIP maps in the MIP Map Generation option.Pete

Share this post


Link to post

>chris,>>After step 1 you must then perform a merge all layers. You>will then be able to proceed with the rest of the DSS format>save. Make sure you select No MIP maps in the MIP Map>Generation option.>>PeteI thought he said..."Too many channels to export (5)"?"Layer collapse should be/is automatic"...fsscr036dds.jpgHere's the pic' of the 'Channels'fsscr035channel.jpgJeff

Share this post


Link to post

jeff,apples and oranges. The error is for too many LAYERS, not Channels. Trust me when I say merging layers before saving as a DSS format will work.I've done over 70 of our liveries.

Share this post


Link to post

Well now you really got me interest peaked....I went and D/L'ed the FSX template and looked.So Using the "747400_Fuse_Layout_Template.psd" Which from doing paints for FS9 is the one you use after you paint and are ready to convert the textures...If memory serves.I collapsed all 7 of the layers...And left in the 'Alpha Channel'...I get the To many channels warning..Take out the 'Alpha" and it will save as DDS?Then Leaving the 'Alpha' out and leaving the "Layers" un-merged...It saved?Not trying to argue with you Pete,simply because I have only been doing the FSX paint thing a short time.But I have a few paints under my belt also...And "Layers is Layers" and Channels is Channels"...No way to get around that.When I first started converting all my FS9 repaints for FSX I learned real quick what a bear that 'Alpha Channel' can be! All I saw was 'Pretty Black or Gray planes'.So,if I seem to be persistent...sorry...just trying to learn how to get a handle on FSX.Jeff

Share this post


Link to post

jeff,NP. This is what to do. Paint the fuse_left and right with the livery and do a final save with all layers. Now merge all layers then copy the flattened fuse onto the fuse_cut template. Select each layer, front, middle and rear in turn and copy and paste into the fuse layout template. Once you've pasted the flattened fuse into the fuse_cut template you can close it WITHOUT saving. This will preserve your livery fuse with all layers intact for later editing if necessary. Close the fuse_cut template (you can save if you want to). Now you must merge the fuse layout template and save as DDS. That's it in a nutshell.

Share this post


Link to post

>chris,>>After step 1 you must then perform a merge all layers. You>will then be able to proceed with the rest of the DSS format>save. Make sure you select No MIP maps in the MIP Map>Generation option.>>PetePete, thank you. I will do this tomorrow night after class and hope it works :-) That one sentence actually explained a lot. :-)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this