Sign in to follow this  
Guest JonP01

Just in case you didn't catch it the other day: Disabl

Recommended Posts

This is such an improvement I thought I better post it one more time for those who missed it. Disable AGP in DirectX and you most likely will improve the subtle but annoying stutters that can happen despite a high end machine. I'm not talking too much about FPS, just stutters. Works super! Noel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Excuse me if I'm wrong, but doesn't that apply only to non AGP cards, wouldn't disabling the AGP on an AGP card disable the whole card? Please correct me if I am wrong.Thanks in advance,Clay

Share this post


Link to post
Share on other sites

Well, I don't think so, since all 3D functionality appears intact. I think the theory is that by disabling use of system memory as a texture buffer by disabling AGP, you in effect end up forcing the program to use only local video memory, which has considerably more bandwidth than the 512mb/sec AGP 2x has, or 1024mb/sec with AGP 4x. Or it may just be a timing or syncronization issue causing stuttering when the AGP bus is used as a texture buffer. In any case, it definitely helps. I still run low on FPS in certain situations, though even FPS is overall improved, but the degree of stuttering WHEN FPS IS OK, has been virtually removed. This was always the irritating thing to me with FS, how you could have 22 FPS, yet still get microstuttering in many situations. Even people with very high end machines have had this problem. I am really looking forward to my system upgrade though because now I am more confident the increase will pay off--in better FPS in those maxed out situations, WITHOUT the irritating microstutters. Put another way, I wasn't too keen on an upgrade if it was not going to fix stuttering.Noel

Share this post


Link to post
Share on other sites

How do i disable agp in directx?i looked in windows direct x file but cannot find any reference to AGPThanks Don

Share this post


Link to post
Share on other sites

Not to burst your bubble Noel, but I've tried every combo of disabling AGP, reducing texturing cache, maximizing cache, and I see no real differences in my FPS. The only thing that changes is when I disable AGP under DXDIAG my 2-d panel gets some beautiful mauve color to it. I get about 30 FPS at 1280x1024x32 with my system (2.26 w/ 533 FSB overclocked at 2.71Ghz, G4 Ti4400 OC'ed about 12% core and memory speeds, and 1 Gig RAMBUS 1066 RAM). With AGP texturing off, it's almost identical. I'm not arguing with you though, if it works for you and others, that's great. It just isn't helping mine any.

Share this post


Link to post
Share on other sites

Well, to make it more clear, it's not really FPS that I am harping on. It's the stuttering that can occur during banked turns, taxiing, in otherwise high FPS areas. This is what has really improved with disbling AGP in DirecX. The fact that disbling AGP causes this mauve color artifact is solid evidence that there are other issues your configuration has that mine does not have. Eagle, are you not having great performance with that rig? I was really hoping that combo of parts would be super with FS2002. It is close to what I plan on building. What's the worst FPS you are getting, with what programs running, addons, etc? You are definitely bursting my bubble with your system specs, unless I'm misreading this!BTW Eagle, what motherboard are you using? This is depressing! Noel

Share this post


Link to post
Share on other sites

Noel,I thought by now you should know this based on previous posts - it does not work for everyone. For example it may heavily depend on the video card. It does NOT work for me. Not one iota worth of difference. And please don't tell me there must be something else wrong with my system ... all right ?Michael J.

Share this post


Link to post
Share on other sites

Noel, I'm having great performance with my setup. I was just seeing if that little trick worked. My worst FPS is usually about... 23 and it jumps into the 40's? I don't fly into large airports often, but I'd guess it drops to something in the 10-15 range? I have the Cessna 421, and the Emma Field scenery as my only two payware add-ons. I run a dedicated server for Tribes 2 (multiplayer game) and sometimes it decides to fire up right in the middle of a session of FS2002, and it stutters for a second. Other than that, it's great. Oh yeah, I have the iWill Par4 I850E mobo in my system. It's really a smokin system. I think the FPS thing is overblown though...it's really smooth. On Quake 3 I hit 85 FPS in many cases. I would assume that much of the stuttering people get (myself included) is an error in the coding on MS's part. I love the game though and try not to worry about it too much, just enjoy playing :) Hope that helps!

Share this post


Link to post
Share on other sites

Well, that is all triple posted but as the information seems to degrade with every new post I wanted to add a few words:Totally disabling the AGP is sure going to extremes, and also it won't work fo everyone without sometimes strange effects. The other possibility is to lower your aperture size to a very low level e.g. 16 or 8 MB. From what I know at 16MB your AGP is in fact still working while at 8MB it is definitely switched off.And absolutely: For whatever reason it will not have any positive effects on one system while it breathes absolute new life to others. It sure won't help graphic cards with less than 32MB sometimes it won't even help with 64MB.The most important result is that you ged rid of these microstutters that even high end systems experience.For those who are interested:After a lot of thorough testing and framerate compares, and stutter compares with defined settings in different situations:AGP on, with 16MB aperture size works best for my rig. No stutters left at all. If I disable AGP completely I will loose 2-3 fps it very dense airport settings. Here, and only here the AGP seems to do something good in FS2002.My rig:MSI K7T266 Pro2-Ru512MB APacer DDR-Ram with all timings at the shapest settingsMSI GF4Ti4600Athlon XP2100+Settings in FS2002:1600x1200x32All settings maxed except mesh (87%)Alex

Share this post


Link to post
Share on other sites

For some reason Alex my system freezes after a while if I lower AGP to 16x. And also, AGP is DISABLED on my system when I lower the ap to 16 or less.Noel

Share this post


Link to post
Share on other sites

Yes I think people need to contain their excitement a bit when it comes to disabling AGP or reducing aperture size. It goes without saying that there are so many configurations out there, results will vary considerably.On my machine, perfomance starts to reduce if the aperture is 32Mb or below, with the sweet spot at 64Mb. If disable AGP, performance drops very noticeably and FS2002 actually falls over after a minute or so, presumably because it runs out of texture memory. However my machine still uses relatively low bandwidth Mushkin PC133 SDRAM memory running CAS 222.I'm actually putting an interim upgrade machine together next week - an Athlon 1800+ XP / Ti4400 but running with my existing SDRAM. It will interesting to try different aperture settings, as my current mainboard only allows 32 or 64Mb. The new Epox board has the entire range of settings to try.

Share this post


Link to post
Share on other sites

I think it's hard to say anything for sure about ideal configurations of software and hardware for FS2002 because the sim taxes virtually every component in any given system, such that some areas of processing are affected more than others, system dependent. I really do hesititate to draw any conclusions but having had such good luck on 6 or so flights with the disable aperture thing I was inclined to share the success.Noel

Share this post


Link to post
Share on other sites

Now I find that pretty so so quite frankly. Here I am with P3 1GHz, PC103 SDRAM, and a Radeon 64 DDR, and I am flying at almost full max everything at 1600 x 1200 and I usually only get to 10-15 in the heavy terminals with one or two AI aircraft moving about. And if I unlock the FPS, and stay away from the big terminals, I'm at about 24-40. Why the heck is this? If we compared benchmarks we would see your machine did double the processing of this one. What the heck is the explaination for this? I fly with 75-38 meter mesh, FSFlightMax, FSMeteo, Flight Deck Companion. This is very difficult to explain, and I'll be danged if this isn't exactly how FS2000 behaved: double the power, and instead of 2x the performance, you get like 1.2x the performance. Someone please explain how this can be. One thing though is I do stick with default aircraft--the hit on this machine for Dreamfleet or PSS stuff is too severe. I like smoothness . . .Noel

Share this post


Link to post
Share on other sites

I think most suggestions, including this one are at least worth trying. At worst your machine will just fall over and you can restore the settings. At best, people will get improved performance. People with large amounts of high spec DDR main memory and lower spec Geforce cards should defintely experiment with it, as it is easy to restore the previous configuration.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this