Sign in to follow this  
Bob Familton

HELP PLEASE-Lost The Use of My CD Drives!

Recommended Posts

This is a little off subject here but I can't load any CD's on either of my CD drives. I have a Toshiba DVD and a Yamaha re-writeable.I can read and write UDF re-writeable CD's on the Yamaha but can't even read any other CD's on either drive. The only thing I have done recently that I know of is to install the latest Augigy SB drivers which installed a Creative Play Center and some sort of disk detector with no help info for either one. I have some FS2002 related CD's I want to load and can't do it. Any help would sure be appreciated.Thanks, Bob.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What OS is it? On the Win9x platform, disappearing CDROM's used to be a common side effect of most viruses. (Most newer viruses don't do this, though). I'd run a full virus scan before I did anything else.

Share this post


Link to post
Share on other sites

Bob - I don't know what the "disk detector" does but it sounds very suspect. Can you uninstall that "feature" and see if that clears the problem?Trip

Share this post


Link to post
Share on other sites

Hi. I tried to uninstall it. There is no uninstall for it that I can find. It is not listed in the Add/Remove in Win ME. I even moved the executalbe files to a temp folder and it still does not work with the CD's. Thanks, regards, Bob.

Share this post


Link to post
Share on other sites

I'd assume you're using Adaptec Easy CD Creator... the Disc Detector is it's method of determining when you put a blank CD format in. It's a stupid little program that opens up ECDC when it sees that the CD is blank. Maybe try updating Easy CD?

Share this post


Link to post
Share on other sites

I had this problem with the creative disk detector too. If you are using XP you can remove it from your startup list. I can't remember where you'll find it without going home and looking... you'll find it in the help files. But I'm sure someone will help here with that???I removed mine from loading at startup and didn't get any more problems. The Easy CD upgrade will help too.Cheers,Si.

Share this post


Link to post
Share on other sites

StartRunmsconfig and then clicking on the Startup tab will get to the list of startup programs. To disable something just uncheck the box next to the name.Trip

Share this post


Link to post
Share on other sites

Thanks. The CD program does not seem to be listed there. Any other help would be appreciated. Thanks, Bob.

Share this post


Link to post
Share on other sites

I am running WinME. It is not listed in the startup list. Any other help would be appreciated. Thanks, Bob.

Share this post


Link to post
Share on other sites

Hi,You could try this. Go to control panel,system,Device manager,CDROm and remove them. Restart WinMe and let the os detect them again. If you have other drivers, reload them at this time.Another option is to use the restore option, going back in time to a point that they worked correctly.Hope this helps.Ed

Share this post


Link to post
Share on other sites

BobWhy not re-install the (latest) drivers for the devices as it's a possibility that they may somehow have got corrupted or even removed.Go to the manufacturers websites (do a search at www.google.com if you don't have the addresses), download and setup the drivers again. That might solve the problem but even if it doesn't, it can't hurt.Worth a try anyway. Good luck.Toni.

Share this post


Link to post
Share on other sites

I had a problem with my old system where both CD drives stopped functioning. In my case both drives were on the same IDE channel and the Master drive failed and this prevented it from recognizing the secondary device. Once you exhaust all the possible software/driver solutions you may want to try each CD on it's own as the master device on the IDE channel. Don't forget that you may have to set a jumper on the back of the CD drive to get to be recognized as the Master device.Good luck!

Share this post


Link to post
Share on other sites

In your control panel, you will find the disk detector Icon - like a little light bulb and a CD together. Open it and click "Disable."Also - check your version of aspi32.sys and wnaspi.dll. Just to a file search and you will locate them - in the Windows system folder I believe. Version 4.71 is the latest version of these and you can get them at adaptec.com - just do a search on their site and they will come up. - This cured my problem on Windows XP - use at your own risk though for WinME.

Share this post


Link to post
Share on other sites

Did a search on my computer. I have wnaspi.dll (Version 4.6.0.109). I don't have any aspi32.sys at all. I looked at adaptec.com and could not find either one. Are they used on WinME? The Yamaha drive reads and writes UDF CD's fine. Also disabled the detector in Control Panel. Thanks, regards, Bob.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this