Sign in to follow this  
Guest

Whatever you do! Disable AGP Texturing in Direct-X!

Recommended Posts

Hey Gang!I don't know if this has been discussed around here or not before, but I have made an interesting discovery. If you go into your Direct-X dialog box, under the Display tab, disable AGP Texturing. As soon as I did this, my frame rates, fluidity, and scenery sharpness increased tremendously. It looks like FS2002 and this function don't mix together very well.Just my 2 cents!Sincerely,Dennis D. Mullert

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,It seems to be a good solution for many setups, but unfortunately it doesn't work on mine (hercules 4500 64Mb). I believe it must be video card dependant. In my system, what makes a hughe difference is the AGP aperture size in the BIOS setup. If I set it to anything more than 64Mb, my FS2002 turns into a slideshow. Any value equal or less to 64 makes it fluid again.Paco

Share this post


Link to post
Share on other sites

Yeah, my experience is that although it may seem faster at first, you're really kidding yourself. Check the available resolutions inside Fs2002 display options and you will find you have lost some. I wonder if this is only an advantage for those people who have not got fast-writes working properly. Otherwise, the card will always prioritise its on-board memory anyway. All from me Georgethetee

Share this post


Link to post
Share on other sites

Hi,Can you guys provide your specs when posting regarding this subject. It seems it helps some and not others. I would like to see if it is related to particular hardware.Thanks, AMD 1600XP @ 1800XP 1.50 (10.5 X 143)EPOX 8KHA+ VIA KT266A 1GB INFINEON PC2100 DDR (2x512)Leadtek GF4 4400 A250 TDIBM 60GB ATA100 7,200RPMQuantum 20GB 5,400RPMSB LIVE 512V350 Watt PSUWINDOWS XP PROGood judgment comes from experience, experience comes from bad judgement.

Share this post


Link to post
Share on other sites

HI Dennis,Long time no talk!Problem with your headline, understandable though it is, is that you are promoting a setup that is within the confines of your own experience.On my own system, disabling AGP texturing is disastrous and reduces frame rates by half, and creates stuttering where there wasn't before. This is on a system, which as you can imagine has endlessly been fine-tuned, tweaked and optimised tothe nth degree.So the moral of the story Dennis: by all means attract attention with controversial post headlines, as long as you understand that not everyone has the same results!Kind Regards,Rob Young

Share this post


Link to post
Share on other sites

I second What ROB just said! On a my system which is a P4, 1,7 GHZ Dell machine, by disabling AGP in my Direct X, my FPS goes down real bad in Spot view, and alot of stutters during the flight, which i never got before!, So seems to be depend on what system, and specs you have that makes this work for some guy's! But for me it's a No NO!! Oh well, MIKE

Share this post


Link to post
Share on other sites

FS crashed on me 3 times today since I have changed this. I never have any problems with FS crashing. Thanks anyways.

Share this post


Link to post
Share on other sites

I'd go eay on him Rob & Heavy,..note how he uses the words "I" and "my", not 'you' and 'yours'Paul

http://www.strontiumdog.plus.com/Fortress.gifVoted Best Virtual Airline of 2002 and Best CEO of 2002 by participants in the BIG VA Vote organized by FSPILOT.comVANF "Best" New Virtual Airline AwardOfficially licenced by British Airways plc for use of name and logohttp://www.strontiumdog.plus.com/saint_georgex1.gif

Share this post


Link to post
Share on other sites

Good points about listing system specs along with these "tweaks" though. It's similar to the fs2002.cfg editing, etc. There are too many different systems out there to consider. What works for one may be negative to another. For what it's worth, turning AGP texturing off seemed to have a positive effect on mine:Pentium 4 2.26 ghz512 RDRAMGeForce TI-4200Soundblaster PCI 512Win XP Home

Share this post


Link to post
Share on other sites

Yeah - absolutely agree Edam, and it's nice for someone to point out something else we could try to improve our hobby!Cheers,Paul

http://www.strontiumdog.plus.com/Fortress.gifVoted Best Virtual Airline of 2002 and Best CEO of 2002 by participants in the BIG VA Vote organized by FSPILOT.comVANF "Best" New Virtual Airline AwardOfficially licenced by British Airways plc for use of name and logohttp://www.strontiumdog.plus.com/saint_georgex1.gif

Share this post


Link to post
Share on other sites

As I have stated in this forum before, disabling AGP Texturing increased my framerates and reduced, if not eliminated, stuttering.Graphics actually look a little better too.Dell Dimension PIII, 1 GHz512 Mb RDRAMATI Radeon 32 DDR videoATI Catalyst video drivers v 2.3SB Live! soundWindows XP Pro w/SP1MSFS2002 Pro

Share this post


Link to post
Share on other sites

Paul, I notice (how could I not?) that you a member of British Airways Virtual...is that the one that has a waiting list to join?At the moment, the VA that I belong to is undergoing some changes that may take it a few months to get back up to speed.

Share this post


Link to post
Share on other sites

Yes - Edam, it does have a waiting list. Capped at 1,000 members I believe, but since I'm no.78 I long ago gave up any interest in new additions.edit: and at this point I'd like to point out the last line of my signature to other posters (smug smug)Cheers,Paul

http://www.strontiumdog.plus.com/Fortress.gifVoted Best Virtual Airline of 2002 and Best CEO of 2002 by participants in the BIG VA Vote organized by FSPILOT.comVANF "Best" New Virtual Airline AwardOfficially licenced by British Airways plc for use of name and logohttp://www.strontiumdog.plus.com/saint_georgex1.gif

Share this post


Link to post
Share on other sites

>edit: and at this point I'd like to point out the last line >of my signature to other posters (smug smug) As Maude (A character on an American comedy show) used to say, "God will get you for that."

Share this post


Link to post
Share on other sites

Heh! Since I'm an atheist, God can do what he likes and it won't worry me....Come Join The Atheists: A Non-Prophet OrganisationCheers,Paul

Share this post


Link to post
Share on other sites

HI Paul,I'm always easy on Dennis :) I was only pointing out the TITLE in his post which said "whatever YOU do disable AGP texturing...." making it a definitive statement for other users when in fact that advice is clearly not working for all of them. OK?Cheers,Rob

Share this post


Link to post
Share on other sites

I have tried it myself in the past and there is no difference on my machine.P4 1.9 512 PC800 SRAMGF2 MX 400 soon to be GF4 Ti4200Driver 30.82Apeture @ 64 Meg

Share this post


Link to post
Share on other sites

I've been using FS w/out AGP since 3 months ago!!! PCI mode makes a more fluid system in my case, in all sense, more FPS and less sttuters.. PIV, 1.6, 256R, TNT2 M64....Regards,Gabriel.

Share this post


Link to post
Share on other sites

Dennis,If this is the case, there are probably technical reasons for it:(1) Your system (main memory) RAM is slow RAM, and by disabling AGP you are forcing your machine to NEVER place textures on the other side of the bus. By forcing things to only reside on your video card, you are guaranteeing fastest texture access (though you are also minimizing your maximum texture memory to whatever is on-board your video card, which may reduce which scenery or aircraft add-ons you'll be able to reasonably use). Low risk if you are running a 64MB or 128MB video card; large risk on 32MB card, huge risk on 16MB card.(2) Your video card is not correctly configured for AGP. This sometimes is the case on older cards which only support 2X AGP, being placed in a 4X AGP slot in 4X mode. Again, your asking your card to do something it really shouldn't try, and by turning off AGP texturing your are reducing this problem. This particular configuration issue, though, should cause larger issues.(3) You have your AGP aperature (in BIOS) set incorrectly for your system configuration. Sometimes it seems like DirectX loves to run to AGP memory as soon as it can, and if you have limited system RAM then you are immediately borrowing critical resources from the Windows OS that could otherwise be used by running applications. If you have your AGP aperature set too large (>128MB), you could simply be starving the system to death. Again, by disabling AGP textures, you are ensuring that memory would never be used, and Windows may be reclaiming that memory for system use.The latter two issues are easy to solve; simply check your motherboard and BIOS configurations, and you should be able to safely re-enable AGP. The first issue is more serious, and would either require faster SDRAM/DDRAM, or a motherboard with a faster front side bus (FSB).Rich

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this