Sign in to follow this  
Guest dswo

ActiveEnvironment with WideFS

Recommended Posts

I've had ASV for about half a day. I can get it to generate weather and it's beautiful. But I'm eager to get AE working.Trick is ASV is running on a WideFS client. Here's what I've done so far:1. Share my Microsoft Games folder with client. Client can read, modify, write. Tested this on client computer using Windows Explorer.2. On client, map Microsoft Games folder to S: (for Simulator).3. On client computer running ASV, I made a copy of my ASV.ini file. Just in case. Then I edited the following line in ASV.ini to read:FS9Path = S:Flight Simulator 9Ok, I think, this should tell AE where to put the texture files. But when I try to Submit a texture set in AE, I receive the following error message: "Error on Submit..FS FOlder Target: S:Flight Simulator 9"What am I doing wrong, and how can I fix it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,Something wrong writing to that folder... make sure your permissions are correct and you are allowing create/modify/write access?

Share this post


Link to post
Share on other sites

Hi,I am not sure you're step 2 is right.This is what I have done:fs9 pc: Give the PC a name, I use ADAM Share Flight Simulator 9 folder over the local area network (with all rights) and give it a name, e.g. FS9second pc: Give the PC a name, I use EDEN Share the ASV folder (the top most) over the network with all rights and give it a name, e.g. ASV On the second pc you can now refer to FS9 as ADAMFS9and on the FS( pc you can refer to ASV as EDENASVThat should workRegards,Nicowww.nicokaan.nl1704.png

Share this post


Link to post
Share on other sites

Thanks for working with me on this.1. I have checked -- and tested -- all permissions for FS9 folder and subfolders.2. I have tried Nico's method of addressing Server from Client.Results:I HAVE successfully replaced textures several times. Maybe 5% of the times I have pressed the submit button. Don't know if this was because I switched to Nico's method, or just because I got lucky.All of this is with FS9 off, and no applications (including Windows Explorer) viewing the FS9 folders. I don't see any rhyme or reason to the successes. What they tell me, though, is that this isn't a straightforward problem of insufficient user priveleges for the Client.A couple more data points that may or may not point the way to a solution:1. No matter how many times I turn off the "Read only" attribute on the Textures folder, it still has the grey box (not the check box -- the grey box).2. But -- none of the files in the Textures folder are actually "Read only." And since I can occasionally replace textures, I don't see how the folder properties could be the problem.

Share this post


Link to post
Share on other sites

Hi David>1. No matter how many times I turn off the "Read only" attribute on >the Textures folder, it still has the grey box (not the check box -- >the grey box).I tried that also but found its not important, the folder can stay read-only it will still be written to, just ensure the folder is shared.CheersTony

Share this post


Link to post
Share on other sites

To the original poster try browsing to your FS2004 folder as a "folder" and not a mapped drive.I had similar problem earlier today. The mapped drive to FS9 folder was required for install and actve radar set up but I had to browse to the sim PC local drive/program files/microsoft games/Flight Simulator 9 to allow the program to work correctly......... otherewise I kept getting the not recognised messages.Once found, goto options and resave.HTH,Martin/TDBscotlandEDIT: Just to add, the only way I can access this folder direct from the client, as a "folder", is through "My Network" but the theory is the same......... if I browse to it I cant get passed "program files" despite all sharing being enabled. Can access the folder no problem as a mapped drive but this results in the error messages.Confused ?........ I am :)

Share this post


Link to post
Share on other sites

I found the problem. I apologize for posting it in a couple places, but I spent several hours tracking this down and I'd like to spare someone else from the same fate: This won't solve everyone's problems, but it fixed mine and maybe it will help someone else. Please note: my description assumes that you understand how to use Windows Explorer, that you know what things like * mean in the context of filenames, and that you already have WideFS up and running the rest of ASV successfully. If you don't know what you're doing, don't do it. In my asv.ini file (on my WideFS client computer), I had pointed ASV to the correct path for FS on (on my WideFS server -- the one that actually runs Flight Simulator). Yet when I tried to "Submit" new textures in Active Environment Configuration, I got a very stubborn "Error on Submit. Target: computernamefs." This made it sound like there was a problem with the path, or with setting the permissions correctly for the FS9 folder on my server.I pursued variations on this for several hours. Luckily, while I was testing, I noticed that I could successfully submit all textures EXCEPT cirrus. But once I tried to submit a Cirrus texture, not only would it not work, but other textures wouldn't work either, until I closed ASV altogether and restarted.Following up on this discovery, I started playing around with copying cirrus*.bmp files from my client to my server (using Windows Explorer). After a few successful copies, it would hang up on one of the files -- "Check to see if disk is write-protected or file is in use" or something similar was the error message I got. Some of these were earlier Chris Willis textures, so I thought, "Maybe there's a funky permissions thing." I first tried to fix this by overwriting all the cirrus textures from a backup I had made last year (prior to installing any new textures). No good -- same problem. So, I deleted them: all the cirrus textures in my FS9 (server) texture directory. Once again, I tried copying cirrus*.bmp from my client (which also has an FS9 installation). This time, success. I fire up ASV, open the AE panel, and start updating Cirrus. Everything works! I can now submit new textures from AE to my heart's content, and ASV's ICS feature works too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this